[Ubuntu] multi ecran et configuration [Fermé]

Signaler
Messages postés
199
Date d'inscription
lundi 21 mars 2005
Statut
Membre
Dernière intervention
17 octobre 2020
-
Messages postés
29348
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
21 octobre 2020
-
Bonjour,

je viens de réinstaller Ubuntu LTS Hardy (Voir la config en bas ).
Je cherche a mettre en place le multi ecran. Apres diverses tentatives, le resultat n'est pas concluant.
Le second écran ne s'allume pas. Dans la fenetre de parametres de resolution d'ecrans, la detection d'un deuxieme ecran ne donne rien.

Dans xorg.conf, les deux ecrans y appaissent. (A verifier, j'en suis pas sur)
Pour le moment, je n'ai encore rien tenter de nouveau. Je me suis juste contenté de lire la doc de ubuntu sur le multi-ecran et sur l'installation de vnvidia avec ubuntu.

Je précise que j'ai une carte grafique avec nvidia ( GeForce FX 5600XT/AGP/SSE/3DNOW ) d'installé.
L'ecran principal (Multiscan de sony) est braché sur la catre graphique VGA ( la version doit-etre "Zotac GeForce 5200" ), et le deuxieme ecran (iiyama LS740UT) est relié a la carte mére.

je donne pour information supplementaire cela:

je l'ai obtenu avec la commande lspci | grep VGA.
"01:00.0 VGA compatible controller: nVidia Corporation NV31 [GeForce FX 5600XT] (rev a1)"

avec la commande suivante : glxinfo | grep OpenGL j'obtiens aussi cela :
"OpenGL vendor string: NVIDIA Corporation
OpenGL renderer string: GeForce FX 5600XT/AGP/SSE/3DNOW!
OpenGL version string: 2.1.2 NVIDIA 169.12
OpenGL extensions: "

Une personne qui s'y connait, pourrait-elle m'aider ? ou simplement me donner une procedure, même sommaire, avant de me lancer.

Je me demande aussi si il n'y aurait pas un conflit d'ecran.
On m'a suggeré de desactiver la carte graphique integrée de la carte mére dans le BIOS. Mais , dans ce BIOS, je ne trouve pas l'option pour le faire. De plus, le BIOS semble ne plus etre le meme qu'avec Windows d'installé. Mon PC est un Compaq. Et, Ubuntu est le seul OS sur le PC.

J'espere que vous pourrez m'aider, même un peu,

Merci

A bientot

2 réponses

Messages postés
29348
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
21 octobre 2020
6 948
Pour une carte nvidia il suffit d'installer nvidia-glx (la bonne version) et nvidia-settings. Ensuite il suffit de lancer nvidia-settings.
http://doc.ubuntu-fr.org/nvidia

Dans "X server display configuration", fais au besoin un detect display afin que tout les écrans apparaissent sur le chemin. Clique sur chaque écran et règle successivement leur résolution. Ensuite, à toi de voir si tu les mets en clone, en right of etc... selon que tu souhaites avoir un écran étendu ou le même affichage sur tous les écrans.

Soit dit en passant, je ne suis pas persuadée que mettre une vieille LTS soit le choix le plus stratégique (surtout que la dernière, la 10.04, est une LTS).

Bonne chance
Messages postés
199
Date d'inscription
lundi 21 mars 2005
Statut
Membre
Dernière intervention
17 octobre 2020
45
En effet mamiemando, et merci pour cette remarque... Je viens donc de changer de distribution LTS pour la dernière 10.04 (Lucid Link).

Ceci dit, j'ai suivi tes conseils. Ma version de nvidia est la 173. Cependant, lorsque je clique sur "detect display", il ne se passe rien.
De plus etrangement, xrandr ne semble pas-etre sugéré par ma carte. Ce qui est surprennant, car avant cela ne pa=osé pas de probleme.

Bref, j'ai pensé faire comme conseillé sur le site de ubuntu. C'est a dire : fusionner les deux configurations pour chacune des cartes graphiques.

Toute fois, je n'y suis pas parvenu. IL doit-y avoir des règles, que je ne connais pas malheureusement, pour modifier le xorg.conf, en multi-écran. Je sais qu'il faut ajouter les sections suivantes "device", "monitor" et "screen". Mais comment je dois procèder ?

Je mets plus bas le contenu de xorg.conf, ainsi que celui genéré lorsque que j'etais encore avec la version LTS 9.04 .

Si certain d'entre vous pouvez me conseiller, sur la démarche a suivre, je suis tout ouïe.

De mon coté, je continue a chercher pourquoi ma seconde carte S3 , ne me permet toujours pas de faire apparaitre l'extension de bureau.


Mon xor.conf (actuel )
# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig:  version 1.0  (buildmeister@builder75)  Sun Nov  8 21:50:38 PST 2009
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings:  version 1.0  (buildd@palmer)  Fri Apr  9 10:35:18 UTC 2010

Section "Monitor"
	Identifier     "Monitor0"
	VendorName     "Unknown"
	ModelName      "Iiyama LS704U"
	HorizSync       30.0 - 70.0
	VertRefresh     50.0 - 160.0
	Option         "DPMS"
	# HorizSync source: edid, VertRefresh source: edid
EndSection

Section "Screen"
	Identifier     "Screen0"
	Device         "Device0"
	Monitor        "Monitor0"
	Option         "TwinView" "0"
	Option         "TwinViewXineramaInfoOrder" "CRT-0"
	Option         "metamodes" "1024x768_60 +0+0; nvidia-auto-select +0+0; 1024x768 +0+0"
	DefaultDepth	24
	Option	"AddARGBGLXVisuals"	"True"
	SubSection "Display"
		Depth       24
	EndSubSection
EndSection

Section "Module"
	Load	"glx"
EndSection

Section "InputDevice"
	Identifier     "Mouse0"
	Driver         "mouse"
	Option         "Protocol" "auto"
	Option         "Device" "/dev/psaux"
	Option         "Emulate3Buttons" "no"
	Option         "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
	Identifier     "Keyboard0"
	Driver         "kbd"
	# generated from default
EndSection

Section "ServerLayout"
	Identifier     "Layout0"
	Screen      0  "Screen0" 0 0
	InputDevice    "Keyboard0" "CoreKeyboard"
	InputDevice    "Mouse0" "CorePointer"
	Option         "Xinerama" "0"
EndSection

Section "Device"
	Identifier     "Device0"
	VendorName     "NVIDIA Corporation"
	BoardName      "GeForce FX 5600XT"
	Driver	"nvidia"
	Option	"NoLogo"	"True"
EndSection


Xorg.conf pour la seconde carte graphique S3 virge
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by failsafeDexconf, using
# values from the debconf database and some overrides to use vesa mode.
#
# You should use dexconf or another such tool for creating a "real" xorg.conf
# For example:
#   sudo dpkg-reconfigure -phigh xserver-xorg
Section "InputDevice"
	Identifier	"Generic Keyboard"
	Driver		"kbd"
	Option		"XkbRules"	"xorg"
	Option		"XkbModel"	"pc105"
	Option		"XkbLayout"	"us"
EndSection

Section "InputDevice"
	Identifier	"Configured Mouse"
	Driver		"mouse"
EndSection

Section "Device"
	Identifier	"Configured Video Device"
	Driver		"vesa"
EndSection

Section "Monitor"
	Identifier	"Configured Monitor"
EndSection

Section "Screen"
	Identifier	"Default Screen"
	Device		"Configured Video Device"
	Monitor		"Configured Monitor"
	SubSection "Display"
		Modes   "800x600"
	EndSubSection
EndSection

Section "ServerLayout"
	Identifier	"Default Layout"
	Screen		"Default Screen"
EndSection

Merci a tous...
Messages postés
29348
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
21 octobre 2020
6 948
Pour commencer fini de migrer vers 10.04 si ce n'est pas déjà fait. Aujourd'hui on est en 195. Si la carte est récente seuls les derniers drivers fonctionneront correctement. Pour qu'il soit chargé il faut régénérer /etc/X11/xorg.conf grâce à nvidia-xconfig et relancer le mode graphique avec un :

sudo service gdm restart


Dans ta session graphique :

(mando@aldur) (~) $ glxinfo | grep -i render
direct rendering: Yes
OpenGL renderer string: GeForce 6600 GT/AGP/SSE/3DNOW!
    GL_NVX_conditional_render, GL_SGIS_generate_mipmap, GL_SGIS_texture_lod,


Personnellement je suis sous debian et j'ai installé les drivers avec module-assistant. Tu as les différentes installations (hormis les package ubuntu) décrites ici :
https://www.commentcamarche.net/faq/3456-installer-drivers-nvidia-sous-debian

Bonne chance