Additionner 2 cellules si pas vides...

Résolu/Fermé
alexandra41120 - 19 juin 2010 à 20:14
 alexandra41120 - 19 juin 2010 à 23:11
Bonjour,

Je dois faire un cumul de prime mais il faut que j'additionne 2 montants et que je divise par 2 pour avoir un cumul de 60€ maxi.
Le problème c'est que mes 2 cellules ne sont pas toujours toutes les 2 remplies et si 1 seulement est remplie alors je ne dois pas diviser par 2.
je ne sais pas si c'est clair là....

Donc si j'ai 60€ en cellule A et 60€ en cellule B : il faut 60€ au cumul (A+B/2)
mais si j'ai 60€ en cellule A et rien (vide) en cellule B : il faut 60€ au cumul (sans diviser /2)

Comment fait-on cela ?
Merci de votre aide.
Alexandra



A voir également:

4 réponses

dobo69 Messages postés 1584 Date d'inscription vendredi 24 juillet 2009 Statut Membre Dernière intervention 30 juin 2013 797
19 juin 2010 à 21:14
bonjour,
par exemple :

=SI(NBVAL(A1;B1)>1;(A1+B1)/2;A1+B1)
pour les deux premières cellules des colonnes A et B. Formule à"étirer" vers le bas.
0
Mytå Messages postés 2969 Date d'inscription mardi 20 janvier 2009 Statut Contributeur Dernière intervention 20 décembre 2016 926
19 juin 2010 à 21:39
Salut le forum

Si tu veux limiter la valeur à 60€

=SI(NBVAL(A1;B1)>0;MIN((A1+B1)/NBVAL(A1;B1);60);0)

Mytå
0
alexandra41120
19 juin 2010 à 21:47
Le problème c'est que en fait ma cellule n'est pas vraiement vide il y a 0€ dedans du coup ça marche pas est ça me met VALEUR car mon 0€ sort d'une formule bien sure...
0
Mytå Messages postés 2969 Date d'inscription mardi 20 janvier 2009 Statut Contributeur Dernière intervention 20 décembre 2016 926
Modifié par Mytå le 19/06/2010 à 22:14
Re le forum

Tu avais bien dis :
"mais si j'ai 60€ en cellule A et rien (vide) en cellule B : il faut 60€ au cumul (sans diviser /2)"

Essaye ceci à la place :

=SI(NB.SI(A1:B1;">0");MIN((A1+B1)/NB.SI(A1:B1;">0");60);0)

Mytå
Versions installées [MsProject 2003(FR), Excel 2003-2007(FR)]
0
alexandra41120
19 juin 2010 à 23:09
Cette solution fonctionne avec 2 cellules super.
Seulement j'ai aussi un autre calcul identique avec 5 cellules qui doivent aussi faire 60€ avec certaines qui sont rempli et d'autres vides. J'ai copié cette formule et essayé de l'adapter mais ça marche pas cette fois... Au secours
Alex
0
alexandra41120
19 juin 2010 à 23:11
Ha si c'est bon ça marche..... SUPER MERCI BEAUCOUP POUR VOTRE AIDE
0
dobo69 Messages postés 1584 Date d'inscription vendredi 24 juillet 2009 Statut Membre Dernière intervention 30 juin 2013 797
19 juin 2010 à 22:55
ou encore :

=SI(OU(A1=0;A2=0);A1+A2;(A1+A2)/2)
0