Fonction SI n'affiche pas le résultat

[Résolu/Fermé]
Signaler
-
Messages postés
54860
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
21 octobre 2021
-
Bonjour,
j'essaie d'utiliser la fonction SI pour voir si j'ai des doublons dans une liste de noms (très longue liste) or, lorsque je valide ma formule, elle s'affiche dans la cellule telle que :
=SI(C1=C2;oui;) Cette formule est-elle "anti-texte" ? ou y-a-t-il un autre problème ?

Au pire, y-a-t-il un autre moyen de repérer des doublons ?
merci pour votre aide.


2 réponses

Messages postés
54860
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
21 octobre 2021
16 769
Bonjour.

Il semblerait y avoir plusieurs problèmes :
* 1) Quand Excel lit =SI(C1=C2;oui;) il traduit "si le contenu de la cellule C1 est égal à celui de la cellule C2 alors j'affiche le contenu de la cellule dont le nom est oui, sinon j'affiche zéro" ; si tu veux afficher le mot oui, il faut le mettre entre guillemets dans la formule =SI(C1=C2;"oui";).
* 2) Si c'est exactement cette formule que tu recopies vers le bas, elle deviendra successivement =SI(C2=C3;oui;) =SI(C3=C4;oui;) =SI(C3=C4;oui;) ce qui veut dire que tu compares toujours 2 cellules voisines ; cela suppose qu'au préalable tu auras fait un tri alphabétique de ta liste ... et tu ne peux pas savoir si un mot se répète 2 ou 3 fois. La fonction SOMMEPROD serait plus appropriée que SI.
* 3) Oui, il y a un autre moyen : Dans les outils de données, il y a la commande "Supprimer les doublons" qui non seulement repère tous les doublons, même dans une liste non triée, mais en plus les supprime instantanément.
Un grand merci à Raymond, il manquait en effet les guillemets ; j'ai quand même essayé les autres solutions : la fonction SOMMEPROD n'a pas l'air approprié, et je n'ai pas trouvé de commande "supprimer les doublons" (où se cache-t-elle ?)
Bonne continuation dans votre nouvelle activité et attention à l'association "soleil + tipunch"
Messages postés
54860
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
21 octobre 2021
16 769
Salut CMUSHI .

Tu n'as pas précisé ta version d'Excel ; c'est pourquoi je ne t'ai pas indiqué où il fallait chercher la suppression des doublons.
Dans la version 2007, c'est dans l'onglet "Données".
Dans la version 2003, ça doit être quelque part dans Outils ou Données.

Tu as raison, SOMMEPROD n'est pas la meilleure fonction ici ; il vaut mieux écrire en B1 la formule =NB.SI($A$1:$A$9999;A1) à recopier vers le bas ; on obtient le nombre d'occurrences de chaque élément de la liste.

Pour le ti-punch, t'inquiète : J'assume !
Bonjour Raymond,
J'ai malheureusement la version 2008, et je dis malheureusement car je la trouve beaucoup moins performante que les 2 précédentes, sur lesquels je ne rencontrais pas ce genre d'ennuis.
Enfin, à vouloir toujours faire plus, je crois qu'ils en oublient un peu en route...
En tout cas merci pour cette nouvelle formule que je vais essayer de ce pas.
Bonne journée,
Messages postés
54860
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
21 octobre 2021
16 769
En fait, la version 2008 est "spéciale Mac" ...