Lecteur flash pas compatible

Résolu/Fermé
mart03 Messages postés 279 Date d'inscription vendredi 16 mai 2008 Statut Membre Dernière intervention 5 juin 2012 - 23 mai 2010 à 20:05
mart03 Messages postés 279 Date d'inscription vendredi 16 mai 2008 Statut Membre Dernière intervention 5 juin 2012 - 23 mai 2010 à 21:34
Bonjour,

J'ai un problème concernant plusieurs lecteurs flash, ils marchent très bien sur Firefox mais impossible de les faire fonctionner sur internet explorer 8.
Problème de compatibilité ??
Avez-vous un solution.. ?
Merci


A voir également:

5 réponses

RAD ZONE Messages postés 5226 Date d'inscription samedi 20 janvier 2007 Statut Contributeur Dernière intervention 1 juin 2024 1 355
Modifié par RAD ZONE le 23/05/2010 à 20:39
Salut

cela vient de ton code d insertion pas du player !!

voila un exemple de code d insertion valide pour un .swf et qui passe tout navigateur

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="800" height="600" id="Flash"> 
    <param name="movie" value="URL DE TON SWF.swf" /> 
    <!--[if !IE]>--> 
    <object type="application/x-shockwave-flash" data="URL DE TON SWF.swf" width="800" height="600"> 
    <!--<![endif]--> 
     <a href="https://get.adobe.com/flashplayer/"> 
      <img src="https://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" /> 
     </a> 
    <!--[if !IE]>--> 
    </object> 
    <!--<![endif]--> 
   </object>


A+

? La plus grande erreur que puisse faire un homme est d'avoir peur d'en faire une. ?
0
mart03 Messages postés 279 Date d'inscription vendredi 16 mai 2008 Statut Membre Dernière intervention 5 juin 2012 21
23 mai 2010 à 20:54
Je te remercie !!!!!!!!
0
mart03 Messages postés 279 Date d'inscription vendredi 16 mai 2008 Statut Membre Dernière intervention 5 juin 2012 21
23 mai 2010 à 21:18
Heu en fait sa marche mais pas trop voici mon code de base :

<object type="application/x-shockwave-flash" data="http://xxxxxx.com" width="100%" height="364px" id="player" style="visibility: visible; "><param name="allowFullScreen" value="true"><param name="flashvars" value="stream=http://xxxxxx.com"></object>

il y a une différence avec l'autre :

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="800" height="600" id="Flash">
<param name="movie" value="URL DE TON SWF.swf" />
<!--[if !IE]>-->
<object type="application/x-shockwave-flash" data="URL DE TON SWF.swf" width="800" height="600">
<!--<![endif]-->
<a href="https://get.adobe.com/flashplayer/">
<img src="https://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" />
</a>
<!--[if !IE]>-->
</object>
<!--<![endif]-->
</object>

même en ayant modifier les liens tout il m'affiche toujours rien...
Cordialement
0
RAD ZONE Messages postés 5226 Date d'inscription samedi 20 janvier 2007 Statut Contributeur Dernière intervention 1 juin 2024 1 355
23 mai 2010 à 21:26
c est normal , c est un code' pour un swf classic !

pour ton player ca vas plutot etre comme ca !

avec les flashvars pour le player

<object classid="clsid:D27CDB6E-AE6D-11cf-96B8-444553540000" width="800" height="600" id="player">
				<param name="movie" value="http://xxxxxx.com" />
				<param name="flashvars" value="stream=http://xxxxxx.com" />
				<!--[if !IE]>-->
				<object type="application/x-shockwave-flash" data="http://xxxxxx.com" width="800" height="600">
					<param name="flashvars" value="stream=http://xxxxxx.com" />
				<!--<![endif]-->
					<a href="https://get.adobe.com/flashplayer/">
						<img src="https://www.adobe.com/images/shared/download_buttons/get_flash_player.gif" alt="Get Adobe Flash player" />
					</a>
				<!--[if !IE]>-->
				</object>
				<!--<![endif]-->
			</object>


A+
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
mart03 Messages postés 279 Date d'inscription vendredi 16 mai 2008 Statut Membre Dernière intervention 5 juin 2012 21
23 mai 2010 à 21:34
Merci beaucoup sa marche impec ;)
0