Gimp-2.6.8 Hardy [Résolu/Fermé]

Signaler
Messages postés
106
Date d'inscription
mardi 17 juin 2008
Statut
Membre
Dernière intervention
3 octobre 2016
-
Messages postés
106
Date d'inscription
mardi 17 juin 2008
Statut
Membre
Dernière intervention
3 octobre 2016
-
Qui arrive à installer Gimp-2.6.8 sur Hardy ? (:-D)
Pas moi... (:'-(

3 réponses

Messages postés
8903
Date d'inscription
mercredi 5 décembre 2007
Statut
Contributeur
Dernière intervention
27 octobre 2015
1 149
Tu n'as qu'à installer la lib babl :

sudo aptitude install libbabl-0.0-0-dev


Ou tu peux compiler Babl ;)

https://gitlab.gnome.org/GNOME/babl
Intel Q6600 Debian Lenny//Gentoo
Sous Linux, 99% des bugs se situent entre le clavier et la chaise de bureau...
Messages postés
106
Date d'inscription
mardi 17 juin 2008
Statut
Membre
Dernière intervention
3 octobre 2016
5
Merci pour ta réponse,

j'ai essayé par aptitude, avec la ligne que tu m'as proposé,
pas d'erreur, je relance donc un
./cofigure
dans gimp-2.6.8 :
blablabla  
checking for iso-codes... yes  
checking for BABL... configure: error: Package requirements (babl >= 0.0.22) were not met:  

No package 'babl' found  

Consider adjusting the PKG_CONFIG_PATH environment variable if you  
installed software in a non-standard prefix.  

Alternatively, you may set the environment variables BABL_CFLAGS  
and BABL_LIBS to avoid the need to call pkg-config.  
See the pkg-config man page for more details.


Alors, je jette un oeil à Synaptique :
"Paquet Installé : libbabl-0.0-0
Version du Paquet : 0.0.22-1 (la dernière version quoi...)"

voilà...
J'en ai apparament besoin pour gimp,
et après le
./configure
à la compilation de celui que j'ai tétéléchargé :
make


make  
make  all-recursive  
make[1]: entrant dans le répertoire « /hometanguy/babl-0.0.22 »  
Making all in babl  
make[2]: entrant dans le répertoire « /home/tanguy/babl-0.0.22/babl »  
Making all in base  
make[3]: entrant dans le répertoire « /home/tanguy/babl-0.0.22/babl/base »  
if /bin/bash ../../libtool --tag=CC --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../.. -I../../babl    -g -O2 -Wall -Wdeclaration-after-statement -Wmissing-prototypes -Wmissing-declarations -Winit-self -Wpointer-arith -Wold-style-definition -MT formats.lo -MD -MP -MF ".deps/formats.Tpo" -c -o formats.lo formats.c; \  
 then mv -f ".deps/formats.Tpo" ".deps/formats.Plo"; else rm -f ".deps/formats.Tpo"; exit 1; fi  
rm: cannot remove '.libs/formats.o': Permission denied  
rm: cannot remove '.libs/formats.o': Permission denied  
 gcc -DHAVE_CONFIG_H -I. -I. -I../.. -I../.. -I../../babl -g -O2 -Wall -Wdeclaration-after-statement -Wmissing-prototypes -Wmissing-declarations -Winit-self -Wpointer-arith -Wold-style-definition -MT formats.lo -MD -MP -MF .deps/formats.Tpo -c formats.c  -fPIC -DPIC -o .libs/formats.o  
Assembler messages:  
Fatal error: can't create .libs/formats.o: Permission denied  
make[3]: *** [formats.lo] Erreur 1  
make[3]: quittant le répertoire « /home/tanguy/babl-0.0.22/babl/base »  
make[2]: *** [all-recursive] Erreur 1  
make[2]: quittant le répertoire « /home/tanguy/babl-0.0.22/babl »  
make[1]: *** [all-recursive] Erreur 1  
make[1]: quittant le répertoire « /home/tanguy/babl-0.0.22 »  
make: *** [all] Erreur 2  


ALORS...
Venant de m'appercevoir du
Fatal error: can't create .libs/formats.o: Permission denied
, je viens de tout refaire en ROOT (sudo -i)...

J'ai l'impression que ça a marché, donc, je me mets en ROOT aussi, tant qu'à faire, sur l'onglet d'à côté, et c'est parti...
blablagimp-2.6.8#./configure


ET MAINTENANT ==> Manque GEGL V0.0.18min.
(qui lui-même demande GLIB V2.14min.)

Allé... j'espère qu'il y en a pas 36 à faire comme ça non plu, ou bien qu'ils soient pas trop pénibles à chopper...

à au prochain souci, merci (:-D
Messages postés
8903
Date d'inscription
mercredi 5 décembre 2007
Statut
Contributeur
Dernière intervention
27 octobre 2015
1 149
C'est la magie de la compilation !!! ^^
Messages postés
106
Date d'inscription
mardi 17 juin 2008
Statut
Membre
Dernière intervention
3 octobre 2016
5
Ah... Si t'es calé en linux, je te redirige vers un post amusant,
figure toi que j'ai des partitions sur mon HDD interne, mais que GParted me détecte /dev/sda comme étant vierge... (:-D

https://forums.commentcamarche.net/forum/affich-17683839-sda-vierge-gparted#p17688143

Quand à Gimp, j'ai installé GLIB, j'ai lancé le ./configure de GEGL, et quand je lance le make (de GEGL), là il me fait ne peut rien faire pour "all-am"

Bon... Allé... Si je veux, je l'ai sur clé de boot usb, on peut l'avoir en VM, je jette l'éponge,
si quelqu'un est intéressé bien sûr, toutes suggestions sont les bienvenues :-)