Wifi sur ubuntu 9.10 [Résolu/Fermé]

Signaler
Messages postés
598
Date d'inscription
mardi 9 février 2010
Statut
Membre
Dernière intervention
30 juin 2015
-
Messages postés
29229
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
11 mai 2020
-
Bonjour,
j'ai sur un portable toshiba satellite ubuntu 9.10
j'ai essayer de le connecter à mon réseaux sans fil mais quand je rente la clé wep, je ne peu pas me connecter, le bouton connecter est pas cliquable.
Comment faire pour mi connecter?

3 réponses

Messages postés
29229
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
11 mai 2020
6 859
Dans un premier temps il faudrait s'assurer que la carte est correctement reconnue, détecte ton réseau sans fil, et que tu parviens à la configurer avec iwconfig.

Ouvre un terminal :
http://doc.ubuntu-fr.org/terminal#ou_est-il

Dedans, tape la commande :

/sbin/iwconfig


(et copie-colle le résultat dans ton prochain message). Supposons que ta carte s'appelle wlan0. Tape ensuite :

/sbin/iwlist wlan0 scan


... et dis moi si ton réseau sans fil apparaît. Si oui, en supposans qu'il s'appelle MonReseauSansFil et que la clé WEP soit 123456798ABCDEF tape :

sudo iwconfig essid MonReseauSansFil key 123456798ABCDEF   
sudo dhclient wlan0


Si la commande dhclient se termine par un DHCPACK, c'est gagné tu es connecté. Il ne reste plus qu'à automatiser le tout. Actuellement tu tentes de faire fonctionner network-manager mais manifestement ce n'est pas concluant. Première possibilité, tu installes wicd à la place :
http://doc.ubuntu-fr.org/wicd

Deuxième solution, tu configures le wifi au démarrage d'ubuntu en modifiant /etc/network/interfaces. Pour cela tape dans ton terminal :

gksudo gedit /etc/network/interfaces &


Au passage, on est simplement en train de faire ce qui est indiqué ici (dans le tutoriel, la carte s'appelle eth1, on utilise l'éditeur nano au lieu de l'éditeur gedit, et comme l'éditeur nano est en mode texte, on passe par sudo au lieu de gksudo... mais concrètement on se contente de modifier le fichier de configuration avec des droits administrateur (root)) :
https://www.commentcamarche.net/faq/11210-configurer-le-wifi-sous-linux#en-wep

Si je reprends les notations données au début du message, cela reviendrait à avoir un truc du genre pour wlan0 :

auto wlan0   
iface wlan0 inet dhcp   
    wireless-essid MonReseauSansFil   
    wireless-key 1234567890ABCDEF


Enfin il reste plus qu'à réinitialiser la carte wifi ou à redémarrer :

sudo ifconfig wlan0 down   
sudo ifup wlan0


Bonne chance
Messages postés
598
Date d'inscription
mardi 9 février 2010
Statut
Membre
Dernière intervention
30 juin 2015
82
Finalement, c'était simple comme problème, je n'ai eu qu'à copier/coller les information de mon réseau et ça la marcher, c'est pourtant bizarre, car j'avais écrit les même information... mais au moin ca marche.
Merci quand même pour les informations.
Messages postés
29229
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
11 mai 2020
6 859
Sans doute une faute de frappe ;-) L'essentiel c'est que maintenant tout marche correctement.

Bonne continuation