Live USB XP [Résolu/Fermé]

Signaler
Messages postés
43
Date d'inscription
vendredi 5 août 2005
Statut
Membre
Dernière intervention
11 mai 2010
-
 bouctin -
Bonsoir,

Je cherche désespérément un moyen de booter XP à partir d'une clé USB. Attention je précise, je ne cherche pas à créer un clé USB d'installation d'XP mais une clé qui démarre XP comme pour un LIVE CD.

J'ai essayé pas mal de choses mais rien ne marche =( J'ai une clé corsair de 32Go et une clé kingston de 8Go.

Merci de votre aide et bonne continuation à tous.

33 réponses

Messages postés
11213
Date d'inscription
jeudi 18 janvier 2007
Statut
Modérateur
Dernière intervention
10 octobre 2019
1 894
Tu as peut-être besoin de copier le contenu de ton Cd sur ton DD...
Essayes de créer un Live CD pour voir si le problème vient de la compilation de l'iso ou de la création du Live USB (peu probable mais on ne sait jamais).
2
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Messages postés
11213
Date d'inscription
jeudi 18 janvier 2007
Statut
Modérateur
Dernière intervention
10 octobre 2019
1 894
Bonjour,
Pourquoi souhaites-tu un Live USB XP ?
Même si tu installais Windows XP sur une clé USB, tu ne pourrais pas l'utiliser sur d'autres ordinateurs que celui que tu aurais utilisé dès le départ (problème de pilotes, je crois.

Il faut créer un Live USB de BartPE. Toutes les infos ICI.
Tu crées d'abord l'ISO, comme pour créer un Live CD, puis tu crées un Live USB avec le logiciel PEtoUSB : https://www.pcastuces.com/logitheque/petousb.htm

PS : une clé 8 Go suffit largement.
Google est votre ami =^-^=
La fonction "Rechercher" de Comment Ça Marche aussi
Messages postés
43
Date d'inscription
vendredi 5 août 2005
Statut
Membre
Dernière intervention
11 mai 2010
2
C'est un projet de SE que j'ai à faire en cours, pour linux et xp je dois expliquer comment faire pour obtenir une clé USB bootable pour ces deux OS, je ne souhaite pas avoir de XP bootable sur USB personnellement, je n'ai juste pas le choix. Ce qui est bien c'est qu'au moins pour linux c'est au point, mais pour XP je galère. Sachant que je dois aussi trouver le moyen d'intégrer certains logiciels pour XP...

Merci je vais réesayer avec BARTPE et je vous tiens au courant.
Messages postés
8415
Date d'inscription
vendredi 7 décembre 2007
Statut
Membre
Dernière intervention
3 janvier 2013
2 605
si tu as bien suivi la procédure decrite dans le site de S.Terrier ça devait marcher
un autre tuto plus simple:
https://www.erenumerique.fr/

veille bien à regler le bios pour booter sur usb

pour y ajouter des log le plus simple est d'ouvrie l'iso avec PowerIso et d'y placer des logiciels standalone (portables)
Messages postés
43
Date d'inscription
vendredi 5 août 2005
Statut
Membre
Dernière intervention
11 mai 2010
2
J'ai pas de CD (physique), je monte l'iso et j'ouvre le lecteur virtuel pour récupérer les fichiers.
Messages postés
11213
Date d'inscription
jeudi 18 janvier 2007
Statut
Modérateur
Dernière intervention
10 octobre 2019
1 894
Je vois. Si ça vient de la compilation, il faut essayer avec un autre iso de XP.
Messages postés
43
Date d'inscription
vendredi 5 août 2005
Statut
Membre
Dernière intervention
11 mai 2010
2
Cela ne marche toujours pas... J'utilise un Windows XP SP3 officiel. "Erreur disque, appuyer sur une touche pour redémarrer".
A la compilation PEBuilder ne me demande rien pour la licence comme dit dans le tutoriel, ça vient peut être de là ?

Mon portable est bien compatible avec le boot USB, pour linux ce la marche. Donc de ce côté là pas de soucis. Auriez vous une idée ?

Merci
Messages postés
11213
Date d'inscription
jeudi 18 janvier 2007
Statut
Modérateur
Dernière intervention
10 octobre 2019
1 894
Tu utilises petousb ?
Messages postés
43
Date d'inscription
vendredi 5 août 2005
Statut
Membre
Dernière intervention
11 mai 2010
2
oui, j'en ai essayé plein à vrai dire.
Messages postés
43
Date d'inscription
vendredi 5 août 2005
Statut
Membre
Dernière intervention
11 mai 2010
2
J'en essayé des tonnes, c'est ça le plus rageant. Et des versions officielles ! Normalement PEBuilder est censé demander la licence à la compilation. Il ne me l'a jamais demandé !
Messages postés
11213
Date d'inscription
jeudi 18 janvier 2007
Statut
Modérateur
Dernière intervention
10 octobre 2019
1 894
Je suis c... !
Voici les paramètres pour Petousb :
USB Removable sélectionné
Enable Disk Format coché
Tout décocher sauf Enable LBA (Fat16X)
Cocher Enable File Copy
Sélectionner Overwrite Always

Je me souviens que j'avais galéré aussi...

EDIT : Je viens de recompiler BartPE, il ne m'a pas demandé ma licence. Donc, c'est normal avec cette version.
Google est votre ami =^-^=
La fonction "Rechercher" de Comment Ça Marche aussi
Messages postés
43
Date d'inscription
vendredi 5 août 2005
Statut
Membre
Dernière intervention
11 mai 2010
2
Avez-vous déjà réussi à rendre XP bootable ?

J'ai reconfiguré PEToUSB comme vous le montrez mais cela n'a rien changé, cela ne veux toujours pas fonctionner ! erreur disque... Je desespère, j'ai essayé tant de tutoriels et rien ne marche c'est quand même aberrant.

Voici le contenu de ma clé si cela peut vous aidez à detecter un éventuel problème. Je persiste à penser que le problème vient des fichiers de boot et non pas des versions de XP que je peux utiliser.

##################################################
Contenu de l'iso que j'utilise pour la compilation
##################################################
24/04/2010 01:17 <REP> .
24/04/2010 01:17 <REP> ..
28/02/2006 14:00 110 AUTORUN.INF
24/04/2010 01:15 <REP> DOCS
24/04/2010 01:15 <REP> DOTNETFX
24/04/2010 01:17 <REP> I386
28/02/2006 14:00 34 301 README.HTM
28/02/2006 14:00 1 314 816 SETUP.EXE
28/02/2006 14:00 85 792 SETUPXP.HTM
24/04/2010 01:17 <REP> SUPPORT
24/04/2010 01:17 <REP> VALUEADD
28/02/2006 14:00 10 WIN51
28/02/2006 14:00 10 WIN51IP
28/02/2006 14:00 10 WIN51IP.SP2
7 fichier(s) 1 435 049 octets
7 Rép(s) 18 754 416 640 octets libres

##################################################
Contenu de la clé USB après avoir utilisé PEToUSB et l'iso issu de la compilation
##################################################
F:\>dir
Le volume dans le lecteur F s'appelle LIVEXP
Le numéro de série du volume est 86DC-43E6

Répertoire de F:\

24/04/2010 12:06 167 winbom.ini
28/02/2006 14:00 260 272 ntldr
28/02/2006 14:00 47 564 ntdetect.com
02/11/2004 15:04 46 autorun.inf
24/04/2010 01:31 2 048 bootsect.bin
24/04/2010 12:07 <REP> minint
24/04/2010 12:25 <REP> Programs
24/04/2010 01:30 0 WIN51IP
24/04/2010 01:30 0 WIN51IP.SP2
7 fichier(s) 310 097 octets
2 Rép(s) 1 784 905 728 octets libres


Merci de votre aide.
Messages postés
11213
Date d'inscription
jeudi 18 janvier 2007
Statut
Modérateur
Dernière intervention
10 octobre 2019
1 894
J'utilise deux clés BartPE, depuis deux ans, sans aucun souci, l'une d'elle est un UBCD4Win (BartPE enrichi, spécialisé pour les réparations).
J'utilise Bartpe depuis longtemps, donc j'avais oublié les détails pour créer une clé USB.

Par exemple, PEToUSB crée un Live USB à partir du dossier BartPE, créé en même temps que l'ISO, et pas de l'ISO, comme je te l'avais dit précédemment.
Petit détail, mes clés USB n'ont aucun souci pour booter sur un BartPe, par contre, elles ne bootent pas sur Linux, donc, essaye avec une autre clé USB...

Pour info, j'utilise, une ISO XP Pro nlité, mon CD XP Pro original n'ayant même pas le SP1. Le contenu de mon ISO est légèrement différent, mais je ne sais pas si c'est important.
Messages postés
43
Date d'inscription
vendredi 5 août 2005
Statut
Membre
Dernière intervention
11 mai 2010
2
Je ne comprends vraiment pas pourquoi cela ne marche pas.
J'ai mon ISO de windows XP professionnel SP2 que je compile sous bartPE. Ensuite j'utilise PeToUsb pour créer le live USB de XP. C'est pourtant ce qui est expliqué. Pourtant à chaque test de boot de la clé USB, j'ai l'erreur "disk error". J'ai essayé avec plusieurs clés, cela ne marche pas, j'ai essayé avec plusieurs version de windows cela ne marche pas. Pourtant avec linux ça marche parfaitement bien. Je ne pense donc pas que le problème vienne de la clé USB. Je pense que je dois mal faire quelque chose avec PeBuilder...
Sinon y'a t'il un endroit où je pourrais me procurer vos ISO ?

Merci de votre aide =)
Messages postés
11213
Date d'inscription
jeudi 18 janvier 2007
Statut
Modérateur
Dernière intervention
10 octobre 2019
1 894
Tu utilises PetoUSB avec l'ISO créé ou avec le dossier BartPE ?

Nos ISO XP, non ^^
Un zip de mon dossier BartPE, ça peut le faire, avec un peu de patience.
Messages postés
11213
Date d'inscription
jeudi 18 janvier 2007
Statut
Modérateur
Dernière intervention
10 octobre 2019
1 894
Je t'ai envoyé un message privé.
Pour rappel, voici mes paramètres pour PeToUSB : http://servimg.com/image_preview.php?i=128&u=12409575
Enjoy !
Messages postés
11213
Date d'inscription
jeudi 18 janvier 2007
Statut
Modérateur
Dernière intervention
10 octobre 2019
1 894
Petit ajout :
Après test sur ma nouvelle clé 16Go, je me rends compte que le formatage ne veut pas se faire sur une clé trop "grosse".
Ca passe sur mes clés 1Go et 2 Go.
Messages postés
43
Date d'inscription
vendredi 5 août 2005
Statut
Membre
Dernière intervention
11 mai 2010
2
Marche pas -.-, c'est toujours la même... Pas besoin de compiler avec PEBuilder ? ça déjà été fait ?
Messages postés
11213
Date d'inscription
jeudi 18 janvier 2007
Statut
Modérateur
Dernière intervention
10 octobre 2019
1 894
Je pense que c'est la taille de la clé le problème. Je teste quelque chose et je reviens.
Messages postés
43
Date d'inscription
vendredi 5 août 2005
Statut
Membre
Dernière intervention
11 mai 2010
2
j'ai testé sur 1,2,8 et 32Go... Donc fallait la compiler avec bartpe ton iso ou pas ? j'ai directement utilisé petousb ?
Messages postés
11213
Date d'inscription
jeudi 18 janvier 2007
Statut
Modérateur
Dernière intervention
10 octobre 2019
1 894
Je t'ai donné le dossier Bartpe, directement utilisable avec PeTousb.
Messages postés
43
Date d'inscription
vendredi 5 août 2005
Statut
Membre
Dernière intervention
11 mai 2010
2
ça ne marche pas. J'avoue que là je suis à 2 doigts de la crise de nerfs :D
Messages postés
11213
Date d'inscription
jeudi 18 janvier 2007
Statut
Modérateur
Dernière intervention
10 octobre 2019
1 894
Je n'ai aucune explication. Ca a fonctionné avec deux clés, et c'est une solution recommandée partout.
Peux-tu créer un LIVE CD, pour voir si tu arrives à booter tout de même sur CD ?
Messages postés
11213
Date d'inscription
jeudi 18 janvier 2007
Statut
Modérateur
Dernière intervention
10 octobre 2019
1 894
Messages postés
43
Date d'inscription
vendredi 5 août 2005
Statut
Membre
Dernière intervention
11 mai 2010
2
je vais faire ça tout de suite et je te dis.
Messages postés
43
Date d'inscription
vendredi 5 août 2005
Statut
Membre
Dernière intervention
11 mai 2010
2
tous mes CD sont morts ! Quel était ta piste ?
Messages postés
11213
Date d'inscription
jeudi 18 janvier 2007
Statut
Modérateur
Dernière intervention
10 octobre 2019
1 894
juste être sûr que le problème vient du passage au usb et pas à la compilation.
Messages postés
43
Date d'inscription
vendredi 5 août 2005
Statut
Membre
Dernière intervention
11 mai 2010
2
ça me fait péter un plomb ! Je ne comprends pas ce qui ne va pas !
Messages postés
11213
Date d'inscription
jeudi 18 janvier 2007
Statut
Modérateur
Dernière intervention
10 octobre 2019
1 894
Moi je ne comprends pas pourquoi ça marche chez mes deux vieilles clés et pas chez la nouvelle de 16 Go. Je pense que c'est un problème de taille, le fat16 ne dépassant pas 4 Go.
C'est pourquoi je me dis que ce tuto doit être bon, en utilisant GParted : https://forum.hardware.fr/hfr/WindowsSoftware/Windows-nt-2k-xp/facilement-convertir-externe-sujet_293783_1.htm