Mise en forme sur une ligne de calcul [Résolu/Fermé]

Signaler
Messages postés
23
Date d'inscription
mardi 19 janvier 2010
Statut
Membre
Dernière intervention
12 avril 2010
-
Messages postés
23895
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 février 2021
-
Bonjour, sous Excel 2007, je désire faire une mise en forme conditionelle pour que lorsque l'une de mes cellules comporte une valeur (exemple : CA dans la cellule C5) plusieurs autres cellules changent de couleur également (exemple : A1)
Une idée pour le programme ?

Merci de votre aide

6 réponses

Messages postés
918
Date d'inscription
samedi 21 novembre 2009
Statut
Membre
Dernière intervention
20 mars 2013
284
Bonsoir,
Une solution serait d'utiliser ta mise en forme par exemple sur A5 avec la formule est :

=SI(ESTVIDE(G5);FAUX;NON(ESTERREUR(TEMPSVAL(TEXTE(G5;"hh:mm:ss")))))


@+
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
23
Date d'inscription
mardi 19 janvier 2010
Statut
Membre
Dernière intervention
12 avril 2010

Merci, la formule fonctionne très bien, maintenant si la formule s'applique de G5 à AN5 ?
j'ai tenté en remplaçant de la façon suivante :
=SI(ESTVIDE($G$5:$AN$5);FAUX;NON(ESTERREUR(TEMPSVAL(TEXTE($G$5:$AN$5;"hh:mm:ss")))))
ainsi que de cette manière :
=SI(ESTVIDE(G5:AN5);FAUX;NON(ESTERREUR(TEMPSVAL(TEXTE(G5:AN5;"hh:mm:ss")))))
mais la mise en forme ne s'applique pas

Une idée ?
Messages postés
918
Date d'inscription
samedi 21 novembre 2009
Statut
Membre
Dernière intervention
20 mars 2013
284 >
Messages postés
23
Date d'inscription
mardi 19 janvier 2010
Statut
Membre
Dernière intervention
12 avril 2010

Bonsoir,
Je ne comprends pas très bien : tu veux que A5 se mette en couleur si toutes les cellules de la plage G5:AN5 continennent une heure ou si au moins une de ces cellule contient une heure, ou si 50 % de ces cellules contiennent une heure, ou ... ?

Merci de préciser.
Messages postés
23
Date d'inscription
mardi 19 janvier 2010
Statut
Membre
Dernière intervention
12 avril 2010
>
Messages postés
918
Date d'inscription
samedi 21 novembre 2009
Statut
Membre
Dernière intervention
20 mars 2013

Je désire que A5 se mette en couleur à partir du moment où j'insère une heure dans l'une des cases comprises entre G5 et AN5 (en réalité, il y en aura toujours 2 : une case pour l'heure de début de poste et l'autre pour la fin de poste)
J'avais déjà tenté un code, mais la mise en forme me mettait la case précédente en couleur

Merci pour le coup de main
Messages postés
918
Date d'inscription
samedi 21 novembre 2009
Statut
Membre
Dernière intervention
20 mars 2013
284 >
Messages postés
23
Date d'inscription
mardi 19 janvier 2010
Statut
Membre
Dernière intervention
12 avril 2010

Bonjour,
Vu le nombre de cellules considérées, je pense qu'il vaut mieux passer par une ligne intermédiaire. Par exemple, en G6, tu inscris la formule :
=SI(ESTVIDE(G5);0;SI(ESTERREUR(TEMPSVAL(TEXTE(G5;"hh:mm:ss")));0;1))

Ensuite, pour ta mise en forme conditionnelle de A5, tu utilises la formule :
=SOMME(G6:AN6)>=1


Sinon, je ne vois qu'une frmule personnalisée en passant par VBA.
Messages postés
23895
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 février 2021
6 664
Bonsoir,

Si ces cellules ne doivent contenir que des heures j'utiliserais une autre approche pour simplifier :
une validation autorisant 'heure' sur la plage, ensuite la MFC se réduit à =nb(ta_plage)=1 (ou 2 si tu veux 2 saisies d'heures obligatoires)
eric
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
918
Date d'inscription
samedi 21 novembre 2009
Statut
Membre
Dernière intervention
20 mars 2013
284
Bonsoir Eric,
Bien vu. Il faut que je travaille un peu ma prise de recul par rapport aux questions, ça évite les formules trop compliquées :-)
Messages postés
918
Date d'inscription
samedi 21 novembre 2009
Statut
Membre
Dernière intervention
20 mars 2013
284
Bonjour,
Tu fais ta mise en forme conditionnelle sur ta cellule A1 avec la formule =(C5="CA"). Idem pour les autres cellules.
Messages postés
23
Date d'inscription
mardi 19 janvier 2010
Statut
Membre
Dernière intervention
12 avril 2010

Merci, cette mise en forme fonctionne

Maintenant j'ai une autre question, désolé d'abuser de tes services :
Je désire faire une mise en forme conditionnelle, mais dans une cellule où l'on insère une heure (dans mon cas, dans la cellule G5) et mettre celle-ci, ainsi que A5 en mise en forme.
Une suggestion pour la formule ?
Messages postés
918
Date d'inscription
samedi 21 novembre 2009
Statut
Membre
Dernière intervention
20 mars 2013
284
Bonjour,
Pourrais-tu préciser la question ? Quelle mise en forme veux-tu ? S'il est plus de 20 h, s'il y a une valeur, si ...
@+
Messages postés
23
Date d'inscription
mardi 19 janvier 2010
Statut
Membre
Dernière intervention
12 avril 2010

La cellule serait sous la forme d'une heure (ex : 20:00) mais la mise en forme ne s'activerait dans la cellule concernée (dans mon cas G5) et dans une autre cellule (A5)
Mise en forme conditionnelle de type couleur, indiquant qu'une heure a été ajoutée (en G5) pour la personne concernée (en A5)
Toutefois, la mise en forme ne doit pas s'activée si aucune heure n'est entrée, celà va de soit.

Merci
Messages postés
918
Date d'inscription
samedi 21 novembre 2009
Statut
Membre
Dernière intervention
20 mars 2013
284
Bonjour,
Est-ce que tu veux dire :
Si G5 est vide alors pas de mise en forme (pas de couleur) en G5 et A5
Si G5 contient une donnée heure, alors on colorie A5 et G5


C'est bien ça ?
Messages postés
23
Date d'inscription
mardi 19 janvier 2010
Statut
Membre
Dernière intervention
12 avril 2010
>
Messages postés
918
Date d'inscription
samedi 21 novembre 2009
Statut
Membre
Dernière intervention
20 mars 2013

Oui, c'est bien ça, mon soucis n'est plus la mise en forme pour les cases "horaires" (G5), mais pour que A5 soit mis en forme également UNIQUEMENT si G5 contient un horaire
Messages postés
23895
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
24 février 2021
6 664
Ah ben c'est ça quand on part d'une question sur 1 cellule et que ça s'étend au fil du dialogue ;-)
on cherche à adapter au fur et à mesure...
A+