Calcul d'un âge par rapport à une date [Résolu/Fermé]

Signaler
-
Messages postés
1263
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
15 mai 2017
-
Bonjour,

je cherche à calculer l'âge d'une personne par rapport à une date :

concrètement :

j'ai dans une case
- A1 la date de naissance d'une personne (ex 14.01.1983)
- b1 la date d'aujourd'hui (11.02.2010)
et je veux dans la case C1 : avoir l'âge exacte (année et mois) de la personne à cette date.

sachant que dans les cases suivantes A2, A3... B2,B3 les dates diffèrent.

Quelqu'un sait-il quelle formule utiliser ?

Merci d'avance

5 réponses

Messages postés
1263
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
15 mai 2017
533
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
1
Date d'inscription
dimanche 11 novembre 2012
Statut
Membre
Dernière intervention
11 novembre 2012

Slt !
N'étant pas calé en informatique, pourrais-tu STP, m'envoyer par excel un exemple date de 1900 à celle du jour, qui me donnerait un âge.
Merci et bon dimanche
Haro Base
Messages postés
1263
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
15 mai 2017
533
Bonjour,

Tu as un exemple ici:
http://gerard.g.pagesperso-orange.fr/logiciels/Excel/datedif.xls

Cordialement
Messages postés
17259
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
20 octobre 2020
4 297
Salut,

cette formule basée sur tes critères

=SI(A1<>"";SI(DATEDIF(A1;B1;"Y")=0;" ";(DATEDIF(A1;B1;"Y")&SI(DATEDIF(A1;B1;"Y")>1;" ans, ";" an, ")))&SI(DATEDIF(A1;B1;"YM")=0;"";DATEDIF(A1;B1;"YM")&" mois, ")&SI(DATEDIF(A1;B1;"MD")=0;" ";(DATEDIF(A1;B1;"MD")&SI(DATEDIF(A1;B1;"MD")>1;" jours ";" jour ")));"")

plus évoluée avec simplement la date de naissance sans passer par la date d'aujourd'hui en B1

=SI(A1<>"";SI(DATEDIF(A1;AUJOURDHUI();"Y")=0;" ";(DATEDIF(A1;AUJOURDHUI();"Y")&SI(DATEDIF(A1;AUJOURDHUI();"Y")>1;" ans, ";" an, ")))&SI(DATEDIF(A1;AUJOURDHUI();"YM")=0;"";DATEDIF(A1;AUJOURDHUI();"YM")&" mois, ")&SI(DATEDIF(A1;AUJOURDHUI();"MD")=0;" ";(DATEDIF(A1;AUJOURDHUI();"MD")&SI(DATEDIF(A1;AUJOURDHUI();"MD")>1;" jours ";" jour ")));"")

Souvent les formules complexe se poluent par des tirets ou virgules, sur ce lien tu les retrouveras

https://www.cjoint.com/?cmsrAARKMf
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Bonjour j'ai essayé de rentrer la formule suivante:

f= date de naissance et g = une date de l'année


=SI(F16<>"";SI(DATEDIF(F16;G16;"Y")=0;"";(DATEDIF(F16;G16;"Y")&SI(DATEDIF(F16;G16;"Y")>1;"ans, ";"an")))&SI(DATEDIF(F16;G16;"YM")=0;"";DATEDIF(F16;G16;"YM")&"mois, ")&SI(DATEDIF(F16;G16;"MD")=0;"";(DATEDIF(F16;G16;"MD")&SI(DATEDIF(F16;G16;"MD")>1;"jours";"jours")));"")


et j'obtien à chaque fois une erreur de nombre...

Est-je fais une erreure ?

Merci d'avance
Messages postés
1263
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
15 mai 2017
533
Bonjour,

Ta formule fonctionne très bien à condition que tu aies activé l' Utilitaire d' analyse du menu Outils / Macros complémentaires.
L' as tu fait ?

Bonne suite.
je ne l'ai pas fais.

Comment dois-je mi prendre? Je suis sous vista
Juste une dernière petite question avant de clôturer ma demande :

que dois-je ajouter dans la formule si je veux que la case ou il y a la formule ne se remplisse pas dans le cas ou il n'y aurait pas de date dans la case G ?

La formule que j'ai est la suivante :

=SI(F16<>"";SI(DATEDIF(F16;G16;"Y")=0;"";(DATEDIF(F16;G16;"Y")&SI(DATEDIF(F16;G16;"Y")>1;"ans, ";"an")))&SI(DATEDIF(F16;G16;"YM")=0;"";DATEDIF(F16;G16;"YM")&"mois, ")&SI(DATEDIF(F16;G16;"MD")=0;"";(DATEDIF(F16;G16;"MD")&SI(DATEDIF(F16;G16;"MD")>1;"jours";"jours")));"")

Merci d'avance
Messages postés
1263
Date d'inscription
vendredi 23 avril 2004
Statut
Membre
Dernière intervention
15 mai 2017
533
Cela est sans rapport avec Vista mais concerne Excel.
Depuis Excel tu vas dans le menu Outils > Macros complémentaires...
Dans la fenêtre qui s'affiche tu coches Utilitaire d' analyse.

Bonne suite.
Je suis allée dans macro complémentaire et on me dit que sont activés :

Analysis Toolpak
Analysis Toolpak VBA
Assistant recherche
Assitant somme conditionnelle


Je n'ai pas utilitaire d'analyse .

Je suis très nulle en anglais donc peut-être que Analysis Toolpak = utilitaire d'analyse.

Si c'est pas le cas : j'ai essayé de faire parcourir pour l'ajouter mais il ne me le propose pas...

Et la formule indique tjrs une erreure de nombre.


Avez-vous une idée ?


Merci d'avance
c'est bon en fait ca fonctionne.


Merci infiniment pour votre aide.

Bonne journée
excusez-moi mais comment faut-il faire pour signaler que mon message a été résolu ?

Merci