Défaut du package inputenc avec LaTeX ?

Résolu/Fermé
(Pabix) - 18 mai 2005 à 17:51
 Damien - 15 juin 2016 à 16:50
Bonjour à tous,

J'utilise Kubuntu (le hérisson blanc) et il semble que ma distribution LaTeX ne veut pas entendre parler de \usepackage[latin1]{inputenc} : mes é, à, ê deviennent des genres de ˜A et autres gâteries malgré tout...

J'ai remplacé mes fichiers inputenc.choses par les plus récentes versions que j'ai pu trouver sur Internet, rien à faire. Je n'ai pas envie de remplacer tous mes é par des \'e etc. pour des commodités de lecture.

Avez-vous une proposition de solution ?

Je vous remercie

Benoit.

8 réponses

Non, ca ne suffira pas, car LaTeX utilise un index des packages installés. Tout ajout n'est par conséquent reconnu que si l'indexation est relancée.

Plus précisément : les fichiers de ressources pour LaTeX sont conservés dans un répertoire nommé texmf (il peut y en avoir plusieurs selon les distributions...). La commande pour mettre à jour les index s'appelle texhash sous Linux, et porte certainement un nom similaire sous Windows.
5
je n'ai pas inputenc et fontenc dans mon ordi donc comment je fais pour télécharger c'est 2 package
0
OK

A priori Windows est en UTF 8, donc il suffit d'effectuer la commande

\usepackage[latin1]{inputenc}

comme spécifié par l'auteur cette discussion .... désolé ...

En tout cas, voici comment gérer les accents en fonction de l'environnement:

Ubuntu \usepackage[utf8]{inputenc}

Windows XP \usepackage[latin1]{inputenc}
4
J'ai Windows 7 mais c'est \usepackage[UTF8]{inputenc} qui m'a aidé et pas latin1.

Merci.
0
Non, Windows est en Latin1 (et même une variante "maison" de microsoft de cet encodage). Linux/Unix sont en UTF-8
0
J'ai bien Windows et j'abonde dans le sens de jikata ; c'est bien \usepackage[UTF8]{inputenc} qui m'a permis d'utilliser correctement les accents
0
Ce n'est pas le système d'exploitation qui détermine l'encodage du fichier, mais l'éditeur utilisé. Pour savoir quel encodage spécifier pour l'extension inputenc, il faut vérifier l'encodage du fichier.

Il est également possible de modifier l'encodage du fichier via la configuration de l'éditeur utilisé.
0
moi aussi comme louis
0
marc[i1]
Messages postés
2571
Date d'inscription
vendredi 1 avril 2005
Statut
Contributeur
Dernière intervention
6 septembre 2008
379
18 mai 2005 à 18:55
Salut,

il me semble que Kunbutu soit en UTF-8, donc Kile (car tu utilises Kile, non ?) peux être réglé pour être par défaut en ISO-8859-15.

Sinon tu peux aussi modifier l'appel du package:
\usepackage[utf8]
ou
\usepackage[utf-8]
je sais plus :/

2
(Pabix)
Messages postés
578
Date d'inscription
mercredi 18 mai 2005
Statut
Membre
Dernière intervention
27 octobre 2009
82
18 mai 2005 à 19:12
Merci beaucoup,

En effet c'est l'encodage qui posait problème...

Bonne soirée !
0
counia manmanw
0
ato > freeeeed
3 nov. 2008 à 23:43
coucoune a manmanw
0
Bonjour,

cette solution fonctionne sous Linux.

Toutefois, elle n'est pas valable sous Windows: j'utilise Technix Center et avec la commande

\usepackage[utf8]{inputenc}

je rencontre le problème cité: les é, è, ù, à ... ne sont pas reconnus...

Quelqu'un aurait-il une idée??

Merci

Guillaume
1
Bonjour,
l'option [ansinew] fonctonne parfaitement avec windows XP. donc
\usepackage[ansinew][inputenc].
Bonne chance
0
Bonjour,
l'option [ansinew] fonctonne parfaitement avec windows XP. donc
\usepackage[ansinew]{inputenc].
Bonne chance
0
Bonjour,
l'option [ansinew] fonctonne parfaitement avec windows XP. donc
\usepackage[ansinew]{inputenc}.
Bonne chance
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
Salut,

J'aurais souhaité savoir comment installer des packages LaTeX. J'utilise la distribution TexLive2007 et le logiciel TechniCenter, le tout sur un système d'exploitation Windows Vista (quelle merde ce Vista) et apparamemnt je n'es pas de module qui me permet d'installer des packages manquant de façon automatique.
Je parviens à télécharger les packages manquant sur CTAN mais je ne comprend pas où et comment les installer !

Quelqu'un sait-il comment procédé pour y parvenir ???

Merci d'avance.

Ben
0
Hello,

Le plus brutal c'est d'installer tes packages dans le même dossier que ton code (un peu comme les images), le seul problème c'est que à chaque nouveau document tu dois de nouveau les copier.
Je travail sur mac mais probablement que c la même chose sur pc, il y a un dossier dans lequel sont déjà enregistrés qques packages des base Par exemple inputenc... fais une recherche et sauve tes nouveau packages dans le même dossier, normalement ça devrait suffire.
0
Il suffit de faire texhash dans les commandes windows. Je pense que cela doit être la même chose sur mac et Linux.
0
je confirme l'utilisatiion de \usepackage[ansinew]{inputenc}
sous windows vista pour résoudre ce problème (miktex + TeXnicCenter)
0
Ca marche pas :(
0