Difficultés à installer Nagios Plugins

Résolu/Fermé
sandybi
Messages postés
5
Date d'inscription
samedi 7 novembre 2009
Statut
Membre
Dernière intervention
21 novembre 2009
- 9 nov. 2009 à 21:07
jesuislibre15
Messages postés
12
Date d'inscription
vendredi 12 août 2011
Statut
Membre
Dernière intervention
15 août 2011
- 12 août 2011 à 16:39
Bonjour,

Je dois faire fonctionner Nagios 3.2.0 sur REDHAT entreprise 4,j'ai compilé et installé le paquet Nagios sans difficultés mais j'ai un gros probleme avec l'installation de nagios plugins 1.4.14, ça plante!

[root@localhost nagios-plugins-1.4.14]#./configure--prefix=/usr/local/nagios --with-nagios-user=nagios --with-nagios-group=nagios --with-cgiurl=nagios/cgi-bin
...
...
checking for xgettext... /usr/bin/xgettext
checking for msgmerge... /usr/bin/msgmerge
checking for ld used by GCC... /usr/bin/ld
checking if the linker (/usr/bin/ld) is GNU ld... yes
checking for shared library run path origin... done
checking for CFPreferencesCopyAppValue... no
checking for CFLocaleCopyCurrent... no
checking for GNU gettext in libc... yes
checking whether to use NLS... yes
checking where the gettext function comes from... libc
configure: See http://nagiosplugins.org/faq/compile/configure_appears_to_hang if this next part takes a long time
checking for redhat spopen problem...

ça plante à ce niveau, et lorque je vais sur la page http://nagiosplugins.org/faq/configure_apears_to_hang, les deux solution qu'on me propose ne marchent pas( forcer et ignorer le test). par exemple lorque j'ignore ça me renvoi l'erreur suivante,

[root@localhost nagios-plugins-1.4.14]# ./configure with --disable-redhat-pthread
configure: WARNING: you should use --build, --host, --target
checking for a BSD-compatible install... /usr/bin/install -c
checking whether build environment is sane... yes
checking for a thread-safe mkdir -p... /bin/mkdir -p
checking for gawk... gawk
checking whether make sets $(MAKE)... yes
checking build system type... Invalid configuration `with': machine `with' not recognized
configure: error: /bin/sh build-aux/config.sub with failed

Merci de m'aider à débloquer la situation!

3 réponses

foobar47
Messages postés
13531
Date d'inscription
jeudi 9 janvier 2003
Statut
Contributeur
Dernière intervention
16 mai 2014
534
10 nov. 2009 à 09:39
Salut,

Pourquoi ne pas avoir utilisé les RPM ?
0
sandybi
Messages postés
5
Date d'inscription
samedi 7 novembre 2009
Statut
Membre
Dernière intervention
21 novembre 2009

10 nov. 2009 à 19:55
j'avais essayé d'installer avec les .rpm mais je me sui rendu compte que tous les fichiers n'étaient pas crées donc j'ai opté pour le tar qui est le plus conseillé d'ailleurs pour l'install de nagios.

pour ce qui est de mon probleme de plantage d'install des plugins, il a été résolu, yavais un petit souci au niveau de ma carte réseau.

cool!
0
jesuislibre15
Messages postés
12
Date d'inscription
vendredi 12 août 2011
Statut
Membre
Dernière intervention
15 août 2011

12 août 2011 à 16:39
pour moi, on me sort deux erreurs à la fin du make, après ./configure, quelque chose du genre : erreur avant le caractere "*" dans le fichier check_http.c:64:
je ne comprend pas vraiment d'où ca peut venir :s
0