Server DNS cache-only [Résolu/Fermé]

Signaler
Messages postés
181
Date d'inscription
mercredi 25 février 2009
Statut
Membre
Dernière intervention
27 avril 2010
-
Messages postés
141
Date d'inscription
vendredi 1 juin 2007
Statut
Membre
Dernière intervention
30 août 2016
-
Bonjour,

J'aimerais monter un serveur qui me servirait de DNS cache-only.
Il s'agit d'un DNS public. J'ai donc installé Bind9 sur une Debian Lenny 5.01.
L'adressage de la machine est correcte, et je peux aller sur le net.

'Pour mettre en place la "fonction" j'ai modifié que deux fichiers :

/etc/resolv.conf :

nameserver 213.244.0.15 # server DNS




Et /etc/bind/named.conf.options :
options {
directory "/var/cache/bind";
forwarders {
213.244.0.15;
194.2.0.20;
};
auth-nxdomain no; # conform to RFC1035
listen-on-v6 { any; };
};



Il me manque quelque chose, mais quoi?
Que faut il faire d'autre pour mettre en place un cache DNS ?

Merci.

5 réponses

Messages postés
141
Date d'inscription
vendredi 1 juin 2007
Statut
Membre
Dernière intervention
30 août 2016
29
Bonjour,
Je ne m'y connais pas particulièrement là dedans, mais je pense qu'il faut distinguer les rôles de ton resolv.conf et de ton named.conf
resolv.conf indique à ta machine quel dns consulter pour résoudre un hote. Ton resolv.conf pointe vers un serveur
externe, et snobe donc ton bind, qui attend désespérément une requête. Il faudrait mettre l'adresse de ton serveur dans ton resolv.conf pour que les requetes passent par lui. (Disez moi si je me trompe)
Messages postés
181
Date d'inscription
mercredi 25 février 2009
Statut
Membre
Dernière intervention
27 avril 2010
14
Effectivement, je pense que vous avez raison sur ce point.
Cependant ma conf n'est toujours pas bonne...
Mais ça me fait toujours une erreur de corrigé, merci.
Messages postés
141
Date d'inscription
vendredi 1 juin 2007
Statut
Membre
Dernière intervention
30 août 2016
29
Peut être faut il indiquer quelque part à bind de qui il accepte des requêtes. (simple supposition)
sinon, peut être les logs apportent-ils des infos...
Messages postés
181
Date d'inscription
mercredi 25 février 2009
Statut
Membre
Dernière intervention
27 avril 2010
14
Oui, c bon j'ai trouvé.

Et je vient de voir que ton dernier poste mise tout pile ou il faut!

c dans le fichier : /etc/bind/named.conf.options

il me manquait la petite ligne :

allow-query {any;};


Merci de ton aide.
Messages postés
141
Date d'inscription
vendredi 1 juin 2007
Statut
Membre
Dernière intervention
30 août 2016
29
C'est un plaisir :)