Windows > Putty > VirtualBox > Ubuntu [Résolu/Fermé]

Signaler
-
 Swadon -
Bonjour,

je souhaiterais pouvoir me connecter via Putty depuis mon windows a Ubuntu qui est installé sur une machine virtuelle (virtualBox) qui elle même se trouve sur un PC sur mon réseau local.

(Je précise que j'ai installé sur Ubuntu open-ssh server et qui est démarré également)

Voici donc un petit schéma:

Mon PC (Windows, ip: 192.168.0.5) - Putty > Serveur (Windows, ip: 192.168.0.2) > VirtualBox (ip: 10.0.2.15)

Je vous décris mon problème :

Lorsque je lance Putty depuis mon windows et que j'entre l'adresse IP de VirtualBox (10.0.2.15), j'ai le message d'erreur suivant :

Network error : Network is unreachable

Lorsque j'entre l'adresse IP du serveur (192.168.0.2), un autre message d'erreur :

Network error : Connection refused

Ca fait plusieurs jours que j'essaie de trouver la solution, mais rien a faire... :s

Je remercie donc d'avance toute personne qui pourra m'aider à y voir plus clair.

Merci

10 réponses

Suite a mon problème, voici la schématisation de ce que j'ai mis en place pour que celà fonctionne :

Lors de l'installation de VirtualBox celui-ci créer automatiquement une connexion reseau virtuel (VirtualBox Host Only -ethernet avec une adresse IP 10.0.2.15), mais cette adresse ne convient pas avec mon réseau puisqu'il (mon réseau) est de type 192.168.X.X (avec un sous reseau 255.255.255.0).

1-Dans un premier temps modifier cette dernière (10.0.2.15) par la suivante 192.168.0.100 (/ 255.255.255.0),

2-Se rendre sur la machine virtuelle, qui doit être éteinte pour pouvoir accéder aux paramétres réseau :
PREFERENCES > RESEAU > Mode d'accès réseau > (sélectionnez) Accès par pont > (juste en dessous du mode accès reseau) choisir sa carte réseau réelle (pour moi: 192.168.0.2 / 255.255.255.0).

3-Démarrer Ubuntu (via la machine Virtuelle).

4-(Dans Ubuntu) Se rendre dans le menu Système > Administration > Outils Réseau > Menu déroulant (périphérique Réseau) choisir Interface éthernet (eth1) > lire l' IP se trouvant en face de IPV4 (c'est avec cette adresse que vous pourrez vous connecter à distance) dans mon cas 192.168.0.18 (avec le sous réseau 255.255.255.0)

5-Vérifier si le service openssh-server est démarré (2 possibilitées):
>> (Menu Ubuntu) Système > Administration > Services (vous devez avoir les droits pour modifications)
>> (En ligne de commande) sudo /etc/init.d/ssh start

6-Vérifier que le port 22 est ouvert sur le serveur (chez moi 192.168.0.2).
(si vous ne souhaitez pas vous connecter depuis internet mais qu'en local, il n'est pas nécessaire d'ouvrir les ports de votre routeur)

7-Lancer Putty (http://www.putty.org/) depuis la machine avec laquelle vous souhaitez vous connecter sur votre serveur.

8-Dans la fenêtre d'acceuil (Putty) entrez l'adresse IP que vous aurez récupérer (à la ligne 4 de ce mini tuto, dans mon cas 192.168.0.18) (vérifier que SSH est sélectionné) et que le numéro de port soit bien sur 22.

9-Cliquez sur "OPEN", un boîte de dialogue s'ouvre alors dans laquelle il vous est demandé si vous souhaitez continuer (Oui, si vous souhaitez pouvoir vous conencter :D ).

Et voilà, j'espère que cela évitera à certains de se retrouver dans la même situation que moi... :P

Je tiens à remercier tous les intervenants de ce post sans qui je n'aurais pu trouver la(les) réponse(s) :

sdj79 (m'avoir indiquer l'adresse IP, sous Ubuntu),
Hishiro (IP et le masque sous réseau de ma carte Réseau),
brupala (le pare-feu -windows- ou autre sur la machine vers laquel on veux se connecter),
boss50 (paramétrage en mode "pont" de la virtualBox).
1192
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
97550
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
23 février 2021
11 678
Impeccable,
merci, c'est sympa pour les autres .
Merci pour la réponse ça vient bien m'aider dans mon travail scolaire :)
Bonne journée
Je me permet de faire un up de ce sujet, car je ne vois toujours pas comment faire.

Merci.
Messages postés
479
Date d'inscription
mercredi 1 octobre 2008
Statut
Contributeur
Dernière intervention
9 janvier 2011
58
Bonjour herwan,

Alors pour le premier c'est normal, tes 2 machines ne sont pas sur le même réseau. (Adresse IP trop différente)
Après est-ce que sur ton serveur 2003 tu autorise la connexion en SSH?

Dans le deuxieme cas c'est le serveur qui refuse la connexion alors que le premier c'est la machine que putty n'arrive pas à atteindre.
Bonjour Hishiro (et merci pour la réponse),

J'ai déjà essayé de modifier l'adresse IP de VirtualBox (10.0.2.15) dans le gestionnaire réseau (windows) en le passant en 192.168.10.20, mais j'ai toujours le même problème :S
quand ta virtualbox est éteinte va dans les parametres virtualbox du systeme à lancer puis dans ses parametre réseaux tu la configure en mode bridge (pont reseau).

tout le monde sera sur le meme réseau comme sur un hub/switch.

enjoy :)
Tout d'abord, comme l'a dit boss50, il faut que tu configure ta machine virtuelle Ubuntu pour que l'interface ethernet soit en "bridge" (connexion par pont) sur ton carte ethernet réelle.

Ensuite il faut également que les machines qui doivent communiquer ensemble soient sur le même sous-réseau. Donner une IP n'est pas suffisant ... le masque sous-réseau doit être indiqué aussi.

Je suppose que pour tes machines en 192.168.0.X tu as un masque sous réseau de 255.255.255.0 ... celà implique que toute machine que tu veux mettre sur le même réseau doivent avoir une adresse comprise entre 192.168.0.1 et 192.168.0.254 (comprise).

Essaie donc par exemple 192.168.0.100 / 255.255.255.0 pour ton ubuntu. Et n'oublie pas de mettre ton interface en bridge. (Paramètres interface réseau de la machine virtuelle).
Messages postés
479
Date d'inscription
mercredi 1 octobre 2008
Statut
Contributeur
Dernière intervention
9 janvier 2011
58
C'est vrai autant pour moi le masque aussi.
Désolé pour moi cela semblais évidant.

Merci de la précision sdj79.
Merci pour vos réponses, je vous décris ce que j'ai effectué et le résultat :

Dans un premier temps, j'ai changé l'adresse IP et le masque de sous-réseau (192.168.0.100 / 255.255.255.0) de la carte réseau virtuel (VirtualBox) dans les paramétres réseau windows sur mon serveur (192.168.0.2 / 255.255.255.0).

Ensuite j'ai lancer VirtualBox (sans lancer Ubuntu -donc machine virtuel éteinte-) et je me suis rendu dans PREFERENCES > RESEAU > Mode d'accès réseau > (j'ai sélectionné) Accès par pont > (juste en dessous du mode accès reseau) j'ai choisi ma carte réseau réelle (192.168.0.2 / 255.255.255.0).

J'ai ensuite lancé Ubuntu (via VirtualBox), j'ai vérifier que "openssh server" était lancé: sudo /etc/init.d/ssh start

J'ai ensuite lancé Putty sur mon PC (192.168.0.5 / 255.255.255.0), j'ai entré l'adresse IP de la machine virtuel (192.168.0.100) mais j'ai toujours un message d'erreur.

si je me connecte (depuis Putty) avec l'adresse 192.168.0.100 > network error : Time out
et le message suivant avec cette adresse 192.168.0.2 > Network error : connection refused

Si j'ai omis de procéder a un réglage merci de me le faire savoir parce que là... je suis perdu (et c'est peu dire :D)
Où ai-je donc fait l'erreur ?

(à quel niveau du paramétrage)
Messages postés
97550
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
23 février 2021
11 678
Salut,
Connexion refusée c'est déjà mieux, ça veut déjà dire ..... qu'il y a connexion .
mais le paramétrage de ton serveur ssh n'est peut-etre pas réalisé correctement ... as tu généré une clé privée sur ton compte utilisateur ?
qu'est ce qu'il y a dans le fichier config ?
et comment est configuré putty .
pour vérifier déjà, peux tu pinguer la machine ubuntu depuis windows ?
Messages postés
295
Date d'inscription
samedi 16 décembre 2000
Statut
Contributeur
Dernière intervention
30 avril 2013
113
L'adresse IP de ta carte virtual box ne devait pas être changée. Bien que ça ne pose pas de souci je pense.

C'est dans ubuntu que tu devais changer l'IP et avoir 192.168.0.100 / 255.255.255.0

Quand tu bridges une interface, c'est comme si tu rajoutais une carte réseau virtuelle. En gros tu as 2 IPs sur une même interface physique.

Tu devrais au final avoir:

- PC/Putty: 192.168.0.5 / 255.255.255.0
- PC/serveur: 192.168.0.2 / 255.255.255.0 (bien que ça n'ait aucune importance ici)
- Ubuntu: 192.168.0.100 / 255.255.255.0 (je parle ici bien de la config de eth0 sous ubuntu)
Messages postés
97550
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
23 février 2021
11 678
Sinon, aussi,
tu n'as pas un parefeu qui traine sur tes machines windows ?
le host virtualbox notamment ?
Merci, ça marche impec pour moi ! ;)