Freeze de jeux sur Ubuntu

Fermé
Messages postés
8
Date d'inscription
samedi 26 septembre 2009
Statut
Membre
Dernière intervention
12 novembre 2009
-
 admin -
Bonjour,


Je viens d'installer Ubuntu, et j'en suis très content.
Un seul (gros) point noir : je me rends compte que ATI et Linux ne sont pas vraiment copains. En effet, je tourne sur une Radeon HD 4650 et elle me cause quelques soucis, notamment des ralentissements lorsque j'active les effets visuels, ce que j'ai réussi à régler via un patch.

Mon autre problème : quasiment à chaque fois que je quitte un jeu sous Linux (lorsque je clique sur le bouton "quitter"), freeze total : le jeu est toujours là, mais plus rien ne bouge, même pas la souris. Quelquefois je peux ouvrir la console en faisant Ctrl+Alt+F1, mais ça ne m'avance pas beaucoup. Il ne me reste plus à ce moment qu'appuyer sur le bouton "reset" de ma tour.
Si je rentre puis je ressort de la console, je ne vois plus le jeu, juste un écran noir. Je vois juste la souris, mais je ne peux toujours pas la bouger.

Les jeux concernés : TA-Spring, TeeWorlds, Counter-Strike 2D, Armagetron Advanced
Je précise que je n'ai aucun problème en utilisant ces mêmes jeux sous Windows.

A chaque fois qu'un nouveau driver ATI sort, je l'installe, plein d'espoir, mais pour l'instant aucun n'a résolu le problème.

J'espère que vous pourrez m'aider, ça me plairait beaucoup de devenir indépendant de Windows.


5 réponses

Messages postés
2094
Date d'inscription
mercredi 18 juin 2008
Statut
Contributeur
Dernière intervention
2 décembre 2010
200
salut
ça rassemble effectivement à un gros pbm de carte graphique
> lorsque tu peux reprendre la main en console,
- tu peux tenter un sudo init 3, suivi d'un sudo init 5
- peux tu lancer un top voir ce qui paralyse la machine ?

> par ailleurs le ctrl-alt-backspace fonctionne t il ?

> As tu les effets 3D (compiz ... )?
Messages postés
8
Date d'inscription
samedi 26 septembre 2009
Statut
Membre
Dernière intervention
12 novembre 2009
2
Je ne connaissais pas les commandes "init" et "top". Je n'ai pas eu le problème de nouveau (c'est assez aléatoire), je ne peux pas encore les tester.

Pour le Ctrl+Alt+Backspace, il me semble avoir déjà essayé, mais ça ne m'avait pas permis de quitter l'application.

Pour les effets 3D et Compiz, oui ils sont effectivement activés (depuis que j'ai réussi à les faire fonctionner correctement, cf mon post précédent), mais le problème arrive même quand il ne le sont pas.

Merci de m'aider.
Messages postés
2094
Date d'inscription
mercredi 18 juin 2008
Statut
Contributeur
Dernière intervention
2 décembre 2010
200
salut
à mon avis, laisse tomber compiz tant que tu n'arrives pas à faire tourner spring au poil. le probleme est lié à mon avis. il se peut aussi que ta carte ne suive pas : le nb de fps dans spring avec compiz est notablement plus bas.
Messages postés
8
Date d'inscription
samedi 26 septembre 2009
Statut
Membre
Dernière intervention
12 novembre 2009
2
Oui, mais comme je l'ai dit, le bug est déjà apparu alors que compiz n'était pas activé. Je ne pense donc pas que ça vienne de là.
bonjour j'ais 11ans je voudrez savoir le code pour les freeze pour être un admin