Problème installations Additions Clients

Résolu/Fermé
rossbaycult
Messages postés
24
Date d'inscription
vendredi 14 août 2009
Statut
Membre
Dernière intervention
26 mars 2010
- 10 sept. 2009 à 23:54
dubcek
Messages postés
18515
Date d'inscription
lundi 15 janvier 2007
Statut
Contributeur
Dernière intervention
26 juin 2022
- 14 sept. 2009 à 19:09
Bonjour,

Je fais tourner Ubuntu en machine virtuelle sur mon PC. J'utilise Virtualbox, et pour plus de confort j'aimerai installer les additions clients. J'ai suivi les tuto sur internet, mais à la fin de l'installation je tombe sur le message "Unknown version of X Window System Installed", et au final ça ne fonctionne pas.

J'ai vu que je n'étais pas le seul à avoir ce problème, mais je n'ai pas trouvé la solution.

Merci d'avance

12 réponses

dubcek
Messages postés
18515
Date d'inscription
lundi 15 janvier 2007
Statut
Contributeur
Dernière intervention
26 juin 2022
5 547
14 sept. 2009 à 17:24
tu crées chez toi un dossier vbox (ou un autre nom)
mkdir ~/vbox
tu va sur le cd/image ISO
cd /media/cdrom0
tu extrais les fichiers, tu choisis x86 ou amd
sudo ./VBoxLinuxAdditions-x86/amd46.run --target ~/vbox
tu vas dans vbox
cd ~/vbox
tu dois trouver le fichier install.sh
ls
le case n'est peut-être plus à la ligne 415
1
jipicy
Messages postés
40805
Date d'inscription
jeudi 28 août 2003
Statut
Modérateur
Dernière intervention
10 août 2020
4 900
11 sept. 2009 à 07:47
Salut,

Je fais tourner Ubuntu en machine virtuelle sur mon PC

Quelle version d'Ubuntu ?


J'ai suivi les tuto sur internet,
Le(s)quel(s) ?

As-tu vu/suivi également celui-ci : https://www.commentcamarche.net/faq/7576-virtualbox-installer-les-additions-client-dans-ubuntu
0
rossbaycult
Messages postés
24
Date d'inscription
vendredi 14 août 2009
Statut
Membre
Dernière intervention
26 mars 2010

13 sept. 2009 à 19:53
Bonjour,

J'ai Ubuntu 9.04 et j'ai essayé quantité de tutos, y compris celui-ci. Tout se passe bien jusqu'à la fin, où je tombe sur "Unknown Version of the X Window System Installed". Et quand je redémarre ça ne fonctionne pas.
0
jeanbi
Messages postés
14747
Date d'inscription
samedi 9 décembre 2006
Statut
Contributeur
Dernière intervention
3 juin 2022
2 391
13 sept. 2009 à 20:03
re, quel fichier essaye tu d'installer ? a mon avis c'est la qui a erreur !a+
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
rossbaycult
Messages postés
24
Date d'inscription
vendredi 14 août 2009
Statut
Membre
Dernière intervention
26 mars 2010

13 sept. 2009 à 20:13
Ben je fais exactement comme dans le tuto Virtualbox: accès internet pour une VM Vista

Sauf qu'au lieu d'avoir à la fin "Successfully Installed the Virtual Box Guest Additions" j'ai "Unknown Version of the X Window System Installed"...

J'ai beau chercher sur internet je trouve pas. Et pour couronner le tout je débute sur Ubuntu, ce qui n'aide pas !
0
jeanbi
Messages postés
14747
Date d'inscription
samedi 9 décembre 2006
Statut
Contributeur
Dernière intervention
3 juin 2022
2 391
13 sept. 2009 à 20:16
re, ça repond a ma questions quel fichiers lances tu il y en a 2
a+
0
rossbaycult
Messages postés
24
Date d'inscription
vendredi 14 août 2009
Statut
Membre
Dernière intervention
26 mars 2010

13 sept. 2009 à 20:17
et bien VBoxLinuxAdditions.run, comme dans le tuto...
0
rossbaycult
Messages postés
24
Date d'inscription
vendredi 14 août 2009
Statut
Membre
Dernière intervention
26 mars 2010

14 sept. 2009 à 15:39
Personne pour m'ôter cette épine du pied ?
0
dubcek
Messages postés
18515
Date d'inscription
lundi 15 janvier 2007
Statut
Contributeur
Dernière intervention
26 juin 2022
5 547
14 sept. 2009 à 16:00
hello
il y a un work-around là
https://wiki.ubuntu.com/QATeam/DevelopmentSetup?action=show&redirect=Testing%2FVirtualBox

You need to extract the installer. So run VBoxLinuxAdditions-x86/amd46.run --target ~/tmp (you need the destination folder first of course). Then check the install.sh file, on line 415, you will see this:

15 1.5.99.* | 1.6 )

Now after the 1.6, add a .0. This is needed, because the version that is returned by X -version is 1.6.0, not 1.6.

After you've fixed the install script, run it as sudo.
0
rossbaycult
Messages postés
24
Date d'inscription
vendredi 14 août 2009
Statut
Membre
Dernière intervention
26 mars 2010

14 sept. 2009 à 17:03
Yeah, merci beaucoup, j'avais pas trouvé ce truc ! C'est bien le problème que j'ai...

Mais y'a juste un bémol, cette page ne détaille rien. Et commençant sur Ubuntu depuis 5 jours je ne sais pas faire ce qu'ils décrivent. "So run VBoxLinuxAdditions-x86/amd46.run --target ~/tmp (you need the destination folder first of course)" = chinois et je trouve pas le fichier install.sh
0
rossbaycult
Messages postés
24
Date d'inscription
vendredi 14 août 2009
Statut
Membre
Dernière intervention
26 mars 2010

14 sept. 2009 à 18:05
Ok, merci beaucoup...
Je viens de me rendre compte que je n'avais pas exactement la bonne version de VirtualBox -> pas les mêmes additions Clients.

Ca marche nickel maintenant !
0
dubcek
Messages postés
18515
Date d'inscription
lundi 15 janvier 2007
Statut
Contributeur
Dernière intervention
26 juin 2022
5 547
14 sept. 2009 à 19:09
impeccable.
se rappeller que quand tu mets à jour Virtualbox, il faut aussi mettre à jour les additions clients
0