Excel / Fonction SI / 3 conditions [Résolu/Fermé]

Signaler
-
Messages postés
8
Date d'inscription
samedi 25 juillet 2009
Statut
Membre
Dernière intervention
20 janvier 2010
-
Bonjour,

Merci d'avance à tous ceux qui peuvent m'apporter leur aide:

voici l'exercice:
Les frais de livraison d'un produit "X" augmentent selon sa zone de livraison
Le transporteur a défini un tarif selon 3 zones de livraison différentes

Pour la Zone1 il n'y a aucune augmentation de tarif ( augmentation=0,00€)
Dans la Zone2 il y a une augmentation de 15 euros( augmentation=15,00€)
Dans la Zone3 il y a une augmentation de 30 euros( augmentation=30,00€)

Imaginez un tableau
Où dans la colonne A1 on rentrerai la Zone concernée ( 1,2 ou 3)
Et ou dans la colone B1 on rentrerai la formule suivante:
Si dans A1 on a 1 alors B1 = 0
Si dans A1 on a 2 alors B1 = 15,00€
Si dans A1 on a 3 alors B1 = 30,00€

quelque chose qui ressemblerai à ceci:

A1 B1
1 - €
1 - €
2 15,00 €
1 - €
3 30,00 €

Voilà merci encore de votre aide
PP

4 réponses

Messages postés
17380
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
22 juin 2021
4 648
Salut,

En B1 colles cette formule, mets la cellule en format monétaire pour avoir le € et incrémente la vers le bas

=SI(A1=1;0;SI(A1=2;15;SI(A1=3;30;0)))

pour éviter l'affichage des valeurs 0 (Outils/Options, onglet Affichage et décoches valeurs zéro)

A+
Mike-31

Un problème sans solution est un problème mal posé  (Einstein)
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Messages postés
8
Date d'inscription
samedi 25 juillet 2009
Statut
Membre
Dernière intervention
20 janvier 2010
6
Merci infiniment Mike,
Je vois que tu Excel's sur tous les tableaux
ça marche parfaitement et ta réponse a été super rapide
Merci aussi pour le compliment Einstenien
Amicalement,
PéPé2Nim
Messages postés
1669
Date d'inscription
vendredi 11 mai 2007
Statut
Contributeur
Dernière intervention
21 mai 2012
181
post en résolu svp :)
Messages postés
8
Date d'inscription
samedi 25 juillet 2009
Statut
Membre
Dernière intervention
20 janvier 2010
6
ok,
désolé d'avoir homis de pointer sur résolu. Ma question a bel et bien été résolue et très rapidement de surcroit.
C'est la première fois que je m'adresse à ce genre de forum alors je ne connaissais pas vraiment le mode de fonctionnement.j'espère que cette fois ci j'ai bien coché la bonne case
Encore merci à tous
PéPé2Nim