Quelques problèmes de sons avec Ubuntu [Résolu/Fermé]

Signaler
Messages postés
80
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
19 janvier 2012
-
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
-
Bonjour,
Voilà, j'ai commencé il y a quelques temps avec Ubuntu, donc je suis assez novice ^^

Bref, une première fois j'ai installé Kubuntu, pas de sons, je recherche sur ce forum et trouve un bon sujet ou l'utilisateur mamiemando donne des solutions très claire et tout.... (voici le sujet : https://forums.commentcamarche.net/forum/affich-3004075-ubuntu-aucun-son )
J'ai tout suivi ce qu'il disait, mais j'ai été incapable d'avoir du son...
Puis j'ai désinstallé Kubuntu et j'ai installé Ubuntu, toujours le même problèmes, je précise, l'installation est faite a partir du "Ubuntu CD Installer" qu'on trouve sur le site ubuntu.com...
Je réessaie tout les trucs du topic d'avant, toujours rien...
Ensuite je vais sur le site d'ubuntu voir si ya des solutions pour mon problème, j'essaie ce qu'ils disent, mais toujours rien...

Bref est-ce que quelqu'un pourrait m'aider ?
J'ai encore désinstaller Ubuntu et je viens de le réinstaller, il est tout frais j'ai encore rien essayer dessus.

Listes des choses que j'ai fait les autres fois:

Désactiver le son de ma carte mère, enfin je crois.
Mis par défaut la bonne carte son sur alsamixer (à nouveau je crois que c'était la bonne, pas sur)
Essayé pas mal de truc du sujet ou mamiemando intervient...
J'ai essayé de réinstaller les pilotes pour ma carte son, mais je pense pas avoir aboutis la chose ^^

Merci de me venir en aide.
Ian

16 réponses

Messages postés
18240
Date d'inscription
lundi 15 janvier 2007
Statut
Contributeur
Dernière intervention
30 novembre 2020
5 165
hello
dans /etc/modprobe.d/blacklist y a-t-il une ligne blacklist pcspkr ?
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
466
Salut,

peux-tu aussi nous donner le résultat des commandes suivantes (à taper dans une console, donc !) :

id

ps ax | grep pulse

aplay -l


merci.
Messages postés
80
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
19 janvier 2012
17
@ dubcek:
Non il n'y a pas de ligne de ce nom...

@ bob031 :
Voici ce que ca me donne :

ianoux@ubuntu:~$ id
uid=1000(ianoux) gid=1000(ianoux) groupes=4(adm),20(dialout),24(cdrom),46(plugdev),106(lpadmin),121(admin),122(sambashare),1000(ianoux)

ianoux@ubuntu:~$ ps ax | grep pulse
3771 ? Ss 0:00 /usr/bin/ssh-agent /usr/bin/dbus-launch --exit-with-session /usr/bin/pulse-session /usr/bin/seahorse-agent --execute x-session-manager
3774 ? S 0:00 /usr/bin/dbus-launch --exit-with-session /usr/bin/pulse-session /usr/bin/seahorse-agent --execute x-session-manager
3780 ? Ssl 0:00 /usr/bin/pulseaudio --start
3781 ? S 0:00 /usr/lib/pulseaudio/pulse/gconf-helper
8454 pts/2 S+ 0:00 grep pulse

ianoux@ubuntu:~$ aplay -l
**** Liste des PLAYBACK périphériques ****
carte 0: Audigy2 [Audigy 2 ZS [SB0353]], périphérique 0 : emu10k1 [ADC Capture/Standard PCM Playback]
Sous-périphériques: 32/32
Sous-périphérique: #0: subdevice #0
Sous-périphérique: #1: subdevice #1
Sous-périphérique: #2: subdevice #2
Sous-périphérique: #3: subdevice #3
Sous-périphérique: #4: subdevice #4
Sous-périphérique: #5: subdevice #5
Sous-périphérique: #6: subdevice #6
Sous-périphérique: #7: subdevice #7
Sous-périphérique: #8: subdevice #8
Sous-périphérique: #9: subdevice #9
Sous-périphérique: #10: subdevice #10
Sous-périphérique: #11: subdevice #11
Sous-périphérique: #12: subdevice #12
Sous-périphérique: #13: subdevice #13
Sous-périphérique: #14: subdevice #14
Sous-périphérique: #15: subdevice #15
Sous-périphérique: #16: subdevice #16
Sous-périphérique: #17: subdevice #17
Sous-périphérique: #18: subdevice #18
Sous-périphérique: #19: subdevice #19
Sous-périphérique: #20: subdevice #20
Sous-périphérique: #21: subdevice #21
Sous-périphérique: #22: subdevice #22
Sous-périphérique: #23: subdevice #23
Sous-périphérique: #24: subdevice #24
Sous-périphérique: #25: subdevice #25
Sous-périphérique: #26: subdevice #26
Sous-périphérique: #27: subdevice #27
Sous-périphérique: #28: subdevice #28
Sous-périphérique: #29: subdevice #29
Sous-périphérique: #30: subdevice #30
Sous-périphérique: #31: subdevice #31
carte 0: Audigy2 [Audigy 2 ZS [SB0353]], périphérique 2 : emu10k1 efx [Multichannel Capture/PT Playback]
Sous-périphériques: 8/8
Sous-périphérique: #0: subdevice #0
Sous-périphérique: #1: subdevice #1
Sous-périphérique: #2: subdevice #2
Sous-périphérique: #3: subdevice #3
Sous-périphérique: #4: subdevice #4
Sous-périphérique: #5: subdevice #5
Sous-périphérique: #6: subdevice #6
Sous-périphérique: #7: subdevice #7
carte 0: Audigy2 [Audigy 2 ZS [SB0353]], périphérique 3 : emu10k1 [Multichannel Playback]
Sous-périphériques: 1/1
Sous-périphérique: #0: subdevice #0
carte 0: Audigy2 [Audigy 2 ZS [SB0353]], périphérique 4 : p16v [p16v]
Sous-périphériques: 1/1
Sous-périphérique: #0: subdevice #0
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
466
1) ton utilisateur ne semble pas faire partie du groupe audio

chez moi :
> redfox@debian[192.168.1.3]:~$ id
uid=1000(redfox) gid=1000(redfox) groupes=20(dialout),24(cdrom),25(floppy),29(audio),44(video),46(plugdev),106(netdev),109(powerdev),110(scanner),112(saned),1000(redfox)
> redfox@debian[192.168.1.3]:
> redfox@debian[192.168.1.3]:~$ cat /etc/group | grep audio
audio:x:29:redfox
> redfox@debian[192.168.1.3]:~$ 


2) ton serveur-son est pulseaudio

3) ta carte-son semble reconnue !


néanmoins :

as-tu essayé de taper la commande suivante :
alsamixer

afin de vérifier que tous les volumes soient à fond (surtout PCM) et que les pistes ne soient pas en mode "mute" (symbole MM en bas de chaque piste).

peux-tu aussi indiquer, lorsque tu es sous alsamixer, ce qui est indiqué en haut à droite, comme chez moi par exemple :
AlsaMixer v1.0.16 (Press Escape to quit)]
Card: Ensoniq AudioPCI 
Chip: Asahi Kasei AK4531
View: [Playback] Capture  All 
Item: Master  
Messages postés
80
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
19 janvier 2012
17
Sous alsamixer, tous les boutons sont sur "MM", on fait comment pour savoir si c'est sur mute ou pas ?
Et comment on fait pour changer ?

Sinon je me suis ajouté au groupe audio.
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
466
sous alsamixer :

les touches droite gauche du clavier pour se déplacer de piste en piste.

touche "M" du clavier pour muter/démuter
Messages postés
80
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
19 janvier 2012
17
Alors j'ai tout changé les "MM" en "00", redémarrer mon ordi et la il y a eu du son quand je suis arriver sur la page de login, et quand je me suis connecté !

Pis j'ai lancé RhythmBox et lancé une chanson et ca marche ! Mais par le son est hyper mauvaise qualité, ya la musique de base, mais ca fait comme si on soufflait dans un micro en meme temps, enfin les basses sont remplacées par des "pff pff pfff"

je dois fais joujou avec les réglages de alsamixer pour que ca aille bien ?
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
466
je ne crois pas que cela soit avec alsamixer que tu vas régler cela !

ton serveur-son est pulseaudio !

tu ne dis pas avec quel lecteur tu lis ta musique ....

tu ne dis pas quel type de fichier audio tu lis : mp3 ? autre ? ....

tu n'as pas répondu à ma question concernant ce qui était affiché en haut à droite dans alsamixer (comme je te l'avais demandé) .....

néanmoins, le souci général sur le son me semble réglé, non ?
Messages postés
80
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
19 janvier 2012
17
Ou pardon pas fait attention !
Alors voici ce qu'il y a en haut :
┌──────────────────[AlsaMixer v1.0.18 (Press Escape to quit)]──────────────────┐
│ Card: Audigy 2 ZS [SB0353] │
│ Chip: SigmaTel STAC9721,23 │
│ View: [Playback] Capture All │
│ Item: Master [dB gain=-12.00]


Sinon c'est bon, j'ai réglé deux trois truc sur alsamixer et le son fonctionne super !
Petite dernier soucis, j'ai 5 enceintes et un caisson de basse, mais les deux prévues à etre placée en arrière de fonctionne pas, je peux régler comment ca ?

Sinon, merci infiniment bob pour m'avoir aidé a régler mon problème !
Thanks dude !
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
466
le son fonctionne super !

alors c'est tout bon !


Petite dernier soucis, j'ai 5 enceintes et un caisson de basse, mais les deux prévues à etre placée en arrière de fonctionne pas, je peux régler comment ca ?

tu veux parler du son 5.1 ???
excuse ma question bête mais je n'y connais pas grand chose en son !

quel est le résultat de :
cat /etc/pulse/daemon.conf | grep default-sample-channels 
Messages postés
80
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
19 janvier 2012
17
Oui je parle bien du son 5.1 !

Ca donne ca :
ianoux@ubuntu:~$ cat /etc/pulse/daemon.conf | grep default-sample-channels
; default-sample-channels = 2


Je suppose de c'est les nombres de canal que j'utilise, c'est a dire 2 colonnes ou plus ?
Comment je fais pour changer ?

Merci beaucoup pour tout en tout cas ;)
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
466
lis attentivement ceci :

https://forums.commentcamarche.net/forum/affich-12391585-5-1-sous-ubuntu-avec-une-unique-jack

tu y trouveras la méthode pour modifier le default_sample_chanel


Merci beaucoup pour tout en tout cas

pas de quoi !!!

:-)

ps : n'hésite pas à nous dire cela cela à complétement résolu ton souci 5.1

merci.
Messages postés
80
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
19 janvier 2012
17
Alors j'ai essayé les commandes, ca règle pas mon problème...

Quand je fais le test, ca cite tout les haut parleurs, et quand c'est ceux a l'arrière qui sont concerné on entend pas... enfin on entend pas dans les colones prévu a l'arrière mais on entend beaucoup moins fort dans celle de devant...
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
466
ha !

peut-être un truc à voir avec pulseaudio ?

si tu es toujours présent on peut regarder ça dans 10 mns ...
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
466
je regarderai en premier lieu dans la configuration de pulseaudio.

je lirai ce lien :
https://fluoblog.wordpress.com/2008/05/24/son-surround-avec-pulseaudio/

qui a utilisé ce tuto (en anglais mais avec une update de mars 2009 donc très récent) :
http://ubuntuforums.org/showthread.php?t=795525

il y a deux méthodes.

as-tu testé les 2 méthodes ?

as-tu regardé avec alsamixer si les nouvelles pistes ne seraient pas mutées ?
Messages postés
80
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
19 janvier 2012
17
Hello !
Désolé de donner signe de vie aussi tard ;)

Alors, voila j'ai suivi ton premier lien, changer ce qu'ils disaient, sauver, redémarrer et tout a l'air de fonctionner sur toutes mes colonnes !

Merci beaucoup pour tout !
Bon après midi :P
Ian.
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
466 >
Messages postés
80
Date d'inscription
vendredi 24 juillet 2009
Statut
Membre
Dernière intervention
19 janvier 2012

problème résolu alors !

tant mieux !

Messages postés
1009
Date d'inscription
dimanche 28 décembre 2008
Statut
Membre
Dernière intervention
29 août 2019
78
Salut,
Il y a aussi, je pense, à cocher plein de choses dans les préférences de alsamixer et ensuite dans options, il faut choisir le nombre de canaux...

A+
Messages postés
4
Date d'inscription
lundi 31 mars 2008
Statut
Membre
Dernière intervention
26 juillet 2009

Hello, désolé j'étais absent ce week end ;)

Alors, je vais passer sous linux dans un tit moment et je vous tiens au courant de tout :P

PS: C'est The Dead T, me suis trompé de compte xD