Pas de son sur Mandriva Linux 2009 Spring [Résolu/Fermé]

Signaler
-
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
-
Bonjour,

J'ai installé sous peu Linux Mandriva 2009 Spring pour me remettre à Linux. La derniere foie, il s'agissait de Linux Mandriva 2008 et je me rappel aussi de ce problème de son, mais j'avais réussi à le mettre par une question de driver.

Ici cependant, j'ai tout fais : alsaconf / alsamixer / le son pas réglé sur 0 / et j'ai installé les derniers drivers !

En faite il s'agit d'une carte son Realtek Haute Définition.. Je peux pas dire quelle marque car "alsaconf" me dit que j'ai une carte Nvidia, ou ATI alors faudrais savoir...
Bref j'ai pris ce driver : LinuxPkg_5.11.tar.bz2 prit sur Tous les Driver

Je l'ai installé sans problèmes... Mais je ne sais pas comment vérifier si un programme est vraiment installé ou non (sachant que j'ai fait configure, make, et make install) Mais je ne l'ai pas ouvert...

Euh quoi d'autre... Ah oui. je fonctionne sous dual boot, et mon son fonctionne sur Window's XP voila =)

Merci de me répondre, et de m'avoir lu :)

8 réponses

Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
467
bonjour,

peut-on avoir le résultat de :

ps ax | grep pulse

id

aplay -l
Merci d'avoir répondu =)

Alors je te donne mes résultats :

ps ax | grep pulse
6467 ? S<sl 0:12 /usr/bin/pulseaudio --start --log-target=syslog
6477 ? S 0:00 /usr/lib/pulse/gconf-helper


id
uid=0(root) gid=0(root) groupes=0(root)

Si c'est pour voir que je suis en root, c'est le cas... ^^

aplay -l
card 0: NVidia [HDA NVidia], device 0: ALC662 Analog [ALC662 Analog]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 0: NVidia [HDA NVidia], device 1: ALC662 Digital [ALC662 Digital]
Subdevices: 1/1
Subdevice #0: subdevice #0
card 1: HDMI [HDA ATI HDMI], device 3: ATI HDMI [ATI HDMI]
Subdevices: 0/1
Subdevice #0: subdevice #0


Ici on remarque que le 3e Subdevices est à 0/1
Si tu pouvais m'en dire plus.. (dis moi ce que c'est au passage =)

Merci =)
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
467
en fait c'est en utilisateur qu'il faudrait le résultat de la commande id
id

uid=500(merom74) gid=100(users) groupes=100(users)

Voila
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
467
essaie ceci :
aplay -D plughw:1,3 /usr/share/sounds/pop.wav


+ résultat de :
cat /proc/asound/oss/sndstat
Alors :

aplay -D plughw:1,3 /usr/share/sounds/pop.wav


aplay: main:590: audio open error: Périphérique ou ressource occupé

Je ne comprends pas je n'utilise rien du tout ^^

cat /proc/asound/oss/sndstat

Sound Driver:3.8.1a-980706 (ALSA v1.0.19_r5.11 emulation code)
Kernel: Linux localhost 2.6.29.3-desktop586-1mnb #1 SMP Thu May 14 13:59:03 EDT 2009 i686
Config options: 0

Installed drivers:
Type 10: ALSA emulation

Card config:
HDA NVidia at 0xdfef8000 irq 21
HDA ATI HDMI at 0xdffec000 irq 19

Audio devices:
0: ALC662 Analog (DUPLEX)

Synth devices: NOT ENABLED IN CONFIG

Midi devices: NOT ENABLED IN CONFIG

Timers:
7: system timer

Mixers:
0: Realtek ALC662 rev1
1: ATI R6xx HDMI


Cette commande à l'air de nous en dire plus
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
467
Je ne comprends pas je n'utilise rien du tout ^^

j'ai la même réponse sur ma mandriva (mais moi je n'utilise pas pulseaudio mais alsa comme serveur son).

en fait il y a quelque chose qui doit utiliser le son (KDE, Gnome, etc .....).

l'idée de la première commande vient d'ici :
http://crunchbanglinux.org/forums/topic/2310/hdmi-ati-hda-sound-how-i-got-hdmi-sound-working-in/

plus trop de temps là ....

@++
Bonsoir !

Je voulais te remercier bob031 de m'avoir guider et aider dans cette aide =)
Grâce à toi j'ai réussi : pour les autres, j'explique ma démarche ;

Tout d'abord, j'ai observé que je possédais 2 cartes sons. Et l'une des deux était sur le "par défaut" et l'autre en secondaire.... Vous devinez tous que, en ayant installé les pilotes, vérifié mes haut parleur, vérifier les logiciels de configuration etc.. je n'avais pas de sous, cela venait de la carte.

Cependant, je dois te contredir sur un point bob : tu m'as donné un lien qui fonctionnait peut etre mais pour les Linux UBUNTU !!! Or je suis sous MANDRIVA Linux. Donc j'ai trouvé le bon lien qui est http://wiki.mandriva.com/
Il y est expliqué comment faire pour inverser le role de ces deux cartes et en français =)

Je vous réexplique si jamais : en faite il faut créer un document texte nommé "asound.conf" placé dans le dossier /etc (vous devez etre en root, donc passez par la console)

Ce qui donne :

vi asound.conf (dans le dossier /etc)

Puis vous copier dedans : le texte suivant :

pcm.!default {
type hw
card 1
}
ctl.!default {
type hw
card 1
}

Puis vous enregistrer et vous quittez (je vous réfère à des guides sur internet pour l'utilisation de vi)

Enfin, vous redémarrer, et le tour est joué !

Merci =) et j'espère avoir aider également d'autre personne
Messages postés
8158
Date d'inscription
samedi 7 août 2004
Statut
Membre
Dernière intervention
1 septembre 2014
467
Cependant, je dois te contredir sur un point bob : tu m'as donné un lien qui fonctionnait peut etre mais pour les Linux UBUNTU !!! Or je suis sous MANDRIVA Linux.

On ne contredit jamais bob !!! -DDDDDD

ok je m'explique ! un Linux sera toujours un Linux ! Ubuntu, Mandriva, Fedora : même combat !

si tu avais été attentif au lien que j'ai donné, il y était question également de créer un fichier asound.conf et voici l'extrait :
8. Assuming that all works, edit /etc/asound.conf (which may not exist yet), put this in it:

pcm.!default {
type hw
card 1
device 3
}



alors, il a pas toujours raison bob ???? -DDDDDDDDDD

Néanmoins, un grand bravo car tu t'es débrouillé tout seul comme un chef !

:-))