Prob de droit avec disque externe

Résolu/Fermé
NitriK - 27 janv. 2005 à 22:38
johndoe
Messages postés
2645
Date d'inscription
jeudi 25 septembre 2003
Statut
Contributeur
Dernière intervention
15 avril 2006
- 27 janv. 2005 à 22:59
Voilà, j'ai un disque dur externe, je fais un mount... il apparait dans /mnt/ tout marche... sauf qu'il y a des droits qui n'autorise que le root a accédé au disque ! Alors je me connecte en root et j'essaye de changer les droits d'utilisateurs sauf que l'on me dit que je ne peux pas faire de changement de droit.

Si quelqu'un a des solutions voir la solution, je suis tout ouïe ^^ merci d'avance.

4 réponses

C'est normal car c'est problablement un systeme de fichiers fat sur ce disque ou la gestion differenciee de droits et de proprietaires n'est pas prevue (ca marche uniquement avec "ext2/3" et autre filesystemes linux.)

La seule solution il faut prevoir un mount en tant qu'utilisateur. Tu ajoute dans le fichier /etc/fstab une ligne comme:
/dev/sda1   /mnt/disque  vfat   noauto,user 0   0

ou /dev/sda1 est le device et /mnt/disque le point de montage, tu y mettras tes propres valeurs! Ce qui importe ce sont les options derriere "noauto,user", avec ca le disque n'est pas monte automatiquement pendant le boot mais apres tout utilisateur normal aura le droit de faire: "mount /mnt/disque" pour le monter et apres tous les fichiers la dedans vont appartenir a lui et non a root! Comme ca l'utilisateur peut lire et modifier les fichiers.

Si tu as la malchance que le disque est en ntfs et non fat la on peut seulement monter en lecture en Linux, mais normalement c'est fat sur de disques externes comme sur les cles USB sauf si tu as formate autrement.
0
johndoe
Messages postés
2645
Date d'inscription
jeudi 25 septembre 2003
Statut
Contributeur
Dernière intervention
15 avril 2006
386
27 janv. 2005 à 22:52
Personnellement, je mets ces params dans le fstab :
/dev/hda6 /mnt/sas vfat auto,users,umask=0 0 0
en modifiant leperiph qui n'est pas /dev/hda6 chez toi, et le nom du directory dans mnt.
Le auto est aussi à éviter pour un periph externe, comme le prevoit kmf.
On reste donc en fat, ce qui est bien pratique, à mon sens, puisque cela permet le passage vers win.
0
Ok merci je vais essayé demain, car là je n'ai plus le temps. Il est pas sous FAT32, mais sous NTFS... et oui je sais... mais ca ne fait que 2 jours que je suis sous Linux.

Je vous tiens au courant si ca fonctionne et je vous remercie déjà pour vos réponse ;)
0
johndoe
Messages postés
2645
Date d'inscription
jeudi 25 septembre 2003
Statut
Contributeur
Dernière intervention
15 avril 2006
386
27 janv. 2005 à 22:59
et bien pour le ntfs, tu ne pourras pas ecrire dessus sans risques....., encore qu'avec captive la knoppix a fait des choses etonnantes ....
0