Installation - adobe flash player [ubuntu] [Fermé]

Signaler
-
 Pierrecastor -
Bonjour tout le monde,

Alors, je vais essayer d'etre clair. Je n'ai pas des masses de connaissances linuxiennes. Alors desolé d'avance pour mon inculture ^^
En fait, je débute avec Ubuntu. Je souhaite juste installer pour firefox, Adobe Flash Player. J'ai le lien : https://get.adobe.com/flashplayer/
Et j ai le choix parmi 4 possibilités. Et aucune n'a l air de fonctionner. Enfin je sais meme pas ce que je dois en faire je selectionne 'ouvrir avec le gestionnaire d archive'

> Yum for linux >> Impossible d'ouvrir « adobe-release-i386-1.0-1.noarch.rpm »

> .Tar.gz for linux >> avec celui là j'ai 2 fichiers flashplayer-installer lib-flashplayer-so. Mais qu'en faire ?

> .Rpm for linux >> Impossible d'ouvrir « flash-plugin-10.0.22.87-release.i386-1.rpm »

> .Deb for Ubuntu 8.04+>> error : dependency is not satisfiable : libacairo2



Je suis perdu. Quel que soit votre conseil je suis preneur.....
Merci d avance

43 réponses

Messages postés
7372
Date d'inscription
lundi 16 juillet 2007
Statut
Contributeur sécurité
Dernière intervention
10 mai 2012
926
Salut , une chose à te souvenir: Ubuntu, c'est .deb
.deb: Il y a l'installateur ''Gdebi'' qui les prends en charge.
Donc, concrètement: Si tu veut installer Adobe flashplayer via le Net ou un autres ''que tu ne trouvrais pas dans le gestionnire Synaptic, tu dois toujours utiliser un .deb , c'est plus simple ainsi.
Il ne faut pas oublier que certains logiciels et plugins sont ''non libres,' et/ou restreints et propriétaires.
Donc, si tu vas sur ajouter/supprimer des logiciels et que dans ton menu déroulant en haut, tu n'aies pas indiqué ''Toutes les applications disponibles'' et que celles soutenues par Carnonical seulement , alors tu limites tes choix de logiciels.
Et dans synaptic si tu recherches ''' flashplugin-nonfree '' devrait s'y trouvé dépendant de ta version d'Ubuntu ...
Et quelle est ta distribution Linux Ubuntu ? Et quelle ? 8.04 ou autre ?
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 63550 internautes nous ont dit merci ce mois-ci

Messages postés
7372
Date d'inscription
lundi 16 juillet 2007
Statut
Contributeur sécurité
Dernière intervention
10 mai 2012
926
Oui je vois ... tu as une vieille version d'ubuntu , le pourquoi aussi de ton vieux firefox.
Tu dis : merci mais j ai pas envie de passer 100h a apprendre tout de linux...
Sais tu qu'en 4 heures sérieuses de lectures, tu sauras plus sur Linux que 4 mois à dériver sur Windows ?
Sous Windows tu as appris par l'exemple, sans te questionner sérieusement ou plus ou moins.
Comment maîtrises-tu Windows après toutes ces semaines ou années ?
J'ai et j'installe encore des distributions Linux et même à des vielles dames et tu sais quoi ? Elles connaissent vraiment comment se servir de Linux en quelques semaines.
Le fait d'avoir connu Windows, est un gros handicap.
Et ce pour tous.
J'ai un ami qui est programmeur depuis 24 ans, puis c'est le plus null et entêté de tous ceux et celles à qui j'ai expliqué Linux.

Alors la version 7.10 est plus vieille que mon temps Linux et depuis ce temps, il a coulé bien de l'eau sous les ponts.
Si tu oublies quelques instant Windows et les réflex associés, tu va avancer rapidenment

Mais, tu dois impérativement lire et ceci te récompensera crois-moi ;-)
Messages postés
7372
Date d'inscription
lundi 16 juillet 2007
Statut
Contributeur sécurité
Dernière intervention
10 mai 2012
926
C'est ce qu'il te dit ici en anglais car tu es tellement pas à jour que même ton terminal est en partie en anglais

E: Impossible de verrouiller /var/lib/dpkg/lock - open (11 Ressource temporairement non disponible)
E: Unable to lock the administration directory (/var/lib/dpkg/), is another process using it?

Et ici il cherche sur la source Cd/ de ta distro pour mettre a jour, alors que dans ton cas ceci est inutile bien-sûr car ton cd si tu as encore est désuet.
Donc a mon idée , ce systeme n'a jamais été configuré correctement et y a de quoi ne pas être tenté par un tel OS. ;-)
Mais c'est à toi de corriger ceci , car même si linux est intelligent, c'est contrairement à Windows ,,, toi le patron .
Messages postés
7472
Date d'inscription
vendredi 14 octobre 2005
Statut
Contributeur
Dernière intervention
5 juin 2020
892
Salut,

et bien pourquoi tu ne passes pas par le gestionnaire de paquet?
C'est plus simple, non?!
parce que je sais pas du tout ce que c est. Ni ce qu il faut faire :(
ah je viens de trouver le gestionnaire de paquets Synaptic mais ca m aide pas, je sais pas du tout comment ca s utilise... mon dieu...
Messages postés
3389
Date d'inscription
samedi 26 avril 2008
Statut
Contributeur
Dernière intervention
8 avril 2020
395
Messages postés
7472
Date d'inscription
vendredi 14 octobre 2005
Statut
Contributeur
Dernière intervention
5 juin 2020
892
Messages postés
7372
Date d'inscription
lundi 16 juillet 2007
Statut
Contributeur sécurité
Dernière intervention
10 mai 2012
926
Ainsi que ceci sur la table de chevet
http://www.framabook.org/ubuntu.html
Mouais pour les liens merci mais j ai pas envie de passer 100h a apprendre tout de linux... Mais c'est gentil quand meme. Je ne veux absolument pas me lancer dans linux. Je voulais juste installer cette chose, car quelque soit le site ou je vais, je ne peux rien faire car je n'ai pas le flash player d'installé. Super mais je demande que ca moi. malgré le lien débouchant sur "simple comme linux" personnellement, je ne pense pas que les mots "simple" et "linux" soient compatibles. Comme là, je veux pas faire quelque chose d exceptionnellement compliqué. Et n'y connaissant rien, tout me parait insurmontable et les seules aides que je trouve comprennent les mots "installer des paquets" "flashplugin-nonfree" et il semble qu il y ait 10000 methodes differentes... Ca deprime. Je sais que pour vous tout parait facile et que je passe pour un incompétant mais c'est comme ca, je connais que Windows. Bref.

@jalobserviteur apres avoir longtemps cherché ma version d ubuntu : 7.10, je sais pas si ca aide et dans mon gestionnaire de paquet j ai pas le "flashplugin-nonfree"
Messages postés
3389
Date d'inscription
samedi 26 avril 2008
Statut
Contributeur
Dernière intervention
8 avril 2020
395
il faut se documenter un minimum sauf si tu veux conserver l'esprit formaté microsoft. D'autant que tu te doutes bien que la simple question que tu poses à propos de cette saleté de flash player a été abordée des centaines de fois, c'est un peu étrange comme attitude, ou plutot comme constat.
@ezula Mais je me documente. et j'ai meme fait des etudes d informatique, ce qui m'a pas réussi d'ailleurs. Et je me doute bien que ceci a été traité plein de fois. J'ai recherché avant de poster. Maintenant c'est facile de trouver des choses là dessus. Mais c'est INCOMPREHENSIBLE pour moi. Je suis noyé par des liens, des termes que je ne comprends pas. Bref, si ca vous embete tant que ca laissez tomber c'est pas grave. Desole de vous avoir communiqué ma mauvaise humeur tardive.

@jalobservateur euh, j ai fait des etudes informatique, et ai travaillé sous linux. et non je pense pas que ce soit si facile d'apprendre. Vu le peu de choses que j en ai retenu. Mais oui, l'handicap est surement ma trop grande habitude a windows
Messages postés
7372
Date d'inscription
lundi 16 juillet 2007
Statut
Contributeur sécurité
Dernière intervention
10 mai 2012
926
Oui comme je le disais lol!
Il va te falloir une désintox mon ami !
Bilou t'a dans le colimateur ...
C'est toujours ainsi quand on connais Windows on bloque sur Nux.
Mais tu n'est sûrement pas une cause perdue ;-)
J'en ai vu d'autres...
Messages postés
7372
Date d'inscription
lundi 16 juillet 2007
Statut
Contributeur sécurité
Dernière intervention
10 mai 2012
926
Alors pourquoi ne pas simplement rafraichir ta distribution Ubuntu car je te donne un simple exemple.
j'ai plusieurs boot sur 1 teragigs de disques et sur la distro que j'écris en ce moment : ''Artistx 8.10'' ( Que je n'upgrade pas en 9.04 simplement à cause du pilote proprio fglrx dont je me plais là, je n'ai absolument rien eu à installer via Fox ou par synaptic pour les flashs, et plugins videos quelqu'ils soient, car ils sont tous là d'office.
Alors à ta période Linux, même si elle date d'un an, alors elle est désuette , car Linux avance plus en une semaine que Bilou en 4 ans.
Messages postés
3389
Date d'inscription
samedi 26 avril 2008
Statut
Contributeur
Dernière intervention
8 avril 2020
395
la question te parait simple parceque c'est vrai qu'avec l'habitude sous windows d'aller dans ajout suppression de propgrammes (personne n'a jamais vraiment compris pourquoi le mot "ajout" s'est glissé là-dedans d'ailleurs), ou encore en allant chercher ton setup sur le web ça semble trivial. C'est surtout les années de pratique machinale qui donnent cette impression. Chercher des programmes à l'extérieur est inconfortable et potentiellement dangereux

En fait il faut décortiquer l'opération. Installer un paquet sous GNU/Linux, cela suppose par exemple :
- d'avoir connaissance du gestionnaire de paquets
- d'avoir les dépôts du gestionnaire de paquets actualisés et opérationnels
- de rechercher le paquet, donc de connaitre la méthode qui permet de tomber dessus
- de comprendre le système de dépendances entre paquets
- et enfin de l'installer

Est-ce qu'il faut te détailler tout ça alors que c'est très bien expliqué sur les liens qui t'ont été donnés ?

c'est pas du tout de la mauvaise humeur mais je crois que ce système exige un minimum de distance et d'autonomie, donc fatalement de savoir, sinon ça n'en vaut pas la peine.
lol. parce que je pense (et espere) ne pas rester tres longtemps sur Linux. c'est juste que j'ai comme qui dirait une panne de windows. et que linux marche miraculeusement, or c est une ancienne version que je n'avais pas touchée depuis longtemps. c'est juste qu'en attendant, je voulais juste ce p***** de flash player... pour au moins faire quelques trucs sur internet. lol
et meme si il y a surement plein de points positifs avec linux, serieusement pour installer ca. sous windows, tu cliques, ca s installe tout seul. Là tu cliques et t'as 10 messages d erreur...
Mais oui, je me doute que linux avance plus car plein de monde y travaille ^^
Utilisateur anonyme
Bonsoir, dans ton gestionnaire synaptic tu tape " flashpluging-nonfree"

Ou dans la console , mais bon faut savoir ou ce trouve ces petite bête aussi ;)

Taper sudo apt-get install flashpluging-nonfree


Quand je lie ce que tu met sur ton poste , tu a raison retourne sur win , car la au moins il y a du travail ;)
> Utilisateur anonyme
@tomy6669
Mais meme si je ne connais pas tout j'ai quand meme quelques micro-connaissances et j'ai déjà essayé de taper flashpluging-nonfree dans le gestionnaire synaptic (que non, je ne connaissais pas). mais il n'y est pas. et je ne sais pas comment faire pour que ce flashpluging-nonfree s'y trouve justement.

Quant au sudo apt-get install flashpluging-nonfree j'avais fait aussi mais ca ne fonctionne pas. pourtant oui je pensais que le sudo était censé me donner les droits et le reste de la commande installer ce flashpluging machin chose.
Messages postés
7372
Date d'inscription
lundi 16 juillet 2007
Statut
Contributeur sécurité
Dernière intervention
10 mai 2012
926
100 % ezila ;-)
Bien-sûr sans jouer aux aguicheuses de Pig???&*? , les diverses distributions Linux, Ubuntu, Madriva en tête, tentent d'être le plus possible ''Freindly users'', si on entends par ceci de ressembler en utilisation de tous les jours à un Windows amélioré, plus stable, solide et beau.
Mais Windows n'est pas Linux et l'inverse.
Et le jour ou Linux sera comme Windows, moi je fout le pc par la fenêtre !
Car il aura une appellation juste selon moi "Windows''. Et tel sera sa destiné.
Alors, oui Linux peut dans une certaine mesure accomoder les Windowsiens , mais non à outrance.
Et pour moi l'outrance et le mur qui nous sépare d'elle est très mince.
Je ne crois pas que Linux doivent tenter d'imiter, car Windows le fait déjà à l'égard de Linux et il y a de bonnes raisons.
Donc les utilisateurs potentiels ont 2 choix.
1: Continuer de faire confiance à un système fermé et tout sauf fiable , mais se confondant avec la masse.
2: S'arrêter quelques heures afin d'ouvrir nos esprits et avoir un minimum de défits à relever, puis se distinguer de la masse en comprenant les gestes que nous portons.
Et ceci sans lecture et intérogations c'est non seulement non souhauitable mais inutile.
@ezula merci pour les details. oui, il est vrai que si je connais pas tout ca, ca aide pas. enfin j ai quelques connaissances mais je melange un peu tout. c'est surtout que deja yavait plein de methodes differentes et que le .deb mene a un message d erreur qui me dit que j ai pas libacairo2 qui n'apparait nulle part ni dans ajouter/supprimer ni dans le gestionnaire de paquets... enfin bon, je vais pas vous saouler toute la soiree avec ca ^^.

j'abandonne. rien de grave. priez avec moi pour que mon windows refonctionne :)
Messages postés
7372
Date d'inscription
lundi 16 juillet 2007
Statut
Contributeur sécurité
Dernière intervention
10 mai 2012
926
Oui avec Windows, tu dois prier je sais , mais au-delà du monde ''méthaphysique'' il y a aussi la compréhension simple et expliquable sur Linux ;-)
Messages postés
7372
Date d'inscription
lundi 16 juillet 2007
Statut
Contributeur sécurité
Dernière intervention
10 mai 2012
926
Finalement, je pourrais te nommer des dixaines de personnes ici sur CCM qui sont passés à Linux et qui maintenant non seulement comprennent mais expliquent au bout que de quelques mois en intervenant sur divers forums.
Alors ceci est tangible ;-)
Bonne soirée nuit à vous