Somme.si sur deux plages de cellules [Résolu/Fermé]

Signaler
Messages postés
15
Date d'inscription
mardi 19 mai 2009
Statut
Membre
Dernière intervention
9 octobre 2013
-
Messages postés
16376
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
25 janvier 2021
-
Bonjour,

J'ai deux onglets dans mon documents Excel:
1er onglet "Médicaments" : Cellule A3 = nom du site, B3 = numéro du médicament, E3 = mouvements (entrée).
2ème onglet "Mouvements": Cellule B3 = nom du site, C3 = numéro du médicament, D3 = mouvements (entrée).

Dans l'onglet "Médicaments", il y aura une ligne par médicament, sachant que le même médicament existe pour chaque site (hôpital) (il y a 3 hôpitaux: P, D, S). On trouvera dans chacune de ces lignes, un cumul des mouvements de l'onglet "Mouvements" représentant le médicament par site (3 lignes par médicaments: 1 ligne par hôpital).

Donc, dans le 1er onglet "Médicaments", il devrait y avoir une récapitulation des mouvements de l'onglet "Mouvements", sachant que le nom du site et le numéro du médicament doivent être identiques dans les 2 onglets. Il y a dans cet onglet 2000 mouvements possibles.
J'ai taper la formule suivante dans l'onglet "Médicaments", cellule E3, mais malheureusement elle n'est pas juste:
=SI(ET(Mouvements!C$3:C$2000=B$3:B$2000;Mouvements!B$3:B$2000=A$3:A$2000);Mouvements!D$3:D$2000;0)

Pouvez-vous svp m'aider à trouver la bonne formule ?
D'avance mille merci de me répondre à l'adresse: bernard.bonvallat@h-ju.ch .

2 réponses

Messages postés
822
Date d'inscription
mercredi 15 octobre 2008
Statut
Membre
Dernière intervention
8 octobre 2011
171
bonjour;
joindre votre fichier par le lien:
http://www.cijoint.com
Messages postés
15
Date d'inscription
mardi 19 mai 2009
Statut
Membre
Dernière intervention
9 octobre 2013

Désolé, mais je n'ai jamais utilisé ce procédé. Comment faire ? Merci d'avance de votre intérêt pour mon problème.
Messages postés
16376
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
25 janvier 2021
3 120
Bonjour, Pourquoi met tu ton mail pour avoir la réponse?
conséquences:
1/Personne ne sait si une réponse valable a été formulée
2/ comme personne ne voit cette solution, le but du forum, le partage des connaissance, est éradiqué
3/ Enfin, laisser une adresse mail sur un forum est du pain béni pour les spammeurs, mais c'est ton pb

essaie en E3 de ta feuille "médicaments"
=sommeprod((Mouvements!C$3:C$2000=B3)*(Mouvements!B$3:B$2000=A3)*(Mouvements!D$3:D$2000))
à tirer vers le bas