Excel, fonction NB.SI

Fermé
Bob - 14 mai 2009 à 14:47
 Anai08 - 14 mai 2009 à 22:19
Bonjour,

J'utilise la fonction NB.SI sans problème. Par contre je voudrais savoir s'il est possible d'assortir plusieurs critères, en comptabilisant, par exemple dans la liste ci-dessous, le nombre de fois France et Suisse.

France
Allemagne
Italie
France
Danmark
Suède
France
etc...

Mieux encore, si je pouvais additioner selon plusieurs critères qui se trouveraient dans une plage de cellules ailleurs. En modifiant ces cellules-là, je pourrais choisir d'autres critères à comptabliliser sans devoir toucher la formule
A voir également:

3 réponses

Mike-31 Messages postés 18306 Date d'inscription dimanche 17 février 2008 Statut Contributeur Dernière intervention 14 février 2024 5 063
14 mai 2009 à 15:26
Salut,

Si les données sont dans la même plage

=NB.SI(A1:A40;"France")+NB.SI(A1:A40;"Suisse")

Si les données sont sur deux plage

=NB.SI(A1:A40;"France")+NB.SI(C1:C40;"Suisse")

Si les données sont sur deux feuilles

=NB.SI(A1:A40;"France")+NB.SI(Feuil2!A1:A40;"Suisse")

Mais dans ce cas je propose que tu allonge ta formule


=NB.SI(Feuil1!A1A1:A40;"France")+NB.SI(Feuil2!C1:C40;"Suisse")

A+
Mike-31

Un problème sans solution est un problème mal posé  (Einstein)
0
Bonsoir,
Je viens de poster un question d'excel et de fonction si ...

si vous pouvez jeter un oeil ? ce serait sympa. Je sèche
Merci
Anaï
0
OK merci.
J'espérais qu'il existe un moyen de définir en une fois une plage contenant tous les critères, pour éviter de mettre une formule distincte pour chaque critère, style =NB.SI(A1:A20;C2:C4), en ayant dans les cellules C2, C3 et C4 des critères que je pourrais définir à volonté...mais apparemment ça fonctionne pas...

Merci pour la rapidité:-)
Bob
0
eriiic Messages postés 24560 Date d'inscription mardi 11 septembre 2007 Statut Contributeur Dernière intervention 15 février 2024 7 205
14 mai 2009 à 21:42
Bonsoir,

Ce que tu veux existe, c'est bdnbval().

eric
0