Lien hypertexte et formule SI ... [Résolu/Fermé]

Signaler
-
Messages postés
1769
Date d'inscription
lundi 7 avril 2008
Statut
Membre
Dernière intervention
15 juin 2020
-
Bonjour,
Je n'ai pas réussi à trouver la solution de mon problème malgré mes mulptiles recherches.
Alors voila mon problème est le suivant :

J'aimerais qu'un lien hypertexte s'active grace à une condition émise par une formule SI, explication par exemple:

A1 = marque voiture
A2 = SI(A1=renault;internet;"")

J'aimerai que dans la cellule A2, il y ai un lien hypertexte intitulé internet qui mène au site de renault quand (et seulement dans ce cas) la marque de la voiture en A1 est renault.
J'ai trouvé comment créer des lien hypertexte (evidement...), comment faire des formules si mais pas moyen de faire les 2...

J'avais testé ca :

A2 = SI(A1=renault;"=LIEN_HYPERTEXTE("http://sitederenaut";"internet")";"")

Le problème de la formule etant que je doit impérativement mettre des "" avant la formule et après la fomrule du lien hypertexte pour que la formule ce valide, seulement évidement quand la condition est rempli il m'écrit la fomrule...mais ca ne marche pas >.<

Quelqu'un pourrait m'aider, me conseiller??

Merci d'avance !!

3 réponses

Messages postés
8700
Date d'inscription
dimanche 8 avril 2007
Statut
Contributeur
Dernière intervention
22 janvier 2020
1 128
Bonjour,
=SI(C5="Renault";LIEN_HYPERTEXTE(C7;"Renault");"")

Mais il faut cliquer sur la cellule
Pour rendre cela automatique je pense qu'il faudra passer par VBA.
NB: Je ne vois pas la nécessité de mettre une condition sauf si tu à beaucoup de liens.
A+
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 76687 internautes nous ont dit merci ce mois-ci

Lol terrible la solution était donc sous mon nez!!

Merci beaucoup tu ma évité de m'arracher les cheveux :D

++
Messages postés
1769
Date d'inscription
lundi 7 avril 2008
Statut
Membre
Dernière intervention
15 juin 2020
553
voilà une solution pour calcul automatique

=SI(A1=1;lien_ajout(A2);lien_supp(A2))

avec les fonctions suivantes :

Function lien_ajout(cellule)

URL = "http://site_renault"
nom = URL & cellule.Address
ActiveSheet.Hyperlinks.Add anchor:=cellule, Address:=URL, TextToDisplay:=nom
lien_ajout = URL

End Function


Function lien_supp(cellule)

URL = "http://site_renault"
nom = URL & cellule.Address
ActiveSheet.Hyperlinks(nom).Delete
lien_supp = ""

End Function