CONVERTIR DATE EN NUMERO DE SEMAINE [Fermé]

Signaler
-
Messages postés
16445
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
7 mai 2021
-
Bonjour,

J'ai un tableau avec une date de début de travaux et une date de fin de travaux que j'aimerais retranscrire sur un planning en semaine ces informations pour voir le nombre de chantier par semaine
A voir également:

3 réponses

Bonsoir
Voir réponses en bas de page (Fonction NO.SEMAINE)
6
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 65492 internautes nous ont dit merci ce mois-ci

Bonsoir,
ATTENTION, si l'on veut calculer des numéros de semaines ISO, ceux en particulier du calendrier français, il ne faut pas utiliser la fonction NO.SEMAINE proposée par l'Utilitaire d'analyse. Celle-ci renvoie un numéro de semaine calculé d'après la méthode utilisée aux Etats-Unis, qui n'est pas conforme à la définition ISO utilisée en France. Pour obtenir un numéro conforme à cette norme, on peut utiliser la formule suivante :
=ENT((D4-SOMME(MOD(DATE(ANNEE(D4-MOD(D4-2;7)+3);1;2);{1E+99;7})*{1;-1})+5)/7)
D4 étant la cellule contenant la date ;
à+
> mbz0804
merci pour la formule car j'avais essayer autant avec NO.SEMAINE et aussi WEEKNUM et celà n'avait pas marché.
je te remerci encore.
Elle ne fonctionne pas aussi.
Messages postés
16445
Date d'inscription
lundi 12 septembre 2005
Statut
Contributeur
Dernière intervention
7 mai 2021
3 170 > 555
le 1° janvier 20155 était un jeudi...
avec le 31/12/14 en A1
=SI(A1=0;"";(ENT(MOD(ENT((A1-2)/7)+0,6;52+5/28))+1)) renvoie la semaine ISO=1--> VRAI
en utilisant
=NO.SEMAINE(A1) renvoie 53 ---> faux
Messages postés
33
Date d'inscription
vendredi 23 octobre 2009
Statut
Membre
Dernière intervention
14 février 2014
2
NO.SEMAINE(1/8/2010;2) donne semaine 31
Bonjour ,
il suffit d'entrer cette formule dans une cellule du tableur EXCEL:
=ENT((D4-SOMME(MOD(DATE(ANNEE(D4-MOD(D4-2;7)+3);1;2);{1E+99;7})*{1;-1})+5)/7)

D4 étant par exemple la référence de la cellule dans laquelle la date est saisie du style 05/02/2009
à+
Cette formule ne fonctionne pas si la date est le 1er aout 2010. on obtient la semaine 30 au lieu de la semaine 31
Messages postés
24043
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
6 mai 2021
6 760
Le 1er Aout est bien semaine 30 si on considère, comme en france, que la semaine commence le lundi.
eric
Essayer.
=ENT(MOD(ENT((D6-2)/7)+0,6;52+5/28))+1