SI trois conditions et une seule réponse

Fermé
José - 22 janv. 2009 à 13:24
Raymond PENTIER
Messages postés
56676
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 septembre 2022
- 29 janv. 2009 à 15:48
Bonjour à tous,

J'ai deux cellules A1 & B2
il doit test

si A1 = " " (vide)
et
si B2 =" " (vide)

et mettre "" (vide) dans une autre cellule exmeple E10

ensuite

il teste A1 ; si A1 = "X" alors il mets "ouvert" sinon rien

et ensuite

il teste B2 ; si B2 = "X" alors il mets "fermé"" en B10 sinon rien

mais en B10 ; je dois avoir trois réponses possibles ; soit ="" (vide) soit "ouvert" soit "fermé"

j'ai cette formuile qui ne marche pas........???????????????

=SI(OU(A1="X";B2="X");"à créer";"retour SIL")+SI(A1+B2="";"")

merci de votre aide

José

4 réponses

HELP ME......................!
0
Raymond PENTIER
Messages postés
56676
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 septembre 2022
17 183
23 janv. 2009 à 05:08
à première vue =SI(OU(A1="X";B2="X");"à créer";"retour SIL")+SI(A1+B2="";"") ne peut pas marcher à cause du +

=SI(OU(A1="X";B2="X");"à créer";"retour SIL") par contre peut donner quelque chose.
Mais SI(A1+B2="";"") est incomplet, il manque la valeur à afficher si lacondition n'est pas remplie.

Ce n'est qu'un début d'analyse ...
0
Merci pour ta réponse, mais vu que tu as l'air de connaître...Je te prépare une question qui vaut son pesant de cacahuètes....
0
Utilisateur anonyme
27 janv. 2009 à 22:22
Bonsoir Ray, et là c'est bien du xls pour le moment...
0
Raymond PENTIER
Messages postés
56676
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 septembre 2022
17 183 > Utilisateur anonyme
27 janv. 2009 à 22:55
En effet, cocotehier : Au moins on va tomber dans des emmerdes connues !
0
Raymond PENTIER
Messages postés
56676
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 septembre 2022
17 183
28 janv. 2009 à 01:38
José, salut. Je reprends l'énoncé initial de ton problème :
si A1="" et B2 ="" et mettre "" dans une autre cellule exemple E10
Cela implique que la formule se trouve écrite dans la cellule E10, sous la forme
=SI(ET(A1="";B2="");""; suite de la formule).

Ensuite tu écris :
il teste A1 ; si A1="X" alors il mets "ouvert" sinon rien
On peut supposer que c'est toujours dans la case E10. La formule a évolué :
=SI(ET(A1="";B2="");"";SI(A1="X";"ouvert";"")).

Mais ensuite arrive :
il teste B2 ; si B2="X" alors il mets "fermé"" en B10 sinon rien
Et ça, ce n'est pas possible : tu ne peux pas, depuis E10 où se trouve la formule, commander le contenu de B10 ! Alors ou c'est toujours en E10 que va s'afficher "fermé", ou il faut saisir une deuxième formule dans B10.
Mais je pense que tu as juste fait une petite erreur de frappe, et qu'il s'agit toujours de E10. Nous aurons donc :
=SI(ET(A1="";B2="");"";SI(A1="X";"ouvert";SI(B2="X";"fermé";""))).

Est-ce ce que tu désirais ? https://www.cjoint.com/?bEbL7AgHb5
0
Raymond Salut,

J'ai trouvé tout seul la formule qui me convient parfaitement, je vais quand même lire attentivement ton email pour vérifier et comprendre si ta formule pourrait convenir.
Merci de ton aide, mais je n'oublie ce que je t'avais promis, le plus simple, c'est de te faire parvenir le fichier, donnes-moi une adresse, c'est une doc de travail donc confidentiel, merci.

José
La formule...!!!!

=SI(Z17="X";"à créer";SI(W17="X";"retour SIL";SI(Z17="";"";SI(W17="";""))))
0
Raymond PENTIER
Messages postés
56676
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 septembre 2022
17 183 > José
29 janv. 2009 à 05:30
Je préfère que seuls les membres inscrits au forum puissent avoir mon adresse e-mail, qu'ils peuvent obtenir en consultant mon profil.
Et si tu envisages d'utliser de nouveau les services de CCM et de ses forums, tu devrais t'inscrire sans tarder ; c'est facile, rapide et gratuit ! Et ça t'apporte quelques facilités supplémentaires, dont l'utilisateur anonyme ne peut profiter.
0
Raymond PENTIER
Messages postés
56676
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 septembre 2022
17 183
29 janv. 2009 à 05:44
=SI(Z17="X";"à créer";SI(W17="X";"retour SIL"; SI(Z17="";"";SI(W17="";"")) ))

Et que se passe-t-il lorsque ni Z17 ni W17 ne sont égaux ni à "" ni à "X" ? Ta cellule affiche "FAUX" !
0
Bonjour Raymond,

Mais je suis inscrit sur le forum !
Je ne sais pas ce qu'il faut faire de plus ?
Enfin je vais regarder attentivement.
Merci pour l'info

José
0
josé > josé
29 janv. 2009 à 13:36
Hello !
0
Raymond PENTIER
Messages postés
56676
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
27 septembre 2022
17 183 > josé
29 janv. 2009 à 15:48
Non, tu n'es pas inscrit comme membre :

Mets le curseur au-dessus de mon nom, en haut d'un post ► tu vois ma photo, le nombre de messages que j'ai postés et la date de mon inscription comme membre.

Mets le curseur au-dessus de ton nom ► c'est marqué "Utilisateur anonyme".
0