Serveur dns sous linux
Fermé
Bonjour tt le monde ;-)))
Je configure ma Redhat 7.3 pour en faire un serveur DNS(j'installe les packages bind et named)mais lorsque je configure(nom du serveur, du domaine, des clients...) mon fichier named.conf, je n'arrive pas a redémarrer le service named.
Merci d'avance de votre aide
Je configure ma Redhat 7.3 pour en faire un serveur DNS(j'installe les packages bind et named)mais lorsque je configure(nom du serveur, du domaine, des clients...) mon fichier named.conf, je n'arrive pas a redémarrer le service named.
Merci d'avance de votre aide
12 réponses
-
-
Bonjour,
Il y a un gros probleme dans la config :
la zone 127.0.0 a été bidouillée : on y voit 127.0.0:7: !!!!
Pour ajouter une config on crée 2 fichiers dans /etc/bind
Exemple :
Le fichier : db.toto.org
$TTL 3h
@ IN SOA pc-client.toto.org. root.toto.org. (
20080327
8H
2H
1W
1D )
NS pc-client.toto.org.
pc-client A 192.168.1.1
poste22 A 192.168.1.22
poste23 A 192.168.1.23
routeur A 192.168.1.254
; Alias
le fichier : db.192.168.1
$TTL 3h
@ IN SOA pc-client.toto.org. root.toto.org. (
20080327
8H
2H
1W
1D )
@ IN NS pc-client.toto.org.
1 IN PTR pc-client.toto.org.
22 IN PTR poste22.toto.org.
23 IN PTR poste23.toto.org.
254 IN PTR routeur.toto.org.
La 1er fichier sert à la resolution de nom, le second à la résolution inverse.
Pour activer ces fichiers de conf, il faut declarer les zones dans le fichier /etc/bind/named.conf.local
zone "toto.org" {
type master;
file "/etc/bind/db.toto.org";
forwarders{};
};
zone "1.168.192.in-addr.arpa" {
type master;
file "/etc/bind/db.192.168.1";
forwarders{};
};
Dans le fichier /etc/bind/named.conf.options
forwarders {
80.10.246.1;
80.10.246.2;
80.10.246.129;
80.10.246.132;
};
Dans les options on y ajoute les DNS de sont fournisseur d'acces (uniquement).
Ensuite il faut faire un /etc/init.d/bind9 reload
Les erreur sont detaillees dans /var/log/syslog
Bind ne tolere aucune erreur, pas le moindre point-virgule ne doit etre omis !!! -
bonjour,
merci de m'expliquer ce message d'erreur, je suis entrain de configurer un serveur DND sous centos 5.1
-----------------------------------------------
[root@pc-client ~]# service named restart
Arrêt de named : [ÃCHOUÃ]
Démarrage de named :
Erreur dans la configuration appelée:
dns_rdata_fromtext: zone/127.0.0:7: near eol: unexpected end of input
zone 0.0.127.in-adr.arpa/IN: loading master file zone/127.0.0: unexpected end of input
_default/0.0.127.in-adr.arpa/IN: unexpected end of input
[ÃCHOUÃ]
----------------------------------------------------- -
Je suis sous Debian moi et avec le paquet Bind vient avec 2 binaires qui vérifient vos conf :
named-checkconf <filename>
named-checkzone <filename>
Déjà vérifier vos conf et allez faire un tour sur zonecheck pour qu'il aille vérifier votre DNS... Suivez ce tuto pour les détails de l'installation de Bind -
Modérateurbon on reprend...
si tu es sur que ton fichier named.conf est bon, es-tu sur de la syntaxe des fichiers de zone dns?
quand tu cree une zone ca doit ressembler a ca:
zone "mazone.fr" {
type master;
file "/var/named/mazone.fr.zone";
};
tu dois donc apres cela creer un fichier /var/named/mazone.fr.zone dans lequel seront inscrites tes infos de zone.
quand tu crees une zone dns, tu
.O No parachute? Wow! This is so cool!
(_)__... Castor - Gonzo -
je ne trouve tjrs pas de solution pour mon serveur dns sous linux
help me
merci d avance -
pourtant j'ai fait le même que sur le site de toolinux
-
C est que ton fichier texte named.conf est mal configuré
cherche des exemples sur le net. -
j'ai essayé killall -HUP named at ça ne marche pas.
Est ce que quelqu'un a une idée.
merci d'avance -
merci Kefka pour ton aide.Je vais voir ce que ça donne
@ plus -
ContributeurTu es un drôle d'oiseau Kefka.
Ton site n'est pas net.
:,§_ ç _
(@)=(@) -