Serveur web sous linux [Résolu/Fermé]

Signaler
Messages postés
56
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
27 février 2009
-
Messages postés
56
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
27 février 2009
-
Bonjour ,
je viens de mettre en place un serveur web sous fedora 9 , seulement l'hebergement se fait en local, j'ai juste pu m'acheter le nom de domaine ,
seulement j'arrive à acceder à mon site via son adresse ip de partout , alors qu'avec son alias , www.nomdedomaine.fr , lr site est introuvable.
Je pensais que cela venait de la resolution DNs , je viens de configurer le serveur web comme etant Serveur dns , en precisant le DNS de mon forunisseur internet , rien ne se fait.
Alors , si vous pouver me resumer les grandes lignes d'un hebergement en local de domaine acquis d'un FAI, cela me permettrai de vite reperer le soucis.
Le test de dns est positif, bien configurer
Sinon l'adresse ip mappée à mon nom de domaine doit forcement être celle de mon serveur?
Merci pour votre aide.
à très bientot

8 réponses


il y a un temps de propagation d'ip ce qui veut dire que tu dois attendre quelques heures avant que les effets se fassent sentir
si tu passe par un routeur, le nom de domaine doit pointer sur celui-ci puis le routeur redirigera vers ton serveur (comme tu as du faire pour configurer la redirection d'IP)

Ceci est seulement dans le cas où tu utilise un routeur !
Messages postés
56
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
27 février 2009

Bonjour,
merci pour votre collaboration les gars,
effectivement il fallait gerer la rediction au niveau de mon routeur et vers l'@ qui pointe vers mon nom de domaine.
on en a une de resolu.
après installation de mon pack , php, mysql, phpmyadmi, je n'arrive pas à acceder mon interface pour loger ma base de donnée,
il s'agit d'un probleme de droit. je ne sais pas trop à quel niveau il 'agit , alors j'attends de vous des details sur la question.
Le message d'erreur est le suivant en voulant faire http://localhost/phpmyadmin:

Forbidden
You don't have permission to access /phpmyadmin on this server.


------------------------------------------------------------­--------------------

Apache/2.2.8 (Fedora) Server at @ip Port 80
j'ai refait le tour des forums sans suite , alors aidez moi s'il vous plait.
je vous serrez reconnaissant de me détailler votre solution
Je suis sur fedora 9 et
Configuration: Windows 2000
Internet Explorer 6.0
Messages postés
31
Date d'inscription
mercredi 6 août 2008
Statut
Membre
Dernière intervention
7 avril 2009
2
SALUT JE PENSE QU'IL FAUT RESPECTER LA CASSE LORSQUE TU ECRIS PHPMYADMIN. ESSAIS:
http://localhost/phpMyAdmin POUR VOIR CE QUE çA DONNE.
Ahmad111
Messages postés
31
Date d'inscription
mercredi 6 août 2008
Statut
Membre
Dernière intervention
7 avril 2009
2
penses aussi à démarrer/redémarrer avant tout le service mysql !!!BONNE CHANCE
Messages postés
56
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
27 février 2009

j'ai bien respecté la casse , j'ai arreté et redemaré les services , rien de mieux ,
voici ce qu'il m'affiche comme erreur.

2002 - Le serveur ne r�pond pas. (ou l'interface de connexion ("socket") vers le serveur MySQL local n'est pas correctement configur�e)

j'ai revu ma config , rien à signaler en ma connaissance
alors je compte sur vous pour l'issu de sortie.
Messages postés
248
Date d'inscription
mercredi 6 février 2008
Statut
Membre
Dernière intervention
3 décembre 2009
19
dans ton fichier de configuration apache vérifie que tu as les accès distants.
Messages postés
56
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
27 février 2009

après quelques recherches sur le sujet, je suis arrivé à renseigner quelques champs sur le fichier config.inc.php et cela m'a permi de voir l'interface se lancer , seulement je suis bloqué sur les identifiants de connexion.
je n'ai pas specifié de mot de passe , le user c'est le root,
J'ai ma page de connexion , en meme temps j'ai deux messages d'erreurs qui ne me permettent pas d'acceder à la page d'administration de ma base
Les deux messages sont les suivants:

20002 le serveur ne repond pas , ou l'interface de connexion(socket) vers le serveur mysql local n'est pas correctement configurée

j'ai un averstissment comme quoi php ne peut prendre en charge l'extension mcrypt .
merci pour votre apport voici mon fichier de config



<?php

/**
* Server(s) configuration
*/
$i = 0;
// The $cfg['Servers'] array starts with $cfg['Servers'][1]. Do not use
// $cfg['Servers'][0]. You can disable a server config entry by setting host
// to ''. If you want more than one server, just copy following section
// (including $i incrementation) serveral times. There is no need to define
// full server array, just define values you need to change.
$i++;
$cfg['Servers'][$i]['host'] = 'localhost'; // MySQL hostname or IP address
$cfg['Servers'][$i]['port'] = ''; // MySQL port - leave blank for default port
$cfg['Servers'][$i]['socket'] = ''; // Path to the socket - leave blank for default socket
$cfg['Servers'][$i]['connect_type'] = 'tcp'; // How to connect to MySQL server ('tcp' or 'socket')
$cfg['Servers'][$i]['extension'] = 'mysql'; // The php MySQL extension to use ('mysql' or 'mysqli')
$cfg['Servers'][$i]['compress'] = FALSE; // Use compressed protocol for the MySQL connection
// (requires PHP >= 4.3.0)
$cfg['Servers'][$i]['controluser'] = ''; // MySQL control user settings
// (this user must have read-only
$cfg['Servers'][$i]['controlpass'] = ''; // access to the "mysql/user"
// and "mysql/db" tables).
// The controluser is also
// used for all relational
// features (pmadb)
$cfg['Servers'][$i]['auth_type'] = 'cookie'; // Authentication method (config, http or cookie based)?
$cfg['Servers'][$i]['user'] = 'root'; // MySQL user
$cfg['Servers'][$i]['password'] = ''; // MySQL password (only needed

$cfg['blowfish_secret'] = 'password'; // with 'config' auth_type)
$cfg['Servers'][$i]['only_db'] = ''; // If set to a db-name, only
// this db is displayed in left frame
// It may also be an array of db-names, where sorting order is relevant.
$cfg['Servers'][$i]['hide_db'] = ''; // Database name to be hidden from listings
$cfg['Servers'][$i]['verbose'] = ''; // Verbose name for this host - leave blank to show the hostname

$cfg['Servers'][$i]['pmadb'] = ''; // Database used for Relation, Bookmark and PDF Features
// (see scripts/create_tables.sql)
// - leave blank for no support
// DEFAULT: 'phpmyadmin'
$cfg['Servers'][$i]['bookmarktable'] = ''; // Bookmark table
// - leave blank for no bookmark support
// DEFAULT: 'pma_bookmark'
$cfg['Servers'][$i]['relation'] = ''; // table to describe the relation between links (see doc)
// - leave blank for no relation-links support
// DEFAULT: 'pma_relation'
$cfg['Servers'][$i]['table_info'] = ''; // table to describe the display fields
// - leave blank for no display fields support
// DEFAULT: 'pma_table_info'
$cfg['Servers'][$i]['table_coords'] = ''; // table to describe the tables position for the PDF schema
// - leave blank for no PDF schema support
// DEFAULT: 'pma_table_coords'
$cfg['Servers'][$i]['pdf_pages'] = ''; // table to describe pages of relationpdf
// - leave blank if you don't want to use this
// DEFAULT: 'pma_pdf_pages'
$cfg['Servers'][$i]['column_info'] = ''; // table to store column information
// - leave blank for no column comments/mime types
// DEFAULT: 'pma_column_info'
$cfg['Servers'][$i]['history'] = ''; // table to store SQL history
"/etc/phpMyAdmin/config.inc.php" 71L, 5534C
Messages postés
56
Date d'inscription
vendredi 18 juillet 2008
Statut
Membre
Dernière intervention
27 février 2009

j'ai desinstallé et reinstallé mysql, tout marche, en plus j'avais specifié comme mode de connexion dans le fichier config.inc.php socket au lieu de tcp par defaut.
Merci à tous ceux là qui ont tenté de m'aider jusqu'au bout.