[Exel] Afficher zero si resultat negative [Résolu/Fermé]

Signaler
-
Messages postés
7080
Date d'inscription
dimanche 8 avril 2007
Statut
Modérateur
Dernière intervention
25 septembre 2020
-
Bonjour,
je suis entrain de me faire une feille de calcul et je recherche une formule pour afficher une case vide ou zero si resultat negatif

actuellement pour la colone total j'ai la formule
=C2-B2-1

pour la colone heure sup (c'est la que je voudrais afficher un zero ou une case vide)
=F2-7,4

idem pour la colone heure normal (D5) ou j'ai actuellement une formule lié a une autre feuille(la aussi je voudrais afficher soit zero soit une case vide ou les heure effectivement effectuer sansles heures sup)
=Taux!B8

http://photomaniak.com/upload/out.php/i300129_exel1.gif




merci de vos reponses

5 réponses

Messages postés
7080
Date d'inscription
dimanche 8 avril 2007
Statut
Modérateur
Dernière intervention
25 septembre 2020
1 241
Bonsoir,
Tu peux écrire ta formule avec une condition comme ceci :
=SI(F2-7,4<0; 0;F2-7,4)
Bonne soirée
Messages postés
737
Date d'inscription
dimanche 8 juin 2008
Statut
Membre
Dernière intervention
20 avril 2017
188
MERCI

j'ai due modifier la formule pour qu'elle fonctionne avec les heure normal
=SI(F5-7,4<0; 0;F5-E5

maintenant il me reste encore a trouver une formule pour les heures sup

donc afficher un zero tant qu'il n'y as pas de nombre

je pensais à

F5-7,4

mais comment faire afficher zero si aucune heure n'est entréé
Messages postés
7080
Date d'inscription
dimanche 8 avril 2007
Statut
Modérateur
Dernière intervention
25 septembre 2020
1 241
Re,
Génial ! La formule que je t'avais donné était juste faite pour que tu comprennes le principe et que tu l'adaptes à tes besoins ce que tu as fait, bravo, bonne continuation et peut-être à une autre fois sur CCM
Messages postés
737
Date d'inscription
dimanche 8 juin 2008
Statut
Membre
Dernière intervention
20 avril 2017
188
hello

encore merci c nickel et a bientot sur ccm
@+
Messages postés
737
Date d'inscription
dimanche 8 juin 2008
Statut
Membre
Dernière intervention
20 avril 2017
188
edit
Messages postés
7080
Date d'inscription
dimanche 8 avril 2007
Statut
Modérateur
Dernière intervention
25 septembre 2020
1 241
Bonsoir,
Que t'arrives t-il ?
Messages postés
737
Date d'inscription
dimanche 8 juin 2008
Statut
Membre
Dernière intervention
20 avril 2017
188
rien c juste que je me suis trompe d'endroit et comme apparemment on ne peut effacer ces erreur donc j'ai editer
Messages postés
7080
Date d'inscription
dimanche 8 avril 2007
Statut
Modérateur
Dernière intervention
25 septembre 2020
1 241 >
Messages postés
737
Date d'inscription
dimanche 8 juin 2008
Statut
Membre
Dernière intervention
20 avril 2017

Oui, je l'ai compris en voyant ton nouveau topic.
Merci d'avoir tout de même répondu.
Bonne nuit et à+