Multi Boot

Fermé
kpnc Messages postés 6 Date d'inscription vendredi 16 mai 2008 Statut Membre Dernière intervention 1 juillet 2008 - 16 mai 2008 à 12:12
jipicy Messages postés 40805 Date d'inscription jeudi 28 août 2003 Statut Modérateur Dernière intervention 10 août 2020 - 17 mai 2008 à 10:14
Bonjour,
J'ai installé Ubuntu Hardy Heron sur le même disque dur que Windows. Mais lors du démarrage, le GRUB ne trouve aucune partition Windows :\ Je peux booter seulement sur Ubuntu.
J'aimerai un peu d'aide, merci.

Si ça peux aider, voici comment j'ai organisé mes partitions :

disque dur 1 :
- WIndows 40Go (NTFS)
- Ubuntu 37Go (ext3)
- Swap 1.5Go

disque dur 2 :
- Partition pour les données (ext3)



Retour de sudo fdisk -l :

Disque /dev/sda: 500.1 Go, 500107862016 octets
255 heads, 63 sectors/track, 60801 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0x1c141c13

Périphérique Amorce Début Fin Blocs Id Système
/dev/sda1 * 1 60801 488384001 83 Linux

Disque /dev/sdb: 81.9 Go, 81964302336 octets
255 heads, 63 sectors/track, 9964 cylinders
Units = cylindres of 16065 * 512 = 8225280 bytes
Identifiant disque: 0xaa82aa82

Périphérique Amorce Début Fin Blocs Id Système
/dev/sdb1 1 5227 41985846 7 HPFS/NTFS
/dev/sdb2 5228 5409 1461915 82 Linux swap / Solaris
/dev/sdb3 5410 9964 36588037+ 83 Linux




Fichier /boot/grub/menu.lst :

# menu.lst - See: grub(8), info grub, update-grub(8)
# grub-install(8), grub-floppy(8),
# grub-md5-crypt, /usr/share/doc/grub
# and /usr/share/doc/grub-doc/.

## default num
# Set the default entry to the entry number NUM. Numbering starts from 0, and
# the entry number 0 is the default if the command is not used.
#
# You can specify 'saved' instead of a number. In this case, the default entry
# is the entry saved with the command 'savedefault'.
# WARNING: If you are using dmraid do not use 'savedefault' or your
# array will desync and will not let you boot your system.
default 0

## timeout sec
# Set a timeout, in SEC seconds, before automatically booting the default entry
# (normally the first entry defined).
timeout 3

## hiddenmenu
# Hides the menu by default (press ESC to see the menu)
hiddenmenu

# Pretty colours
#color cyan/blue white/blue

## password ['--md5'] passwd
# If used in the first section of a menu file, disable all interactive editing
# control (menu entry editor and command-line) and entries protected by the
# command 'lock'
# e.g. password topsecret
# password --md5 $1$gLhU0/$aW78kHK1QfV3P2b2znUoe/
# password topsecret

#
# examples
#
# title Windows 95/98/NT/2000
# root (hd0,0)
# makeactive
# chainloader +1
#
# title Linux
# root (hd0,1)
# kernel /vmlinuz root=/dev/hda2 ro
#

#
# Put static boot stanzas before and/or after AUTOMAGIC KERNEL LIST

### BEGIN AUTOMAGIC KERNELS LIST
## lines between the AUTOMAGIC KERNELS LIST markers will be modified
## by the debian update-grub script except for the default options below

## DO NOT UNCOMMENT THEM, Just edit them to your needs

## ## Start Default Options ##
## default kernel options
## default kernel options for automagic boot options
## If you want special options for specific kernels use kopt_x_y_z
## where x.y.z is kernel version. Minor versions can be omitted.
## e.g. kopt=root=/dev/hda1 ro
## kopt_2_6_8=root=/dev/hdc1 ro
## kopt_2_6_8_2_686=root=/dev/hdc2 ro
# kopt=root=UUID=cc3502e0-ed31-4133-aaa0-b65b3ecc9f7c ro

## Setup crashdump menu entries
## e.g. crashdump=1
# crashdump=0

## default grub root device
## e.g. groot=(hd0,0)
# groot=(hd1,2)

## should update-grub create alternative automagic boot options
## e.g. alternative=true
## alternative=false
# alternative=true

## should update-grub lock alternative automagic boot options
## e.g. lockalternative=true
## lockalternative=false
# lockalternative=false

## additional options to use with the default boot option, but not with the
## alternatives
## e.g. defoptions=vga=791 resume=/dev/hda5
# defoptions=quiet splash

## should update-grub lock old automagic boot options
## e.g. lockold=false
## lockold=true
# lockold=false

## Xen hypervisor options to use with the default Xen boot option
# xenhopt=

## Xen Linux kernel options to use with the default Xen boot option
# xenkopt=console=tty0

## altoption boot targets option
## multiple altoptions lines are allowed
## e.g. altoptions=(extra menu suffix) extra boot options
## altoptions=(recovery) single
# altoptions=(recovery mode) single

## controls how many kernels should be put into the menu.lst
## only counts the first occurence of a kernel, not the
## alternative kernel options
## e.g. howmany=all
## howmany=7
# howmany=all

## should update-grub create memtest86 boot option
## e.g. memtest86=true
## memtest86=false
# memtest86=true

## should update-grub adjust the value of the default booted system
## can be true or false
# updatedefaultentry=false

## should update-grub add savedefault to the default options
## can be true or false
# savedefault=false

## ## End Default Options ##

title Ubuntu 8.04, kernel 2.6.24-16-generic
root (hd1,2)
kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=cc3502e0-ed31-4133-aaa0-b65b3ecc9f7c ro quiet splash
initrd /boot/initrd.img-2.6.24-16-generic
quiet

title Ubuntu 8.04, kernel 2.6.24-16-generic (recovery mode)
root (hd1,2)
kernel /boot/vmlinuz-2.6.24-16-generic root=UUID=cc3502e0-ed31-4133-aaa0-b65b3ecc9f7c ro single
initrd /boot/initrd.img-2.6.24-16-generic

title Ubuntu 8.04, memtest86+
root (hd1,2)
kernel /boot/memtest86+.bin
quiet

### END DEBIAN AUTOMAGIC KERNELS LIST
A voir également:

6 réponses

jipicy Messages postés 40805 Date d'inscription jeudi 28 août 2003 Statut Modérateur Dernière intervention 10 août 2020 4 901
16 mai 2008 à 12:22
Salut,

A la fin de ton "menu.lst" rajoute :
title windows
root (hd1,0)
chainloader +1
makeactive
Et ça devrait rouler ;-))
0
kpnc Messages postés 6 Date d'inscription vendredi 16 mai 2008 Statut Membre Dernière intervention 1 juillet 2008
16 mai 2008 à 12:50
Merci, j'ai rajouté ce que tu m'a dit, et j'ai bien windows qui apparait dans le grub.
Mais lorsque je sélectionne windows, le démarrage se bloque sur "starting up" :\
Peut être un problème de montage, non ?
0
jipicy Messages postés 40805 Date d'inscription jeudi 28 août 2003 Statut Modérateur Dernière intervention 10 août 2020 4 901
16 mai 2008 à 13:18
Apparemment ce n'est pas une erreur du "grub" qui en général affiche un message "Error nn" (ou nn est un numéro)...

Peut être est-ce du au fait que la partition n'ait aucun "flag" de boot ? ;-\

Il faudrait essayer de corriger ça via "fdisk".
Est-ce que tu te le sens ?
0
kpnc Messages postés 6 Date d'inscription vendredi 16 mai 2008 Statut Membre Dernière intervention 1 juillet 2008
16 mai 2008 à 13:30
Oui je veux bien, de toute façon j'ai pas le choix. Enfin si y a quelque chose d'autre je préférerais. Comment on fait ?
0
jipicy Messages postés 40805 Date d'inscription jeudi 28 août 2003 Statut Modérateur Dernière intervention 10 août 2020 4 901
16 mai 2008 à 13:46
Donc tu ouvres un terminal et tu tapes :
sudo /sbin/fdisk /dev/sdb
Une fois dans "fdisk" tu affiches la table des partitions en appuyant sur la touche "p".
Puis tu appuies sur la touche "a" (pour basculer le fanion d'amorce).
Là, il te sera demandé d'entrer le numéro de la partition qui doit être marquée comme bootable. Donc dans ton cas ça doit être la 1.
Tu valides, puis tu appuies sur la touche "w" pour écrire l'information dans la table des partitions et quitter.
Il ne te reste plus qu'à rebooté.

PS. Tu auras droit certainement à un message d'erreur t'expliquant (en gros) que les changements n'auront lieu qu'au prochain reboot. Donc pas d'affolement...
0
kpnc Messages postés 6 Date d'inscription vendredi 16 mai 2008 Statut Membre Dernière intervention 1 juillet 2008
16 mai 2008 à 14:11
Ca n'a rien changé :\


Par contre, après avoir fait appel à /sbin/fdisk /dev/sdb, je reçoie ce message :

Le nombre de cylindres pour ce disque est initialisé à 9964.
Il n'y a rien d''incorrect avec cela, mais c'est plus grand que 1024,
et cela pourrait causer des problèmes en fonction pour certaines configurations:
1) logiciels qui sont exécutés à l'amorçage (i.e., vieilles versions de LILO)
2) logiciels d'amorçage et de partitionnement pour d'autres SE
(i.e., DOS FDISK, OS/2 FDISK)
0

Vous n’avez pas trouvé la réponse que vous recherchez ?

Posez votre question
jeanbi Messages postés 14754 Date d'inscription samedi 9 décembre 2006 Statut Contributeur Dernière intervention 9 novembre 2022 2 391
16 mai 2008 à 19:32
bonjour,
si j'ai bien compris le dd de windows est le hd1 et celui de linux hd0
dans ce cas windows n'aimant pas cette config il faut lui faire croire qu'il est le 1 er en mappant hd1 et hd0
title        windows 
map (hd0) (hd1)
map (hd1) (hd0)
root (hd1,0)
makeactive
chainloader     +1

par exemple
a+
0
jipicy Messages postés 40805 Date d'inscription jeudi 28 août 2003 Statut Modérateur Dernière intervention 10 août 2020 4 901
16 mai 2008 à 20:00
Salut jeanbi,

Non, non, les 2 OS sont bien sur le même HD (hd1).
Le hd0 est un disque de données formaté en Ext3FS ;-))
0
jeanbi Messages postés 14754 Date d'inscription samedi 9 décembre 2006 Statut Contributeur Dernière intervention 9 novembre 2022 2 391
17 mai 2008 à 09:28
bonjour,
cela revient au même windows , lui veut être sur le 1 er disque bootable . donc sur le hd0 essaye donc ce que je te propose , ça coûte rien .
a+
0
jipicy Messages postés 40805 Date d'inscription jeudi 28 août 2003 Statut Modérateur Dernière intervention 10 août 2020 4 901
17 mai 2008 à 10:14
Je ne remettais nullement en cause le mappage, mais je voulais juste clarifier l'emplacement des OS et des données sur les disques ;-))
0