Nombre de caractères dans une cellule

Résolu/Fermé
-
 patrick -
Bonjour,

J'aimerais calculer le nombre de caractères écrits dans une celle et recevoir un message m'indique que je dépasse le maxximum de caractères souhaités?

3 réponses

Messages postés
1506
Date d'inscription
mardi 19 juillet 2005
Statut
Membre
Dernière intervention
18 juin 2012
594
Bonjour

Oui c'est sans aucun doute la meilleur solution
Pour le fun
=SI(NBCAR(A2)>5;"Attention nombre de caractères est supérieur à 5";"")

ou encore
http://bvrve.club.fr/Astuces_Michel/55excelvba.html
Messages postés
26410
Date d'inscription
lundi 23 juillet 2007
Statut
Non membre
Dernière intervention
25 janvier 2022
6 188
Bonjour Alainco
Supposant que vous parlez d'Excel, je vous propose:
Sélectionner les cellules à traiter
Barre des tâches/ Données / Validation
Dans la boite qui s'ouvre:
Autoriser / Longueur du texte / Rentrez vos arguments
Cliquer "message de saisie":
le texte inscrit dans la partie message s'affichera en avertissement à la sélection de la cellule
Cliquer "Alerte d'erreur"
/ Idem / Choisissez votre option dans style et mettez votre message, qui s'affichera lorsque le nombre de caractères sera dépassé..
Ca devrait marcher.
Bonne journée
BCRDLMNT--

Science sans conscience n'est que ruine de l'Ame

J'ai aussi un problème avec la mise en forme sur Excel, par exemple :

=SI(NBCAR(A2)>5;"Attention nombre de caractères est supérieur à 5";"")

Je ne veux pas afficher une message mais je veux colorer les doutes en rouge

Est-ce quelqu'un peut m'aider

Merci d'avance
Il suffit de faire une mise en forme conditionnelle pour les cellules contenant le texte spécifique "Attention nombre de caractères est supérieur à 5" ou autre et de modifier la police dans ce cas