Impossible de télécharger kafka sous ubuntu !

Bonjour,

Je tente de télécharger kafka sous ubuntu avec la commande suivante :

wget http://apache.crihan.fr/dist/kafka/0.10.2.1/kafka_2.10-0.10.2.1.tgz


Mais j'ai l'erreur suivante :

HTTP request sent, awaiting response... 404 Not Found 2022-05-28 22:49:34 ERROR 404: Not Found


En cherchant on m'a dit que c'est probablement le service
telnet
qui n'est pas activé dans les fichiers de config. Je devais alors modifier le yes en no dans le fichier
xinetd
comme suit:

service telnet
{
flags = REUSE
socket_type = stream
wait = no
user = root
server = /usr/sbin/in.telnetd
log_on_failure += USERID
disable = yes
}


J'ai trouvé le fichier
xinetd-client
, mais il est vide. Idem pour
xinetd-server
.

S'il y a des bonnes volontés pour me dépanner je serai reconnaissant.

11 réponses

  1. Bonjour,

    Le message est clair ; ERROR 404 not found.
    Le fichier n'est pas trouvé car il n'existe pas à l'adresse indiquée.
    Soit tu as fait une faute de frappe dans l'adresse, soit le fichier n'existe pas/plus sur le serveur.

    Pourquoi ne pas télécharger la version qui t'intéresse ici :
    https://kafka.apache.org/downloads
    0
    1. Bonjour,
      Merci de votre aide.

      Si j'ai compris le message mais je sais pas pourquoi c'est ainsi puisque mes camarades utilisent le même lien sur le même ubuntu et et avec la même commande, ils n'ont pas d'erreur. Il n'y a aucune faute de frappe, c'est sûr.
      Oui j'ai contourné l'erreur en allant sur le navigateur télécharger comme vous venez de le dire. Quand je l'installe et que j'essaie de le lancer ça ne marche pas et j'ai des erreurs.
      C'est pourquoi je me suis dis qu'il vaut mieux affronter l'erreur dès le départ. Je vais vous partager l'erreur obtenue en tentant de lancer après un téléchargement sur le navigateur.
      Le fichier de config xinetd est vide dans mon système et c'est là le problème je pense. Je n'ai pu trouver la raison et la solution.

      Si vous avez d'autres pistes, je vous remercie.

      Cdlt,
      0
      1. En complément de ce que je disais par rapport au téléchargement via le navigateur :
        Dès je finis de télécharger et installer et que je lance le serveur
        kafka
        avec la commande :

        ./bin/kafka-server-start.sh ./config/server.properties


        J’ai l’erreur :
        java.net.ConnectException: Connection refused


        Idem pour
        zookeeper
        :
        ./bin/zookeeper-server-start.sh ./config/zookeeper.properties

        Le processus se bloque sur l’erreur suivante :
        INFO ZooKeeper audit is disabled
        .

        Merci.
        0
        1. Modérateur
          Bonjour,

          Pourquoi ne pas juste suivre un tutoriel, par exemple celui-ci ?

          Ensuite concernant ta dernière erreur, voir ce lien.

          Bonne chance
          0
          1. Bonjour,

            Ok, je regarde ça. Merci bien de votre aide.
            0
        2. Bonjour,

          Honnêtement j'ai utilisé toutes les cartouches qui m'ont été offertes mais rien n'a marché.
          Mes camarades utilisent le même lien et ça marche mais chez moi rien ne marche.
          Mon PC est peut-être maudit
          Je vous remercie infiniment de votre aide.
          0
          1. Modérateur
            Bonjour,

            Si un tutoriel donné marche chez tes camarades mais pas chez toi, c'est que le tutoriel est bon et que quelque chose ne va pas sur ton PC. Mais si tu veux de l'aide, il faudrait nous décrire les symptômes (message d'erreur etc). Peux-tu repartir du tutoriel que je t'ai donné et me dire où ça bloque ?

            Bonne chance
            0
            1. Bonjour,

              Merci pour votre bonne volonté.
              J'ai tout supprimé et recommencé, mais j'arrive à peine à démarrer.
              Je n'arrive pas à extraire le dossier.
              La commande ci-dessous me donne l'erreur suivante :

              gzip: stdin: not in gzip format
              tar: Child returned status 1
              tar: Error is not recoverable: exiting now


              Idem avec :
              tar zxvf


              J'ai essayé dautres methodes comme clic droit en GUI qui n'ont pas marché:
              Not an archive
              0
              1. Modérateur
                Bonjour,

                Il faut passer en paramètre à
                tar
                le chemin vers ton archive.

                Exemple :

                tar xzvf /home/toto/fichier.tgz


                Bonne chance
                0
              2. @mamiemandoBonjour,

                Ça me renvoie ceci :

                tar (child): Error is not recoverable: exiting now
                tar: Child returned status 2
                tar: Error is not recoverable: exiting now
                0
              3. @ShieldMerci bien. Le chemin semble être long avec mon pc.
                0
              4. Modérateur
                @ShieldDu coup, as-tu résolu ton problème ?
                0
            2. Entre temps, j'ai pu extraire le dossier et suivi le tuto mais arrivé au lancement j'ai le status suivant tandis que la commande de lancement start kafka ne retourne rien.

              × kafka.service
              Loaded: loaded (/etc/systemd/system/kafka.service; disabled; vendor preset: enabled)
              Active: failed (Result: exit-code) since Sat 2022-06-11 21:44:06 CEST; 17s ago
              Process: 7464 ExecStart=/bin/sh -c /home/kafka/kafka/bin/kafka-server-start.sh /home/kafka/kafka/config/server.properties >>
              Main PID: 7464 (code=exited, status=127)
              CPU: 43ms

              juin 11 21:44:06 vm systemd[1]: Started kafka.service.
              juin 11 21:44:06 vm systemd[1]: kafka.service: Main process exited, code=exited, status=127/n/a
              juin 11 21:44:06 vm systemd[1]: kafka.service: Failed with result 'exit-code'.
              lines 1-10/10 (END)
              0
              1. Modérateur
                Que dit le fichier de log de
                kafka
                (vraisemblablement dans
                /var/log
                ) ?
                0
            3. Je n'ai pas de
              /var/log
              . Par contre dans le dossier config j'ai
              connect-log4j.properties
              dont le contenu est :

              log4j.appender.stdout=org.apache.log4j.ConsoleAppender
              log4j.appender.stdout.layout=org.apache.log4j.PatternLayout
              # Send the logs to a file, rolling the file at midnight local time. For example, the `File` option specifies the
              # location of the log files (e.g. ${kafka.logs.dir}/connect.log), and at midnight local time the file is closed
              # and copied in the same directory but with a filename that ends in the `DatePattern` option.
              #
              log4j.appender.connectAppender=org.apache.log4j.DailyRollingFileAppender
              log4j.appender.connectAppender.DatePattern='.'yyyy-MM-dd-HH
              log4j.appender.connectAppender.File=${kafka.logs.dir}/connect.log
              log4j.appender.connectAppender.layout=org.apache.log4j.PatternLayout
              # The `%X{connector.context}` parameter in the layout includes connector-specific and task-specific information
              # in the log messages, where appropriate. This makes it easier to identify those log messages that apply to a
              # specific connector.
              #
              connect.log.pattern=[%d] %p %X{connector.context}%m (%c:%L)%n
              log4j.appender.stdout.layout.ConversionPattern=${connect.log.pattern}
              log4j.appender.connectAppender.layout.ConversionPattern=${connect.log.pattern}
              log4j.logger.org.apache.zookeeper=ERROR
              log4j.logger.org.reflections=ERROR
              0
              1. Modérateur
                Bonjour,

                Je n'ai pas de
                /var/log
                .

                Je suspecte que tu n'as pas regardé depuis le dossier racine de ton serveur (
                /
                ), il y a forcément un
                /var/log
                , Ubuntu en a besoin ne serait-ce que pour loguer les paquet installés...

                Le fichier que tu reportes est un fichier de configuration qui spécifie sous quel format loger les informations et ne recense donc pas les messages d'erreur qui pourraient nous aider à avancer.
                0