Fichier index.html ne fonctionne pas bien

Signaler
-
 Nelson -
Bonjour,



Configuration: Android / Chrome 91.0.4472.120


Bonjour, s'il vous plaît j'ai besoin d'aide.

j'ai acheté un nom de domaine chez OVH. J'ai ajouté le fichier index.html à la racine de mon serveur. Actuellement mon site www.nemafi.fr s'ouvre bien, mais le problème est que lorsque je clic sur un lien se trouvant à la page d'accueil de mon site une page s'ouvre et m'indique que l'URL n'a pas été trouvé dans le serveur.
En plus ma page d'accueil n'affiche pas les images des articles que j'ai déjà rédigé...
Besoin d'aide s'il vous plaît

4 réponses

Messages postés
33137
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
27 juillet 2021
3 639
Bonjour
Tu as bien les sous dossiers sur ton site ?
Tu as bien respecté la même orthographe (majuscule/minuscule)

Tu as un fichier . htaccess à la racine ? Que se passe-t-il si tu le désactives ?

Le fichier index.html contient le code source de mon site d'avant.

Les orthographe sont bien respectés.

Je n'ai pas un fichier .htaccess
Messages postés
33137
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
27 juillet 2021
3 639 > Nelson
Bien sûr.
Chaque lien pointe vers une autre page si tu ne l'as pas récupéré c'est normal que ça n'apparaisse pas....
>
Messages postés
33137
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
27 juillet 2021

Ok. Considérons que ceci
<div dir="ltr" style="text-align: left;" trbidi="on">
<div class="separator" style="clear: both; text-align: center;">
<a href="https://1.bp.blogspot.com/-8RcagmXwfsQ/XbCPHjko4YI/AAAAAAAABMw/l1ZJQ1t--EMH47IMnTovL9cCyET5asuUgCLcBGAsYHQ/s1600/images.png" style="margin-left: 1em; margin-right: 1em;"><img border="0" data-original-height="225" data-original-width="225" height="200" src="https://1.bp.blogspot.com/-8RcagmXwfsQ/XbCPHjko4YI/AAAAAAAABMw/l1ZJQ1t--EMH47IMnTovL9cCyET5asuUgCLcBGAsYHQ/s200/images.png" width="200" /></a></div>
<br />
<br />
<div class="separator" style="clear: both; text-align: center;">
<a href="https://1.bp.blogspot.com/-MQsdmmtZKaI/XbJDdRda_ZI/AAAAAAAABNM/F88WAWDan0g71BSyJc4luWNNZ063SBwKACLcBGAsYHQ/s1600/pictofleche.png" style="margin-left: 1em; margin-right: 1em;"><img alt="haut" border="0" data-original-height="512" data-original-width="512" height="200" src="https://1.bp.blogspot.com/-MQsdmmtZKaI/XbJDdRda_ZI/AAAAAAAABNM/F88WAWDan0g71BSyJc4luWNNZ063SBwKACLcBGAsYHQ/s200/pictofleche.png" title="haut" width="200" /></a></div>
<br /></div>
est le code de l'une de mes pages.

Dois-je créer un fichier nomdelapage.html dans mon serveur?
Messages postés
33137
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
27 juillet 2021
3 639 > Nelson
Ben oui
Messages postés
33137
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
27 juillet 2021
3 639 >
Messages postés
33137
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
27 juillet 2021

Et adapter les liens pour cibler l'emplacement de cette page
>
Messages postés
33137
Date d'inscription
mercredi 22 octobre 2003
Statut
Modérateur
Dernière intervention
27 juillet 2021

Je crée ces fichiers dans quel dossier?
Dossier racine ou bien!
Messages postés
9
Date d'inscription
samedi 10 juillet 2021
Statut
Membre
Dernière intervention
10 juillet 2021

contact le webhosting service
Bonjour. Ils me répondent une fois par semaine. Voilà pourquoi je viens poser mon problème ici
Messages postés
35
Date d'inscription
lundi 16 juin 2014
Statut
Membre
Dernière intervention
10 juillet 2021
11
Hello, le problème vient du SSL !
toutes les pages redirige vers des liens en HTTPS,
2 solutions possibles
première solution configure un certificat SSL puis demande à ton htaccess de faire des redirection.
deuxième solution va dans ton htaccess et demande à ce que toutes les redirection se fasse sans HTTPS
Bonjour serais-ce plus facile en utilisant cloudflare ?