Openvpn connect (Android) : TLS error [Résolu]

Signaler
Messages postés
42
Date d'inscription
mercredi 29 janvier 2020
Statut
Membre
Dernière intervention
13 décembre 2020
-
Messages postés
42
Date d'inscription
mercredi 29 janvier 2020
Statut
Membre
Dernière intervention
13 décembre 2020
-
Bonjour à tous.
Je reviens afin d'essayer de comprendre une erreur alors que tout semble parfaitement bon. J'ai configuré une connexion vpn en utilisant openvpn.
J'ai donc installé openvpn server sur mon serveur windows
J'ai installé openvpn sur mon client windows 10. La connexion se passe parfaitement bien, aucun souci.
J'i donc convertit mon fichier de configuration client windows en client android. Et là, j'ai cette erreur qui apparaît : (et impossible de se connecter au serveur depuis ce client)

Authenticate/Decrypt packet error: packet HMAC authentication failed
TLS Error: incoming packet authentication failed from [AF_INET6]::ffff:monip:36123

Est ce quelqu'un aurait une idée ?

Fichier openvpn serveur :

port 1194
proto udp
dev tun
ca "C:\\Program Files\\OpenVPN\\config\\ca.crt"
cert "C:\\Program Files\\OpenVPN\\config\\ServerVPN.crt"
key "C:\\Program Files\\OpenVPN\\config\\ServerVPN.key"
dh "C:\\Program Files\\OpenVPN\\config\\dh2048.pem"
server 10.8.0.0 255.255.255.0
ifconfig-pool-persist ipp.txt
keepalive 10 120
tls-auth ta.key 0 # This file is secret
cipher AES-256-CBC
persist-key
persist-tun
status openvpn-status.log
verb 3
explicit-exit-notify 1


Fichier client Windows 10 :

client
dev tun
proto udp
remote monip1194
resolv-retry infinite
nobind
persist-key
persist-tun
ca "C:\\Program Files\\OpenVPN\\config\\ca.crt"
cert "C:\\Program Files\\OpenVPN\\config\\ClientVPN.crt"
key "C:\\Program Files\\OpenVPN\\config\\ClientVPN.key"
remote-cert-tls server
tls-auth ta.key 1
cipher AES-256-CBC
verb 3


Fichier client android :

client
dev tun
proto udp
remote monip 1194
resolv-retry infinite
nobind
persist-key
persist-tun
remote-cert-tls server
key-direction 1
<ca>
-----BEGIN CERTIFICATE-----
-----END CERTIFICATE-----
</ca>

<cert>
-----BEGIN CERTIFICATE-----
-----END CERTIFICATE-----
</cert>

<key>
-----BEGIN PRIVATE KEY-----
-----END PRIVATE KEY-----
</key>



<tls-auth>
#
# 2048 bit OpenVPN static key
#
-----BEGIN OpenVPN Static key V1-----
-----END OpenVPN Static key V1-----
</tls-auth>

cipher AES-256-CBC
verb 3

3 réponses

Messages postés
96549
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
15 janvier 2021
11 410
Salut,
converti ?
ça m'inquiète, tu as changé quoi en fait ?
là suivant le message d'erreur, la connexion semble se faire en ipv6, c'est ça qui est configuré ?
Messages postés
42
Date d'inscription
mercredi 29 janvier 2020
Statut
Membre
Dernière intervention
13 décembre 2020

Je ne comprends pas pourquoi il tente une connexion en ipv6. L'adresse est configuré en ipv4. Voici par exemple mon fichier log lors de la connexion windows server et windows 1 client :

peer info: IV_GUI_VER=OpenVPN_GUI_11
Control Channel: TLSv1.3, cipher TLSv1.3 TLS_AES_256_GCM_SHA384, 4096 bit RSA
[ClientVPN] Peer Connection Initiated with [AF_INET6]::ffff:
T ClientVPN/9 MULTI_sva: pool returned IPv4=10.8.0.6, IPv6=(Not enabled)
Thu Dec 10 18:14:32 2020 ClientVPN/ MULTI: Learn: 10.8.0.6 -> ClientVPN/90.65.169.126:63009
Thu Dec 10 18:14:32 2020 ClientVPN/ MULTI: primary virtual IP for ClientVPN/: 10.8.0.6
Thu Dec 10 18:14:33 2020 ClientVPN/ PUSH: Received control message: 'PUSH_REQUEST'
Thu Dec 10 18:14:33 2020 ClientVPN/ SENT CONTROL [ClientVPN]: 'PUSH_REPLY,route 10.8.0.1,topology net30,ping 10,ping-restart 120,ifconfig 10.8.0.6 10.8.0.5,peer-id 0,cipher AES-256-GCM' (status=1)
Thu Dec 10 18:14:33 2020 ClientVPN/ Data Channel: using negotiated cipher 'AES-256-GCM'
Thu Dec 10 18:14:33 2020 ClientVPN/9 Outgoing Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key
Thu Dec 10 18:14:33 2020 ClientVPN/ Incoming Data Channel: Cipher 'AES-256-GCM' initialized with 256 bit key

Si je ne dis pas de bêtises, c'est bien lipv4 qui est configuré ?
Messages postés
96549
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
15 janvier 2021
11 410
Etrange ce message :
[ClientVPN] Peer Connection Initiated with [AF_INET6]::ffff:

Les logs que tu fais voir là, c'est la connexion qui fonctionne sur le PC ?
sur ta config windows, je vois ceci:
tls-auth ta.key 1
et sur ta config android, c'est ça:
key-direction 1
c'est toi qui l'as mis ?
je vais vérifier sur mon vpn ce que j'ai.
Messages postés
42
Date d'inscription
mercredi 29 janvier 2020
Statut
Membre
Dernière intervention
13 décembre 2020
>
Messages postés
96549
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
15 janvier 2021

effectivement c'est bien la connexion fonctionnant entre le pc windows set le serveur. Pour key-direction 1, il s'agit d'une erreur. Je ne l'ai pas mis dans la config.

tls-auth ta.key 1 : c'est bien bien présent sur la config windows client
Messages postés
96549
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
15 janvier 2021
11 410 >
Messages postés
42
Date d'inscription
mercredi 29 janvier 2020
Statut
Membre
Dernière intervention
13 décembre 2020

Tu sais que tu es cool à aider comme gars toi :-(
Messages postés
42
Date d'inscription
mercredi 29 janvier 2020
Statut
Membre
Dernière intervention
13 décembre 2020
>
Messages postés
96549
Date d'inscription
lundi 16 juillet 2001
Statut
Modérateur
Dernière intervention
15 janvier 2021

Aïe
Messages postés
42
Date d'inscription
mercredi 29 janvier 2020
Statut
Membre
Dernière intervention
13 décembre 2020

finalement, j’ai tout repris à zéro. Et en créant un dossier spécifique ovpn dans android avec uniquement les fichiers de config, tout fonctionne parfaitement bien. Vraiment merci pour votre aide