Pb avec IMAP de GMAIL dans Thunderbird 68.8.0

Signaler
Messages postés
4
Date d'inscription
mercredi 17 juin 2020
Statut
Membre
Dernière intervention
18 juin 2020
-
Messages postés
35030
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
7 juillet 2020
-
bonjour,
Ma messagerie GMAIL fonctionne sur smartphone et ordi, mais sur le portable (ubuntu 16.04 LTS), impossible de se connecter,en TB (en direct il ne répond pas) il réclame ceci:" veuillez saisir votre mot de passe sur imap.gmail.com" et n'en démord pas. J'ai supprimé puis reconstruit le compte: idem!! et regardé sur le net, mais rien trouvé, sauf des collègues qui ont le même pb!
Merci de toute réponse

9 réponses

Messages postés
18385
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
4 juillet 2020
4 195
Bonjour,

Pour l'accès IMAP, tu dois créer un mot de passe d'application depuis les paramètres de ton compte Google. Tu ne dois pas utiliser ton mot de passe Google/Gmail.

https://support.google.com/accounts/answer/185833?hl=fr
Messages postés
4
Date d'inscription
mercredi 17 juin 2020
Statut
Membre
Dernière intervention
18 juin 2020

suite à mon pb de IMAP, j'ai obtenu le mot de passe d'application, mais comment le rentrer sur le portable en thunderbird?
C'est sans doute élémentaire, mais impossible de voir??

sur le portable avec Firefox, la connection à GMAIL et mon adresse mail reste sans réponse!
Désolé de vous déranger!!
cdm33
Messages postés
18385
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
4 juillet 2020
4 195
Ce mot de passe d'application doit être renseigné dans Thunderbird lorsque le logiciel te demande le nom d'utilisateur et le mot de passe, lorsque tu configures les accès SMTP et IMAP.

Le nom d'utilisateur reste ton adresse @gmail.com, mais le mot de passe est celui obtenu comme "mot de passe d'application"
Messages postés
4
Date d'inscription
mercredi 17 juin 2020
Statut
Membre
Dernière intervention
18 juin 2020

Votre réponse est claire, mais impossible de rentrer le pwd d'application! Je supprime le compte, le recrée, d'où l'accès,
mais en mettant pwd normal dans IMAP pour rentrer ce fameux code d'appli, il le refuse. (alors que l'authentification est OAUTH2)
j'ai essayé n fois, alors qu'avant çà marchait TB sans ce code d'appli!!
D'ailleurs çà marche sur smartphone/android et ordi/ubuntu!!
Désolé de vous embêter, mais je ne comprends pas!!
Merci
Messages postés
18385
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
4 juillet 2020
4 195
> mais en mettant pwd normal dans IMAP pour rentrer ce fameux code d'appli

Donc tu tentes d'utiliser ton mot de passe Google/Gmail ?
C'est justement ce que j'ai dit de ne pas faire...
Tu dois utiliser le mot de passe d'application.

> alors que l'authentification est OAUTH2
Je ne vois pas ce que OAuth2 via faire là-dedans, tu dois configurer une connexion IMAP et SMTP "classique" avec nom d'utilisateur + mot de passe.

Au risque de me répéter : il faut configurer le compte de messagerie dans Thunderbird comme n'importe quel autre compte SMTP/IMAP. Quand on te demande le nom d'utilisateur, tu mets l'adresse email complète. Quand on demande le mot de passe, tu mets le mot de passe d'application, créé via ton compte Google (mais tu ne mets pas le mot de passe de ton compte Google !)

Si tu tiens à utiliser OAuth2, alors il ne faut pas utiliser le mot de passe d'application, mais bien celui de ton compte Google. Une "pop-up" devrait s'ouvrir avec l'écran de connexion de Google.
Messages postés
4616
Date d'inscription
mardi 13 février 2018
Statut
Contributeur
Dernière intervention
7 juillet 2020
1 751
Bonjour,

Je viens de faire un essai sur Linux Mint (machine virtuelle)

J'ai pu créer mon compte dans Thunderbird sans trop de problèmes.
J'ai pu utiliser mon mot de passe ordinaire sans créer de mot de passe d'application.
J'ai bien eu l'écran " veuillez saisir votre mot de passe sur imap.gmail.com"
J'ai redonné mon mot de passe et j'ai reçu un code par texto sur mon smartphone.
La grosse difficulté a été de saisir ce code, car je n'ai pas de pavé numérique et curieusement les chiffres en haut du clavier étaient inaccessibles ! J'ai rusé en faisant un copié/collé.

Je tenterai sur Ubuntu (toujours en machine virtuelle).

Une remarque : Dans la page de création des mots de passe d'application, Google propose "ordinateur Windows" comme appareil mais pas "ordinateur Linux" !
Messages postés
4616
Date d'inscription
mardi 13 février 2018
Statut
Contributeur
Dernière intervention
7 juillet 2020
1 751
Avec Ubuntu je ne suis pas arrivé à créer un compte gmail dans Thunderbird.
Même échec avec le mot de passe du compte Google ou un mot de passe d'application.

J'ai un blocage au moment de la vérification du mot de passe, à la fin du processus, quand tout a été configuré.
Ça ressemble à un gros bug de Thunderbird ou d'Ubuntu.
Messages postés
18385
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
4 juillet 2020
4 195 >
Messages postés
4616
Date d'inscription
mardi 13 février 2018
Statut
Contributeur
Dernière intervention
7 juillet 2020

Salut !

Pour ma part, aucun problème ni en liveCD, ni après une installation fraîche et à jour (Ubuntu 20.04 Desktop amd64).
Thunderbird se connecte à mon compte Gmail en OAuth2, l'envoi et la réception fonctionnent.

Thunderbird utilise automatiquement le mode OAuth2 pour les adresses @gmail.com, d'ailleurs le mot de passe donné dans la première étape n'est pas utilisé car inutile avec cette méthode : l'accès se fait sur base du jeton oauth obtenu après s'être authentifié sur la page de connexion (Web) de Google. Le mot de passe à utiliser lors de cette authentification est bien-entendu le mot de passe habituel du compte Google/Gmail.

Messages postés
4616
Date d'inscription
mardi 13 février 2018
Statut
Contributeur
Dernière intervention
7 juillet 2020
1 751 >
Messages postés
18385
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
4 juillet 2020

Salut,

J'ai utilisé la version 18.04 LTS.
J'ai contacté un linuxien averti (pas comme moi !). Il n'a pas réussi non plus, avec la même version 18.04.
Messages postés
35030
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
7 juillet 2020
5 253 >
Messages postés
18385
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
4 juillet 2020

Salut à tous,

Je viens de faire un test sur une VM avec Linux Mint 19.3 et un vieux compte gmail créé il y a plus de 10 ans et qui ne me sert que de compte pour le smartphone, aucune utilisation du mail depuis des années.

Donc, sur Mint et Thunderbird, avec une configuration auto, aucun problème. Pop-up pour l'authentification et une fois le password entré, roule ma poule ;-)

Exactement les mêmes réglages auto que notre piloteDJ ci-dessus ;-)

Nul besoin de créer un mot de passe d'application. J'ai juste reçu deux alertes comme quoi un nouvel appareil s'était connecté :
Un utilisateur vient de se connecter à votre compte Google à partir d'un nouvel appareil Linux. Nous vous envoyons cet e-mail pour vérifier qu'il s'agissait bien de vous.


Voilà…
Bonjour,

Sous Windows (désolé je n'ai pas Linux), pour réaliser l'authentification OAuth2 avec Thunderbird il faut que celui-ci soit configuré pour accepter les cookies. Si ce n'est pas le cas, il vous demande et redemande le nom du compte sans arrêt.

Donc :
Outils>Options>Vie privée>Accepter les cookies sur OUI, accepter les cookies tiers sur toujours.
Messages postés
4
Date d'inscription
mercredi 17 juin 2020
Statut
Membre
Dernière intervention
18 juin 2020

BONJOUR ET MERCI POUR TOUTES VOS RÉPONSES,
Dès que possible, je vais reprendre le pb!!
cdm33

PS çà marchait avant, donc çà va marcher!! ...
Messages postés
4616
Date d'inscription
mardi 13 février 2018
Statut
Contributeur
Dernière intervention
7 juillet 2020
1 751
Bonjour,

Je confirme ce qui semblait se dessiner dans ce topic : il s'agit bien d'un bug d'Ubuntu.
J'ai installé la version 20.04 LTS et l'addition du compte gmail dans Thunderbird a été rapide et sans problème, avec le mot de passe habituel (pas de mot de passe d'application).

Donc faites la mise à jour et les problèmes devraient être résolus.

Cordialement
Messages postés
18385
Date d'inscription
dimanche 17 février 2008
Statut
Contributeur
Dernière intervention
4 juillet 2020
4 195
Bonjour,

Il semble en effet y avoir un problème avec la version 18.04, mais une solution existe. Mais il s'agit d'un problème lié à la version de Thunderbird et non un problème lié à la distribution.

La solution : activer l'option « general.useragent.compatMode.firefox » dans l'éditeur de config (et redémarrer Thunderbird).

Pour accéder à l'éditeur de config :
https://support.mozilla.org/en-US/kb/config-editor

Pour plus d'infos :
https://support.mozilla.org/bm/questions/1272184
https://support.google.com/mail/thread/4528103?hl=en

Le problème est réglé dans les versions récentes de Thunderbird, d'où le fait qu'il ne se présente pas sur Ubuntu 20.04 ou d'autres distros avec des packages plus récents.

@zipe31 : "DJ" comme Django, un F-16 sait mettre le feu sans brancher les platines ;-)
Messages postés
35030
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
7 juillet 2020
5 253
Re-

<ModeHS ON>
@zipe31 : "DJ" comme Django
J'veux bien môa, mais lequel ? ;-))
<ModeHS OFF>