Installation de pilotes par Powershell ? - Asus Vivobook S512FA - Windows 10 [Résolu]

Signaler
Messages postés
2
Date d'inscription
samedi 25 janvier 2020
Statut
Membre
Dernière intervention
18 février 2020
-
Messages postés
2
Date d'inscription
samedi 25 janvier 2020
Statut
Membre
Dernière intervention
18 février 2020
-
Bonjour,

Je suis actuellement en possession d'un PC Asus Vivobook S512FA, avec Windows 10. Suite à un formatage, je souhaite réinstaller tous les pilotes. Je télécharge donc les derniers pilotes sur le support d'Asus (lien ici -> https://www.asus.com/fr/supportonly/S512FA/HelpDesk_Download/) (il faut sélectionner X512FAC puis Windows 10 64 bits). Jusque-là, rien de nouveau.

Une fois le téléchargement terminé, je décompresse l'archive. Le pilote montré ici est celui de la connexion sans-fil.

C'est la première fois que je remarque que pour les pilotes Asus, l'installation se fait par Powershell selon le fichier "InstallStep" accompagné en tant que procédure. Voici le contenu de ce fichier:




Je suis la procédure en tapant ce qu'il faut dans powershell et j'arrive donc à ceci au final:



D'après la procédure, tout est bon, il reste juste à redémarrer. Ce que je fait, mais rien ne change. Je n'ai toujours pas de connexion et dans le gestionnaire de périphérique, il n'y a pas de changements non plus).

Et là, je suis bloqué depuis déjà pas mal de temps. N'ayant donc pas de réseau, je ne peux pas faire grand chose notamment.
Quelqu'un a-t-il déjà eu cette situation pour ce genre d'installation et a-t-il réussi ? J'ai tout essayé selon mes connaissances et en recherchant sur Internet, mais rien.


Je reprécise que les tests ci-dessus sont fait avec le pilote de réseau sans-fil car je peux directement voir les changements s'il y en a (ici donc, pas de détection de la carte par le PC vu qu'il n'y a pas de pilote, ainsi pas de menu de sélection des réseaux wifi depuis la barre des tâches). Autrement, tous les autres pilotes de ce modèle s'installe ce cette façon et je vois de même, pour la plupart, aucun changement (exemple: Le touchpad). Par contre certains pilotes ont l'air d'avoir fonctionné, car une fois leur installation terminée par Powershell, le gestionnaire de périphériques avait moins de périphériques non reconnus (exemple: Chipset).

Merci d'avance pour vos réponses.

1 réponse

Messages postés
16080
Date d'inscription
dimanche 16 décembre 2007
Statut
Membre
Dernière intervention
13 juillet 2020
2 025
Bonjour


à mon avis, il faut lancer le setup.bat dans le powershell

d'ailleurs c'est marqué un 1ère ligne de ta copie d'écran

C:\Users\xxxxx\Downloads\WLAN_DCH_QualcommAtheros_Win10_64_VER1200919 -> je ne vois aucun .install.bat
Messages postés
2
Date d'inscription
samedi 25 janvier 2020
Statut
Membre
Dernière intervention
18 février 2020

Bonjour,

Merci, j'ai finalement réussi avec un vieux pilote.