Souci de droit sur dossier de montage [Fermé]

Signaler
-
Messages postés
29252
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
2 juillet 2020
-
Bonjour a tous,

après avoir créer un dossier de montage :

mkdir /media/info


modifier mon fstab

//MONSERVEUR/MonPartage       /media/info/ cifs    user,user=XXX,pass=YYYY      0       0


et monté tout ca :

mount -a


mon dossier de montage perd tous les droits et est donc inaccessible

ls -l
?------------------- ? ? ? ? ? info



Ou ais je fais une erreur ?
Que dois je faire pour que cela fonctionne ?

Meci d'avance pour votre aide

Cordialement

5 réponses

Messages postés
18149
Date d'inscription
lundi 15 janvier 2007
Statut
Contributeur
Dernière intervention
4 juillet 2020
4 887
hdllo
quel est le système de fichier
df -T  /media/info
le systeme de fichier est après la commande ls : ext3

Merci de ton aide et de ton interet
Cordialement
Messages postés
18149
Date d'inscription
lundi 15 janvier 2007
Statut
Contributeur
Dernière intervention
4 juillet 2020
4 887
quelle option de ls ?
euh pardon de

df T /media/info
je ne sais pas si ca peut aider mais lorsque je fais un

df -h


Je vois mon montage mais de manière partielle. C'est a dire que le chemin est tronqué.

j'ai donc verifié mon fstab et le chemin est bon

j'ai essayé le montage manuel et de nouveau le chemin est bon

Mystère
Messages postés
18149
Date d'inscription
lundi 15 janvier 2007
Statut
Contributeur
Dernière intervention
4 juillet 2020
4 887
d'ou vient le media ? quel format ?
c'est du ext3 ? ou du NTFS Windows ?
Non, le $ a bien sa place

et j'ai bien comparé avec les autres qui fonctionne et la différence est qu'après le mount si je verifie avec un

df -T


le chemin est tronqué sur les serveurs qui ne fonctionne pas. Le chemin s'arrete sur ceux la juste apres informatique/

Merci de ton interet et de ton aide
Messages postés
18149
Date d'inscription
lundi 15 janvier 2007
Statut
Contributeur
Dernière intervention
4 juillet 2020
4 887
y aurait-t-il une limite dans la longueur du chemin ?
Normalement non puisque sur les autres serveurs (une vingtaine) cela ne pose aucun problème avec les memes commandes
Messages postés
35003
Date d'inscription
dimanche 7 novembre 2010
Statut
Contributeur
Dernière intervention
4 juillet 2020
5 248 > Stephane
Salut,

Est-ce que tous les serveurs ont la même configuration, tant au niveau système d'exploitation (OS/version), noyau, paquets, etc. ?
Effectivement les noyaux ne sont pas identiques
Euh... comment mettre a jour le noyau sous red hat ?
Messages postés
29252
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
2 juillet 2020
6 882
Bonjour,

Comme ici, s'agit ici de monter un partage réseau (samba/cifs), donc les droits que tu auras sont la conséquence des paramètres que tu auras passé à la commande
mount
(soit explicitement, via
-o
, soit implicitement, via
/etc/fstab
).

La solution la plus simple consiste à monter le dossier "comme si" c'était ton utilisateur qui l'avait monté (actuellement, il est monté par root, donc avec des droits administrateurs). Tu peux pour cela utiliser les options
uid
et
gid
. Ton UID et ton GID (généralement 1000 ou plus) se retrouvent respectivement dans
/etc/passwd
et
/etc/group
. Les deux sont généralement égaux. Ton utilisateur principal à généralement un UID égal à 1000. Tu peux les retrouver ainsi :

grep ^$(whoami): /etc/passwd | cut -d":" -f3 # ou echo $UID
grep ^$(whoami): /etc/group | cut -d":" -f3


Conformément à ce qui est expliqué dans cet exemple, tu peux alors préciser au moment du montage ton UID et ton GID.

Afin d'éviter d'avoir un mot de passe en clair dans un fichier accessible à tous (
/etc/passwd
) je te recommande de déporter ton login et le mot de passe samba dans un fichier externe, comme expliqué dans cette page cette page de référence.

Au final ta ligne ressemblera à ceci (en admettant que ton UID et ton GID sont égaux à 1000) :

//MONSERVEUR/MonPartage /media/info/ cifs credentials=/root/smb.cred,uid=1000,gid=1000 0 0


... et le fichier
/root/smb.cred
:

username=user_name
password=password
domain=domain_name


... avec les permissions
rw-------
:

chmod 600 /root/smb.cred


Enfin, pour un contrôle plus précis des permissions, il peut être intéressant de personnaliser ton umask via
/etc/samba/smb.conf
.

Bonne chance