Macro sélection ne marche pas dans une feuille protégée Excel

[Résolu/Fermé]
Signaler
-
 Amar -
Bonjour,
J'ai créé une macro dont voici un extrait:
Sheets("AdmisTL").Activate
Set c = Range("B13")
Range(c, c.End(xlDown).End(xlToRight)).Select
Selection.Clearcontents

Selection.Sort key1:=Range("G13"), Order1:=xlDescending, key2:=Range("D13"), Order2:=xlAscending, key3:=Range("C13"), Order3:=xlAscending, Header:=xlGuess, Orientation:=xlTopToBottom
Range("B13").Select
Mais sur ma feuille protégée, il signale un bug (partie gras).
Aidez moi à résoudre ce problème sur une feuille protégée.
Merci

6 réponses

Messages postés
15974
Date d'inscription
dimanche 25 novembre 2007
Statut
Membre
Dernière intervention
23 septembre 2021
1 535
Re,

exemple a mettre dans VBA Thisworkbook en adaptant le nom de feuille et le mot de passe
Private Sub Workbook_Open()
    Worksheets("feuil3").protect Password:="TOTO", UserInterfaceOnly:=True
End Sub
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 42674 internautes nous ont dit merci ce mois-ci

Messages postés
15974
Date d'inscription
dimanche 25 novembre 2007
Statut
Membre
Dernière intervention
23 septembre 2021
1 535
Bonjour,

enlever protection avant le Clear et remettre apres par programme

voir
Unprotect 

et
Protect


ou
 protect userinterfaceonly
qui permet d'ecrire sans deproteger
Bonjour f894009,
En fait je n'ai pas de protection par programmation, mais onglet révision puis protéger la feuille....
Une solution macro serait la bienvenue.
Merci pour la diligence quand même.
Bonjour,
La macro marche bien mais ne répond pas à mon problème.
Sur la feuille en question il y a des boutons pour "Générer","Annuler" et autres. Et ces boutons ne fonctionnent pas quand la feuille est protégée.
Mais je voudrai que ça marche même si la feuille est protégée car je dois partager le classeur.
Merci encore.
Messages postés
15974
Date d'inscription
dimanche 25 novembre 2007
Statut
Membre
Dernière intervention
23 septembre 2021
1 535
Bonjour,

Et ces boutons ne fonctionnent pas
Ben si, userinterfaceonly est fait pour
Oh oui!!! Vous avez parfaitement raison. J'ai vérifié et ça marche.
Mon problème est résolu.
Merci sincèrement.