Formule matricielle calc [Résolu/Fermé]

Signaler
Messages postés
1234
Date d'inscription
mercredi 11 mai 2005
Statut
Membre
Dernière intervention
25 janvier 2018
-
Messages postés
1234
Date d'inscription
mercredi 11 mai 2005
Statut
Membre
Dernière intervention
25 janvier 2018
-
Bonjour,

je suis sous libreoffice calc 4 version windows 7 la formule matricielle ne marche plus comme avant il y a 5 ans que je n'en fais plus.
=SI(A1:A5="ICI";si(B1:B5="Janvier";X1:X5)) le tout avec la combinaison CTRL + MAJ + ENTREE ou fonction et je coche matrice.
pourquoi j'écris cette formule il met #valeur ou sinon il met un 0 sur 5 lignes, est-ce un bug ?
merci

2 réponses

Messages postés
53126
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
21 janvier 2021
15 105
Bonjour.

J'ai
Libre Office Version: 5.1.5.2
et quand je cherche à reconstituer tes manipulations je ne tombe jamais sur une option "matrice" !
En saisissant ta formule en A7 j'obtiens la valeur FAUX dans les cellules A7 à A11 si la cellule en A1:A5 est différente de "ICI", et une cellule vide dans le cas contraire ...
Messages postés
1234
Date d'inscription
mercredi 11 mai 2005
Statut
Membre
Dernière intervention
25 janvier 2018
257
Moi aussi j'obtiens ce même résultat, c''est dommage que çà ne fonctionne plus comme avant.
Cette formule vérifié si en colonne A et B (par exemple) c'est dans mon champ de recherche et donc elle me donne en résultat colonne C. et lorsque je fais maj + entrée il met la formule ente { }. Mais Libreoffice ne marche pas comme çà j'ai remarqué alors je faisais un clique sur l'icône 'fx' et je cochais matrice, çà marchait plutôt bien.
Je me demande si un module n'a pas été enlevé dans Libreoffice.
Messages postés
2428
Date d'inscription
mercredi 3 février 2010
Statut
Membre
Dernière intervention
22 janvier 2021
921
Bonjour,
Ne serait-ce pas la formule qui a été amputée:
=SOMME(SI(A1:A5="ICI";SI(B1:B5="Janvier";X1:X5))) fonctionne mieux en matricielle.
Messages postés
1234
Date d'inscription
mercredi 11 mai 2005
Statut
Membre
Dernière intervention
25 janvier 2018
257
oui la formule matricielle fonctionne uniquement en commençant avec =SOMME(SI ou =NB(SI
merci