DATEDIF - Calculer ancienneté conditionnelle (Excel 2010) [Fermé]

Signaler
-
 Ad -
Bonjour,

J'aimerais calculer le temps resté dans l'entreprise. Je voudrais obtenir le nombre de mois passés dans l'entreprise, à la fois pour les employés qui y sont toujours mais aussi pour ceux qui sont partis. En gros je veux faire une DATEDIF avec date d'entrée; date de sortie et si la case date de sortie est vide mettre une fonction aujourd'hui par défaut. Est-ce que vous voyez ce que je veux dire ?

Merci d'avance,

3 réponses

Merci beaucoup mrjenkins pour cette réponse expresse !

J'ai mis cette formule : =SI(ESTVIDE(O2), DATEDIF(A2,AUJOURDHUI(),"m"), DATEDIF(A2,O2,"m")) mais ça ne marche pas... Est-ce que vous savez pourquoi ?
3
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Messages postés
577
Date d'inscription
jeudi 22 novembre 2007
Statut
Membre
Dernière intervention
17 juillet 2018
83
Qu'avez-vous comme erreur ?

J'imagine qu'en A, c'est la date d'entrée, et en O la date de sortie ?

Votre excel est bien en français ?
Dans le doute, remplacez les virgules par des point virgules :
=SI(ESTVIDE(O2); DATEDIF(A2;AUJOURDHUI();"m"); DATEDIF(A2;O2;"m"))
>
Messages postés
577
Date d'inscription
jeudi 22 novembre 2007
Statut
Membre
Dernière intervention
17 juillet 2018

Moi même j'essaye ça ne marche cette formule. En validant ça m'affiche un message disant vous avez tapé un nombre insuffisant pour cette fonction
C'est bon, ça marche avec les points virgules ! Vous ne pouvez pas imaginer à quel point c'est un soulagement d'avoir réussi à faire ça. Ma chef vous en est très reconnaissante !! Merci
Messages postés
577
Date d'inscription
jeudi 22 novembre 2007
Statut
Membre
Dernière intervention
17 juillet 2018
83
Pas de quoi ;)
Messages postés
577
Date d'inscription
jeudi 22 novembre 2007
Statut
Membre
Dernière intervention
17 juillet 2018
83
Salut,

avec la date d'entrée en A, la date de sortie en B (vide si pas de sortie), et le temps écoulé en mois en C :

=SI(ESTVIDE(B2), DATEDIF(A2,AUJOURDHUI(),"m"), DATEDIF(A2,B2,"m"))

à mettre dans la colonne C
--
Messages postés
4148
Date d'inscription
mardi 5 février 2013
Statut
Membre
Dernière intervention
25 février 2019
1 297
Bonjour

Dans la formule au lieu de mettre des virgules ,tu mets des points virgule
Cordialement
Messages postés
577
Date d'inscription
jeudi 22 novembre 2007
Statut
Membre
Dernière intervention
17 juillet 2018
83
C'est ce que je lui ai dit. Ca dépend des options de régions (étant au Luxembourg, chez moi, il faut mettre des virgules ^^)