Exercice d'application de la fonction "SI" sur Excel

[Résolu/Fermé]
Signaler
Messages postés
19
Date d'inscription
jeudi 22 octobre 2015
Statut
Membre
Dernière intervention
22 mai 2018
-
Messages postés
54703
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 septembre 2021
-
Bonsoir,
J'ai exercice que je dois vérifier en utilisant Excel, mais je n'arrive pas à trouver la formule idéale, je tourne autour de la solution depuis plusieurs heures.
Le contexte étant:
Des commerciaux reçoivent une commission en fonction des ventes qu'ils ont effectués dans le mois. Soit x la commission, CA le chiffre d'affaire réalisé , on a les barèmes et les taux correspondant pour les CA suivant :5000e, 8000e et 10 000e.
-Si 5000>CA , x=CA*3%
-Si 8000>CA>5000 , x=5000*3%+(CA-5000)*4%
-Si 10 000>CA>8000, x=5000*3%+3000*4%+(CA-8000)*6%
-Si CA>10 000, x=5000*3%+3000*4%+2000*6%+(CA-10 000)*8%

Je dois utiliser uniquement la fonction "si" pour l'écriture de ma formule dans Excel.
Dans mon exemple, j'utilise la valeur du chiffre d'affaire dans la cellule A1.

=SI(A1>8000;SI(A1>10000;5000*3%+3000*4%+2000*6%+(A1-10000)*8%;5000*3%+3000*4%+(A1-8000)*6%);5000*3%+(A1-5000)*4%)

A cette étape, je n'ai pas intégrer les CA inférieurs à 5000e mais la formule fonctionne très bien pour le reste.


=SI(A1>8000;SI(A1>10000;5000*3%+3000*4%+2000*6%+(A1-10000)*8%;5000*3%+3000*4%+(A1-8000)*6%);SI(8000>A1>5000;5000*3%+(A1-5000)*4%;A1*3%))

Avec celle-ci je pensais avoir enfin résolu le problème mais Excel ne tient pas compte de mon dernier point virgule on dirait ?
Merci de votre aide !

1 réponse

Messages postés
54703
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
24 septembre 2021
16 599
Question déjà posée dans le forum Bureautique: Excel !
https://forums.commentcamarche.net/forum/affich-32682040-la-fonction-si

C'est bien, la retraite ! Surtout aux Antilles ... :-)
Raymond (INSA, AFPA, CF/R)