Proxy inaccessible Squid + Windows 7 [Résolu/Fermé]

Signaler
Messages postés
2
Date d'inscription
jeudi 20 novembre 2014
Statut
Membre
Dernière intervention
20 novembre 2014
-
Messages postés
179626
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
9 août 2020
-
Bonjour à tous,

je suis entrain de mettre en place un proxy web et j'ai une question concernant la machine qui est le PROXY.

La configuration réseau que je souhaite mettre en place est la suivante :

Internet <----> MODEM/ROUTEUR <----> PROXY <----> SWITCH <----------> LAN


MODEM/ROUTEUR : Netgear ADSL2+ Modem/Router (avec Firewall intégré), configuré en 192.168.1.254

PROXY : Machine sous Windows 7, avec 2 cartes réseaux :
- la première connectée directement à mon modem/routeur (192.168.1.253)
- la deuxième connectée au switch (192.168.1.252)

SWITCH : Switch classique (192.168.1.251) sans configuration particulière (pas de VLAN)

LAN : réseau du type 192.168.1.0/24 avec différentes machines connectées sur le switch (DHCP fournit par le modem/routeur)

J'ai configuré mon proxy avec SQUID, mis en place mon ACL de test (blocage de facebook).
Je configure mon navigateur web de mon proxy en mettant l'interface 192.168.1.253. Je lance mon navigateur, je tente d'accéder à facebook et HOP, page du proxy « Accès non autorisé ».

Cool ça à l'air de fonctionner...

Pour que mes machines sur mon LAN obtienne une IP par mon modem/routeur (qui fait DHCP), je dois mettre un pont entre mes 2 cartes réseaux.
Sauf que dès lors que le pont est actif, si je refais le test d'accès à Facebook, j'ai l'erreur suivante : « Impossible de se connecter au serveur proxy : ERR_PROXY_CONNECTION_FAILED

Bien entendu si je tente d'accéder à Internet avec proxy sur une de mes machines dans le LAN, j'ai la même erreur : « Impossible de se connecter au serveur proxy : ERR_PROXY_CONNECTION_FAILED »

Et si j'enlève le pont, cela fonctionne sur mon proxy mais pas sur mes autres machines LAN...


Quelqu'un a t-il déjà été confronté à cette situation et si oui quelle solution peut on mettre en place ?

En vous remerciant par avance



2 réponses

Messages postés
179626
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
9 août 2020
21 711
Salut,

A mon avis, y a un prob de branchements.

PROXY : Machine sous Windows 7, avec 2 cartes réseaux :

A moins de ne pas tout avoir compris.
Quel est l'interêt d'avoir deux cartes réseaux sur ton poste client ?
surtout qu'elles ont l'air d'avoir le même adressage.

Ca peut-être interressant à la limite au niveau de la machine Proxy, si tu veux mettre en place une DMZ, mais sur ton poste client, je vois pas l'interêt.


Donc :
- soit tu branches tout sur le switch avec une seule carte réseau partout et tu désactives le DHCP du modem/routeur et tu le mets sur le proxy pour pas qu'il y est une route sur les clients directs par le routeur.
- soit les clients sur le switch, une carte réseau de la machine proxy sur le switch, et l'autre carte sur le modem et le serveur proxy fait DHCP.
Les bonnes routes sur la machine proxy et ça va rouler.

Like the angel you are, you laugh creating a lightness in my chest,
Your eyes they penetrate me,
(Your answer's always 'maybe')
That's when I got up and left
Messages postés
2
Date d'inscription
jeudi 20 novembre 2014
Statut
Membre
Dernière intervention
20 novembre 2014

Muahahahahahahahahahahah merci beaucoup...

Pourquoi faire simple quand on peut faire compliquer, c'est tout à fait moi ça -_-'

Effectivement en ne gardant qu'une interface et en la connectant directement à mon switch, je passe par le proxy partout :)

Merci beaucoup!
Messages postés
179626
Date d'inscription
mercredi 17 mai 2006
Statut
Modérateur, Contributeur sécurité
Dernière intervention
9 août 2020
21 711
Pas de problème :)