Utilisation Java impossible depuis màj X.10

Fermé
SonyXperiaSP
Messages postés
87
Date d'inscription
lundi 16 juin 2014
Statut
Membre
Dernière intervention
18 juin 2015
- Modifié par SonyXperiaSP le 27/10/2014 à 14:35
SonyXperiaSP
Messages postés
87
Date d'inscription
lundi 16 juin 2014
Statut
Membre
Dernière intervention
18 juin 2015
- 29 oct. 2014 à 16:23
Bonjour,
J'ai mis à jour mon système en OS X.10. Depuis impossible de faire fonctionner l'appli de chargement Monéo avec Java.

J'ai donc désinstallé Java et réinstallé la
version 8 mise à jour 25 (build 1.8.0_25b17)


Le problème vient surtout du fait que je ne peux plus charger ma carte monéo (carte de cantine) car la carte n'est plus reconnue par l'ordinateur. Lorsque je l'insert dans le lecteur Teo de la marque Xiring, la led verte s'allume quelques secondes avant de s'éteindre (alors que normalement elle doit rester allumée).

# J'ai testé mon lecteur sur le port usb du pc de mon pote et ça fonctionne (donc pas de souci matériel).
# J'ai testé si Firefox reconnait bien Java et oui ça fonctionne (test sur le site java.com et oracle.com)
# J'ai ajouté de nouveau le site moneo.net dans ma liste de confiance ainsi que le serveur de chargement des cartes.


Je ne sais pas ce qui plante et sans crédit sur ma carte, pas de resto U ou de café à la pause (le crous n'accepte plus les paiements en espèces) :(

>> Pour ceux qui veulent de la lecture officielle sur le lecteur et le mode de fonctionnement du rechargement c'est ici : http://www.moneo.com/boutique/lecteurs-moneo/lecteur-teo



Sony Xperia Z 4G (modèle : C6603)
Étudiant un jour, fauché toujours !

1 réponse

*_Francis_*
Messages postés
39262
Date d'inscription
mardi 2 octobre 2007
Statut
Modérateur
Dernière intervention
19 mai 2022
11 411
Modifié par *_Francis_* le 27/10/2014 à 16:34
Bonjour,

Je tente une piste :

Pour un Mac, il faut une version particulière de Java. D'ailleurs lorsque Mac OS en a besoin, il vous suggère une installation automatique. Sinon, il faut prendre cette version selon le site de Java :
https://www.java.com/fr/download/help/mac_install.html

Si vous pensez avoir la bonne version, oubliez ce message. Mais c'est tout de même une vérification à faire.

PS: http://lemagtechno.com/installer-java-yosemite/

Cordialement

Pour obtenir une réponse appropriée, indiquez toujours votre configuration système exacte.
Bonne Journée :-) - Francis
0
SonyXperiaSP
Messages postés
87
Date d'inscription
lundi 16 juin 2014
Statut
Membre
Dernière intervention
18 juin 2015
7
Modifié par SonyXperiaSP le 27/10/2014 à 18:11
bonjour,
je vous remercie du coup de pouce.

Malheureusement ça ne fonctionne pas dans un cas comme dans l'autre.
J'ai testé avec le PKG de chez apple mais ça ne fonctionne pas ... Dans l'autre cas, impossible d'installer le PKG (dmg modifié) alors même que j'avais supprimé le PKG Apple via AppCleaner
0
*_Francis_*
Messages postés
39262
Date d'inscription
mardi 2 octobre 2007
Statut
Modérateur
Dernière intervention
19 mai 2022
11 411
27 oct. 2014 à 18:26
Il se peut que l'une des versions installées empêche l'installation de la bonne version. Il faudrait tenter une désiinstallation complète. Ce que AppCleaner ne fait pas.
Voir ici:
https://www.java.com/fr/download/help/mac_uninstall_java.html

Si ensuite avec la bonne installation de Java, ça ne fonctionne toujours pas, c'est qu'il y a peut-être réellement une mise à jour à faire dans Yosemite, ou un bug...

Voir éventuellement le bas de cette page:
https://www.securitemac.com/java-mac.html
0
SonyXperiaSP
Messages postés
87
Date d'inscription
lundi 16 juin 2014
Statut
Membre
Dernière intervention
18 juin 2015
7
29 oct. 2014 à 16:23
mince, ça ne fonctionne toujours pas ... je suis passé par la ligne de commande et ça a supprimé Java. J'ai réinstallé une nouvelle version (depuis le site oracle, comme d'hab') mais le site/mac ne veut rien savoir

En passant par mon PC Win7 émulé grâce à VirtualBox et à la licence fournie dans le programme étudiant j'ai réussi à installer Firefox + Java Win et ça a fonctionné.

Cela veut donc dire que le mac détecte bien le lecteur de carte puisqu'un "sous-système" peut le faire fonctionner, non ?
0