Windows 7 ne démare plus depuis que j'ai Ubuntu.

Fermé
Signaler
Messages postés
30
Date d'inscription
dimanche 6 juillet 2014
Statut
Membre
Dernière intervention
16 septembre 2014
-
Messages postés
30
Date d'inscription
dimanche 6 juillet 2014
Statut
Membre
Dernière intervention
16 septembre 2014
-
Bonjour, très chère communauté qu'elle est gentille et que je vous aime tous.
Je viens juste de partitionner mon disque dur pour installer Ubunutu 14.04 à côté de Windows 7.

Et maintenant, lorsque Grub me propose de choisir entre lancer Ubuntu ou seven, si je choisis Ubuntu, il se lance normalement. Et si je choisis Seven, l'écran devient noir durant 1 ou 2 secondes, puis je reviens à l'écran de boot.

On notera que, lors du partitionnage, j'ai semblerait-il supprimé la partition recovery de windows.
Du coup je me demande si j'ai pas fait un grosse connerie, et je vous demande si vous connaissez un solution à mon problème.

Voilà voilà, merci d'avance.


5 réponses


Salut,

Installe le programme boot-repair en suivant cette procédure :

http://forum.ubuntu-fr.org/viewtopic.php?pid=16690381#p16690381

Tu ne fais pas la réparation recommandée, mais tu choisis "faire un rapport boot-info" et tu donnes le lien correspondant à ce rapport.
Messages postés
30
Date d'inscription
dimanche 6 juillet 2014
Statut
Membre
Dernière intervention
16 septembre 2014

J'ai fait tout ça, on me retourne l'URL suivante: paste.ubuntu.com/8334195/
Salut,

Déjà, une simple question... pourquoi avoir installé grub dans la partition Windows au lieu du mbr du disque ? Ce genre d'installation est souvent cause de plantages.

Boot-repair te propose de réinstaller grub dans le mbr... peut-être que ça peut suffire (restaure-t-il le secteur de boot de la partition ? Mystère) . Je n'en suis pas sûr.

As-tu un DVD ou une clé ou W7 (ou la console de réparation) ? Si tu ne le possèdes pas, il faudra utiliser testdisk pour récupérer le secteur de boot de la partition.
Messages postés
30
Date d'inscription
dimanche 6 juillet 2014
Statut
Membre
Dernière intervention
16 septembre 2014

Hum.... personnellement je n'ai pas touché à Grub (enfin pas volontairement en tout cas, ni consciemment)
C'est peut-être bien bootmgr en effet.
Je vais tenter la réparation automatique de boot-repair alors.
Donne le résultat de

bcdedit /v

On va vérifier que le bootloader de windows pointe dans la bonne direction... Selon le résultat, on avisera.

Edit. A priori, les problèmes de grub mal placés sont réglés, et plus rien n'indique de problème à propos du dual boot. Pour en être sûr à 100 %, un bootrec /fixmbr remettrait le disque dans son état initial. Mais attention, Ubuntu ne se lancera plus provisoirement (il faudra réinstaller grub avec boot-repair pour le réactiver). Donc, à toi de voir.

Selon moi, tu n'as pas supprimé que la seule partition recovery lors de l'installation, mais tu as aussi supprimé la partition contenant le bootloader. Il faut donc reconstruire ce loader en le plaçant sur la partition active actuelle. Essaie une nouvelle fois de réparer automatiquement le démarrage avec l'option 1 du menu proposé par le DVD W7 en mode "réparer".

Tu es dans le même cas qu'ici :

https://openclassrooms.com/forum/sujet/windows-7-bloque-au-demarrage-13652#message-5688267

Si ça ne veut rien savoir, on pourra essayer de réduire la partition racine d'ubuntu, créer une partition de 100 Mo pour installer le loader et recommencer le processus.
Messages postés
30
Date d'inscription
dimanche 6 juillet 2014
Statut
Membre
Dernière intervention
16 septembre 2014

Alors: le bcdedit /v me donne:

Gestionnaire de démarage windows
------------------------------------------------------------------------------------------------------
Identificateur {9dea862c-5cdd-4e70-acc1-f32b344d4795}
device: partition=C:
description: Windows Boot Manager
locale: en-us
inherit: {7ea2e1ac-2e61-4728-aaa3-896d9d0a9f0e}
default: {8cb2d9b7-7c05-11de-842e-b4611d44fefa}
resumobject: {8cb2d9b6-7c05-11de-842e-b4611d44fefa}
displayoreder: {8cb2d9b7-7c05-11de-842e-b4611d44fefa}
{8cb2d9b1-7c05-11de-842e-b4611d44fefa}
tooldisplayorder: {b2721d73-1db4-4c62-bf78-c548a880142d}
timeout: 30

Chargeur de démarage Windows
-----------------------------------------------------------------------------------------------------------
identificateur: {8cb2d9b7-7c05-11de-842e-b4611d44fefa}
device: Partition=C:
path: \Windows\system32\winload.exe
description: Windows 7
locale: en-us
inherit: {6efb52bf-1766-41db-a6b3-0ee5ff72bd7}
recoverysequence: {8cb2d9b4-7c05-11de-842e-b4611d44fefa}
recoveryenabled: Yes
osdevice: partition=C:
systemboot: \Windows
resumobject: {8cb2d9b0-7c05-11de-842e-b4611d44fefa}
nx: OptIn
detechtal: Yes

Chargeur de démarage Windows
-----------------------------------------------------------------------------------------------------------
identificateur: {8cb2d9b7-7c05-11de-842e-b4611d44fefa}
device: boot
path: \Windows\system32\winload.exe
description: Windows 7
locale: fr-FR
inherit: {6efb52bf-1766-41db-a6b3-0ee5ff72bd7}
recoverysequence: {8cb2d9b4-7c05-11de-842e-b4611d44fefa}
recoveryenabled: Yes
osdevice: boot
systemboot: \Windows
resumobject: {8cb2d9b0-7c05-11de-842e-b4611d44fefa}
nx: OptIn


Note: autant je tiens à mon windows, autant ça me dérange d'exploser mon Linux, j'aurai qu'à le réinstaller.
Comme je te l'ai dit, il semble que le problème ne soit plus dû à Linux et au dual-boot, mais à ton Windows lui-même. Le désinstaller ne me semble pas réellement urgent.

As--tu essayé la réparation automatique du démarrage via l'option 1 du DVD W7 ? La commande bcdedit /v affiche des manques et une entrée inutile vers un recovery qui n'existe plus (et dont l'identificateur est le même que celui de Windows).

Si la réparation automatique ne fonctionne pas, on peut essayer en manuel la séquence suivante:

bcdedit /export c:\sauvebcd
On a une copie de sauvegarde au cas-où. Puis,

bcdedit /set {bootmgr} device partition=c:
bcdedit /set {bootmgr} path \bootmgr
bcdedit /set {bootmgr} displaybootmenu yes

Respecte le sens des slashs et des majuscules. Tu me refais une capture du résultat par copier / coller ou par simple photo (ça évite de tout taper). Si ça passe, on devrait obtenir un menu avec deux entrées Windows.... dans un monde idéal.
Messages postés
30
Date d'inscription
dimanche 6 juillet 2014
Statut
Membre
Dernière intervention
16 septembre 2014

ça m'a juste dit
"opération réussie" pour chacune des 4 lignes de commande.

c'est tout.
Refais-moi un bcdedit /v (fais une photo pour ne pas avoir à tout recopier)

PS. Tu n'as toujours pas répondu à ma question sur la réparation automatique du démarrage, malgré deux demandes.
Messages postés
30
Date d'inscription
dimanche 6 juillet 2014
Statut
Membre
Dernière intervention
16 septembre 2014


Voilà voilà ...
Messages postés
30
Date d'inscription
dimanche 6 juillet 2014
Statut
Membre
Dernière intervention
16 septembre 2014

Oui. C'est pas la première fois que je grave un CD d'installation d'OS. Normalement je maîtrise.
Je vais voir s je peux "tester ubuntu" depuis la clef d'install, et mv tout mes fichiers sur un DDE
Utilisateur anonyme
On peut réactiver ton Linux, si tu veux, tu auras déjà au moins ça.
Messages postés
30
Date d'inscription
dimanche 6 juillet 2014
Statut
Membre
Dernière intervention
16 septembre 2014

je veux bien.
Utilisateur anonyme
Tu démarres sur le live-cd, tu te connectes sur Internet, puis tu installes boot-repair selon la méthode simplifiée proposée ici

http://forum.ubuntu-fr.org/viewtopic.php?pid=16690381#p16690381

Tu fais une réparation recommandée, ça doit suffire.
Messages postés
30
Date d'inscription
dimanche 6 juillet 2014
Statut
Membre
Dernière intervention
16 septembre 2014

Ok merci merci