Suppression dossiers dans C:\user impossible

[Résolu/Fermé]
Signaler
Messages postés
143
Date d'inscription
mardi 11 septembre 2012
Statut
Membre
Dernière intervention
7 mars 2021
-
Messages postés
143
Date d'inscription
mardi 11 septembre 2012
Statut
Membre
Dernière intervention
7 mars 2021
-
Bonjour,

J'ai supprimé deux comptes utilisateur pour ne conserver que mon compte XXX administrateur.
Mais impossible de supprimer les dossiers associés à ces deux comptes dans C:\user ;
Clique droit sur dossier puis supprimer s'affiche alors une fenêtre indiquant :
Soit « vous devez disposer des droits d'administrateur pour supprimer ce dossier »
Soit « vous devez disposer d'une autorisation pour effectuer cette action, vous avez besoin d'une autorisation de la part d'Administrateur pour modifier ce dossier »

J'ai essayé d'appliquer la procédure ci-dessous mais sans succès

Première étape : Afficher l'onglet Sécurité
Deuxième étape : S'approprier le dossier
* Clic droit sur le fichier / dossier
* Propriétés
* Sécurité
* Avancé
* Onglet Propriétaire
* Cliquer sur Modifier
* Sélectionner votre nom / votre session
* Cliquer sur "Appliquer" puis "OK".
Troisième étape : Ré-attribuer les droits d'accès
* Refaire un clic droit sur le fichier / dossier
* Propriétés
* Sécurité
* Groupes ou noms d'utilisateurs
* Cliquer sur "Modifier"
* Cliquer sur "Ajouter"
* Écrire son nom d'utilisateur / sa session
* En dessous, sélectionner "Tous les accès autorisés"
* Cliquer sur "Appliquer" puis sur "OK".

L'un d'entre vous connait il une solution .

Merci de votre aide





5 réponses

Messages postés
1646
Date d'inscription
lundi 21 juillet 2008
Statut
Membre
Dernière intervention
3 juin 2021
444
Bonjour,
il suffisait de cliquer sur "Continuer". Si tu possède les droits administrateur, le dossier se serait supprimé.

Sinon, clic droit sur le dossier -> onglet sécurité -> clic sur Avancé -> Modifier les autorisations -> Décoche la case "Inclure les autorisations pouvant être héritées du parent de cet objet" -> Bouton Supprimer. Ensuite, bouton Ajouter -> tape : Tout le monde -> OK -> Autoriser : Controle Total -> OK (autant de fois que nécessaires pour fermer les fenêtres.
Ensuite, supprime le dossier.
Messages postés
143
Date d'inscription
mardi 11 septembre 2012
Statut
Membre
Dernière intervention
7 mars 2021
31
Bonjour et merci de ta réponse.

Cela ne marche pas

Après clic droit sur le dossier -> onglet sécurité -> clic sur Avancé -> Modifier les autorisations -> Décoche la case "Inclure les autorisations pouvant être héritées du parent de cet objet" -> Bouton Supprimer. Ensuite, bouton Ajouter -> tape : Tout le monde -> OK -> Autoriser : Controle Total -> OK (autant de fois que nécessaires pour fermer les fenêtres.

Clic droit puis supprimer>>fenêtre "ce dossier est partagé avec d'autres personnes" (nota dans onglet partage pas de partage indiqué)

Continuer>>"vous devez disposer des droits d'administrateur pour supprimer ce dossier" (ce qui est le cas)

Continuer>> "vous devez disposer d'une autorisation pour effectuer cette action"

Nota: si je retourne sur l'onglet sécurité du fichier "tout le monde" a disparu pour être remplacé par mon nom d'utilisateur
Messages postés
1646
Date d'inscription
lundi 21 juillet 2008
Statut
Membre
Dernière intervention
3 juin 2021
444
Si les dossiers correspondent bien à des utilisateurs supprimés du système, le plus simple, c'est d'utiliser un Live CD de Linux (Ubuntu étant le plus connu et simple à utiliser). Étant donné que le Live CD ne connaitra pas le propriétaire du dossier, il te laissera les supprimer. (ça ne marche pas avec les CD Live Windows.)

Pour démarrer sur ce Live CD, tu dois configurer l'ordre de démarrage du BIOS pour démarrer d'abord sur le lecteur CD/DVD puis le disque dur. Tutoriel si besoin.
Ensuite, au démarrage sur ce Live CD, clique sur Essayer Ubuntu (cela ne modifiera rien sur ton disque dur) : http://doc.ubuntu-fr.org/_media/installation/live_cd_maverick3.png?w=195&tok=2c20f8
Messages postés
143
Date d'inscription
mardi 11 septembre 2012
Statut
Membre
Dernière intervention
7 mars 2021
31
Bonjour,

L'un d'entre vous a t il déjà utilisé le fichier.reg ci-dessous pour effacer des dossiers ne pouvant l'être ni sous mon profil ni sous le profil grand administrateur.

Merci de votre aide

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\*\shell\runas]
@="Grand Administrateur"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\*\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrateurs:F"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrateurs:F"

[HKEY_CLASSES_ROOT\exefile\shell\runas2]
@="Grand Administrateur"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\exefile\shell\runas2\command]
@="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrateurs:F"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" && icacls \"%1\" /grant administrateurs:F"

[HKEY_CLASSES_ROOT\Directory\shell\runas]
@="Grand Administrateur"
"NoWorkingDirectory"=""

[HKEY_CLASSES_ROOT\Directory\shell\runas\command]
@="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrateurs:F /t"
"IsolatedCommand"="cmd.exe /c takeown /f \"%1\" /r /d y && icacls \"%1\" /grant administrateurs:F /t"
Messages postés
143
Date d'inscription
mardi 11 septembre 2012
Statut
Membre
Dernière intervention
7 mars 2021
31
Bonsoir,

J'ai résolu le problème en utilisant Kaspersky Rescue disk très simple d'utilisation