Open office tableur/calc calcul [Résolu/Fermé]

Signaler
-
Messages postés
54102
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 juin 2021
-
Bonjour,

Je voudrais savoir si quelqu'un pouvait m'aider vis à vis du tableur avec Open Office...voilà comment fait-on ou quelle formule doit-on utiliser pour calculer un "nombre de débits supérieur à (une certaine somme), mais aussi la somme des débits supérieur à (une certaine somme) et la moyenne des débits supérieur à (une certaine somme) ?? J'ai toute une liste de débits de différents montants dans la colonne "débits" de mon tableur, et je dois calculer ce que j'ai indiqué précédemment...quelqu'un peut-il m'aider?? En espérant que ma demande est suffisamment compréhensible...Je vous remercie!

2 réponses

Messages postés
31
Date d'inscription
vendredi 5 avril 2013
Statut
Membre
Dernière intervention
10 mai 2013
3
Salut, il faudrais savoir quel utilité tu fais du tableur.

Tu as de nombreux exemple pour chaque utilité ici : https://forum.openoffice.org/fr/forum/viewtopic.php?t=358
Salut, merci d'avoir répondu! Bah concernant l'utilité, c'est simplement pour calculer le "nombre de débits supérieur à", la moyenne et la somme...c'est une statistique que je dois réaliser...merci pour ton fichier joint!
Messages postés
54102
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 juin 2021
16 094
Bonjour.

Liste des débits en A2:A21 -------------- Limite en C3

Nombre de débits supérieurs en D7 avec la formule =NB.SI(A2:A21;">"&C3)
Montant des débits supérieurs en D9 avec la formule =SOMME.SI(A2:A21;">"&C3)
Moyenne des débits supérieurs avec la formule que tu sauras bien écrire ...

https://www.cjoint.com/c/CDvhnNEJvQf

Cordialement.
Bonjour,
d'abord merci d'avoir répondu...mais par contre comment je fais si je n'ai pas de "limite" dans mon tableur...? J'ai bien compris votre formule, mais je n'ai pas de cellule "limite" comme dans celui que vous m'avez envoyé...Peut-être devrais-je vous envoyé l'exercice en question...le voici ci-dessous, voilà comment il se présente à peu de choses près...en espérant que vous que vous puissiez répondre...Merci bien!

Cdt,


A B C D E
Date opération Date valeur Libellé Débit Crédit
05/06/06 05/06/06 PRLV Abonnement 27,50 €
06/06/06 05/06/06 RET DAB 05/06/2006 80,00 €
07/06/06 07/06/06 CHQ 8765 57 782 285,00 €
12/06/06 10/06/06 F Cotisation 5,28 €
13/06/06 12/06/06 RET DAB 12/06/06 60,00 €
16/06/06 16/06/06 PRLV Trésor Public 493,00 €
21/06/06 21/06/06 CHQ 8765 57 783 9,00 €
22/06/06 21/06/06 RET DAB 21/06/2006 60,00 €
28/06/06 28/06/06 Virement Salaire 1 823,39 €
30/06/06 30/06/06 Carte 20/06 Essence 55,96 €
01/07/06 01/07/06 RET DAB 01/07/2006 80,00 €
01/07/06 30/06/06 Carte 26/06 PNEUS 269,70 €
02/07/06 30/06/06 Carte 20/06 Hyper 27,12 €
03/07/06 01/07/06 Vir périodiq 089721567 500,00 €
03/07/06 30/06/06 Carte 26/06 Hyper 28,65 €
04/07/06 04/07/06 PRLV Abonnement 27,50 €
05/07/06 30/06/06 Carte 02/07 Vêtements 57,31 €
06/07/06 06/07/06 Vir Mutuelle 11,00 €
Solde dernier extrait Compte chèques 1 626,83 €

Total 2 066,02 € 2 461,22 €

Débit minimum 5,28 €
Débit maximum 500,00 €
Nombre de débits supérieur à 50 € ????
Somme des débits supérieur à 50 € ????
Moyenne des débits supérieurs à 10€ ????
Lire le libellé de la date de valeur choisie (07/06/06)
Bon ok j'ai trouvé finalement j'ai trouvé pour la somme et le nombre mais je trouve pas pour la moyenne maintenant, c'est quoi la formule ?? "MOYENNE.SI" ça n'existe pas...
Messages postés
54102
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 juin 2021
16 094
... et SOMME/NOMBRE, ça n'existe pas non plus ?

Ton exemple (qu'il aurait été tellement plus simple, pour toi et pour nous, d'envoyer à l'aide de https://www.cjoint.com/ au lieu d'essayer de tout retaper) étant différent de ta question initiale, les formules doivent être adaptées :
* Les écritures sont saisies en A1:E21
* Concernant ton interrogation "J'ai bien compris votre formule, mais je n'ai pas de cellule "limite" comme dans celui que vous m'avez envoyé", c'est 50 ou 10, car finalement ton exemple propose deux limites différentes, ce qui n'était pas spécifié au départ !
* On va donc inscrire la limite 50 dans la cellule H7 et la limite 10 dans la cellule H10.
* Nombre des débits supérieurs à H7 avec la formule =NB.SI(D2:D20;">"&H7)
* Montant des débits supérieurs à H7 avec la formule =SOMME.SI(D2:D20;">"&H7)
* Moyenne des débits supérieurs à H10 avec cette dernière formule
=SOMME.SI(D2:D20;">"&H10)/NB.SI(D2:D20;">"&H10)
https://www.cjoint.com/c/CDvsLff2Nez

Quant à la phrase qui termine ton message "Lire le libellé de la date de valeur choisie (07/06/06)", je n'ai pas saisi sa raison d'être ...
Oui je sais que j'ai fait une erreur,j'ai oublié de mentionné 50 pour nombre et somme mais pour moyenne c'était 10 effectivement, quant au fait de copier/coller avec le "ci-joint", rassurez-vous j'y ai bien songé, hélas je ne savais pas comment on faisait, c'est la toute première fois, que je viens sur ce site...mais je trouvais moi aussi, bien évidemment, que ça aurait été bien plus simple pour vous...par contre je n'ai pas tout recopié manuellement, j'ai fait un copié/collé tout simplement, mais bon ça c'est pas très grave...Néanmoins je vous remercie bien de m'avoir aidé, c'est bon ça marche...à ce propos, pour la dernière phrase, elle correspond à une consigne à laquelle je dois répondre...
Messages postés
54102
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
20 juin 2021
16 094
OK ; c'est parfait ! Et à la prochaine.