Installation de paquets

Résolu/Fermé
Signaler
-
Messages postés
30374
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
3 décembre 2021
-
Bonjour,

POur installer l'outil générateur de traffic (de type VOIP) sipp, je dois installer ses pré-requis:
compilateur C++
librarie Curses
OpenSSL
libnet et libcap (pour le support RTP)

Sur le terminal ,j'ai tapé la commande: apt-get install make gcc g++ automake autoconf libncurses5-dev python build-essential openssl libpcap-dev libssl-dev libnet1-dev libgsl0-dev gsl-bin libgsl0ldbl

Mais ,on m'affiche:

Note : sélection de « libgphoto2-port0 » au lieu de « libgphoto2port »
Aucune version du paquet autoconf n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Impossible de trouver le paquet automake
E: Le paquet « autoconf » n'a pas de version susceptible d'être installée
E: Impossible de trouver le paquet libncurses5-dev
E: Impossible de trouver le paquet build-essential
E: Impossible de trouver le paquet libpcap-dev
E: Impossible de trouver le paquet libssl-dev
E: Impossible de trouver le paquet libnet1-dev
E: Impossible de trouver le paquet libgsl0-dev
E: Impossible de trouver le paquet gsl-bin
E: Impossible de trouver le paquet libgsl0ldbl


J'arrive pas à installer ces packages .
Pouvez-vous m'aider ?
merci d'avance
A voir également:

13 réponses

Bonjour,

J'ai installer libc-bin 2.15-0ubuntu10.3 et j'ai besoin de la version 2.15-0ubuntu10.2 afin d'installer libc6 2.15-0ubuntu10.2 .
Que dois-je faire?
J'ai vraiment besoin de votre aide.

Merci d'avanace

PS:j'utilse ubuntu 12.04lts
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 41989 internautes nous ont dit merci ce mois-ci

Messages postés
1053
Date d'inscription
mercredi 17 octobre 2012
Statut
Membre
Dernière intervention
17 mai 2015
165
Bonjour regarde en bas de la page (8. Installation des outils GNU autotools) http://doc.ubuntu-fr.org/compilation
bonjour Pierre8888,
j'ai pas réussi à installer le package automake

sudo apt-get install autoconf automake
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet autoconf n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

E: Le paquet « autoconf » n'a pas de version susceptible d'être installée
E: Impossible de trouver le paquet automake


Puvez-vous m'aider.Merci d'avance
Messages postés
30374
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
3 décembre 2021
7 238
Il doit te manquer des dépôts, car l'un de ceux configurer dans /etc/apt/sources.list est sensé te fournir ce paquet.
http://www.mistra.fr/tutoriel-linux-apt-configuration.html
http://doc.ubuntu-fr.org/tutoriel/comment_modifier_sources_maj

Normalement il est sensé être dans le dépôt principal d'après :
https://packages.ubuntu.com/fr/raring/autoconf

Commence par lancer :

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install autoconf automake


Si ça ne change rien, reporte-moi le résultat de :

cat /etc/apt/sources.list


Bonne chance
Messages postés
2
Date d'inscription
mercredi 17 avril 2013
Statut
Membre
Dernière intervention
17 avril 2013

les commandes que vous m'avez envoyé ne marchent pas.

voilà le contenu de fichier /etc/apt/sources.list

cat /etc/apt/sources.list
#deb cdrom:[Ubuntu 12.04.2 LTS _Precise Pangolin_ - Release i386 (20130213)]/ precise main restricted

# See https://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
# newer versions of the distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ precise main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ precise main restricted

## Major bug fix updates produced after the final release of the
## distribution.
deb http://fr.archive.ubuntu.com/ubuntu/ precise-updates main restricted
deb-src http://fr.archive.ubuntu.com/ubuntu/ precise-updates main restricted

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team. Also, please note that software in universe WILL NOT receive any
## review or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ precise universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ precise universe
deb http://fr.archive.ubuntu.com/ubuntu/ precise-updates universe
deb-src http://fr.archive.ubuntu.com/ubuntu/ precise-updates universe

## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
## team, and may not be under a free licence. Please satisfy yourself as to
## your rights to use the software. Also, please note that software in
## multiverse WILL NOT receive any review or updates from the Ubuntu
## security team.
deb http://fr.archive.ubuntu.com/ubuntu/ precise multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ precise multiverse
deb http://fr.archive.ubuntu.com/ubuntu/ precise-updates multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ precise-updates multiverse

## N.B. software from this repository may not have been tested as
## extensively as that contained in the main release, although it includes
## newer versions of some applications which may provide useful features.
## Also, please note that software in backports WILL NOT receive any review
## or updates from the Ubuntu security team.
deb http://fr.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse
deb-src http://fr.archive.ubuntu.com/ubuntu/ precise-backports main restricted universe multiverse

deb http://security.ubuntu.com/ubuntu/ precise-security main restricted
deb-src http://security.ubuntu.com/ubuntu/ precise-security main restricted
deb http://security.ubuntu.com/ubuntu/ precise-security universe
deb-src http://security.ubuntu.com/ubuntu/ precise-security universe
deb http://security.ubuntu.com/ubuntu/ precise-security multiverse
deb-src http://security.ubuntu.com/ubuntu/ precise-security multiverse

## Uncomment the following two lines to add software from Canonical's
## 'partner' repository.
## This software is not part of Ubuntu, but is offered by Canonical and the
## respective vendors as a service to Ubuntu users.
# deb http://archive.canonical.com/ubuntu/ precise partner
# deb-src http://archive.canonical.com/ubuntu/ precise partner

## This software is not part of Ubuntu, but is offered by third-party
## developers who want to ship their latest software.
deb http://extras.ubuntu.com/ubuntu/ precise main
deb-src http://extras.ubuntu.com/ubuntu/ precise main
Messages postés
2
Date d'inscription
mercredi 17 avril 2013
Statut
Membre
Dernière intervention
17 avril 2013

Bonjour,

j'ai pu installer les paquets ( automake, libncurses5-dev,libpcap-dev,libssl-dev,libnet1-dev,libnet1-dev, libgsl0-dev,gsl-bin, libgsl0ldbl )
Mon problème est d'installer le paquet build-essential.J'ai utilisé ubuntu software center pour l'installer (je l'ai utilisé pout les autres paquets aussi);J'ai toujours ce problème dependancy is not satisfiable:g++(>=4:4.4.3)
SVP J'ai besoin de votre aide.
Merci d'avance


PS:J'UTILSE UBUNTU 12.04TLS
Messages postés
30374
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
3 décembre 2021
7 238
Ah donc le problème est différent car avant tu avais une liste de paquets non trouvés.

Au sujet de build essentiel si on va ici :
https://packages.ubuntu.com/fr/precise/build-essential

... on voit que ce paquet existe bien dans les dépôts precise, qu'il dépend bien de g++ >= 4:4.4.3 qu'apt les trouve bien chez toi, et qu'apt le trouve bien.

Ce qui est bizarre c'est qu'il devrait de la même façon trouver g++ qui est dans les mêmes dépôts :
https://packages.ubuntu.com/fr/precise/g++

À mon avis tu as une mise à jour qui n'est pas faite jusqu'au bout et tu as plein de paquets qui sont "bloqués" dans une vielle version. Peux-tu me copier coller le résultat complet de :

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install build-essential


Bonne chance
Messages postés
30374
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
3 décembre 2021
7 238
À mon avis tu as une mise à jour qui n'est pas faite jusqu'au bout et tu as plein de paquets qui sont "bloqués" dans une vielle version. Peux-tu me copier coller le résultat complet de :

sudo apt-get update
sudo apt-get upgrade
sudo apt-get install build-essential


Bonne chance
Bonjour,

sudo apt-get install build-essential
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Aucune version du paquet build-essential n'est disponible, mais il existe dans la base
de données. Cela signifie en général que le paquet est manquant, qu'il est devenu obsolète
ou qu'il n'est disponible que sur une autre source

sudo apt-get update
E: Impossible d'obtenir le verrou /var/lib/apt/lists/lock - open (11: Resource temporarily unavailable)
E: Impossible de verrouiller le répertoire /var/lib/apt/lists/

sudo apt-get upgrade
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.

Le problème je pense que j'ai un proxy sur mon pc donc je peux pas télécharger un paquet par exemple.
Bonjour,
Je veux te remercier au début pour votre aide mamiemando .
j'ai réussi à télécharger sipp (donc j'ai télécharger par la suite le paquet build-essential) sur mon pc personnel chez moi(en feit j'ai É pc:le premier qu'on m'a donné au travail et qui est relié à un proxy pour me connecter à internet et le deuxième est mon pc personnel).Je pense que le problème ,lors l'installation de paquet build-essential est du à la présence du proxy.
Maintenant,j'ai un nouveau soucis.Je dois effectuer plusieurs scénarios de tests afin de tester sipp .Aprés avoir effectuer des recherches sur le net :j'ai trouvé la commande suivante:
./sipp -sd uac_pcap > uac_pcap.xml
(uac_pcap est le scénario par défaut et pcap.xml est le nouveau scénario aveclequel je vais effectuer mes testes ).
mais ,on m'affiche sur le terminal:
bash: uac_pcap.xml: Permission denied

ESt ce que vous pouvez m'aider ?
Merci en avance
Messages postés
30374
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
3 décembre 2021
7 238
E: Impossible d'obtenir le verrou /var/lib/apt/lists/lock - open (11: Resource temporarily unavailable) 
E: Impossible de verrouiller le répertoire /var/lib/apt/lists/ 


Cette première erreur est due au fait qu'un gestionnaire de paquets est déjà lancé. Si par exemple ta logithèque ubuntu est lancée, utilise-la (ou si tu préfères utiliser apt-get, ferme la logithèque).

Le problème je pense que j'ai un proxy sur mon pc donc je peux pas télécharger un paquet par exemple.

Tu peux configurer le proxy pour apt :
https://www.commentcamarche.net/faq/4509-utiliser-un-proxy-pour-les-mises-a-jour

j'ai réussi à télécharger sipp (donc j'ai télécharger par la suite le paquet build-essential) sur mon pc

Normalement tu n'es rien sensé télécharger à la main, apt le fait pour toi... à condition qu'il soit bien configuré.

bash: uac_pcap.xml: Permission denied 


C'est probablement que ton programme essaye de lire dans le fichier uac_pcap.xml et qu'il n'a pas les droits pour. En l'occurrence vu ta commande, le problème c'est écrire dans ce fichier.

./sipp -sd uac_pcap > uac_pcap.xml 


Si on reprend on s'aperçoit que tu essayes d'écrire dans le répertoire dans lequel sipp est stocké. Pour peu que ce répertoire appartienne à root et que tu lances le programme en utilisateur, l'erreur vient de là. Il faut donc faire ta redirection pour écrire le fichier par exemple dans ton home directory (noté ~ sous linux).

Exemple :

./sipp -sd uac_pcap > ~/uac_pcap.xml 


Bonne chance
Merci bien pour votre aide .Ça marchait
Messages postés
30374
Date d'inscription
jeudi 12 mai 2005
Statut
Modérateur
Dernière intervention
3 décembre 2021
7 238
Parfait bonne continuation :-)