Incrémenter le nom d'une feuille dans une formule

Résolu/Fermé
Frédéric - 17 oct. 2012 à 20:41
 Frédéric - 18 oct. 2012 à 17:41
Bonjour,

Je débute sur VBA et je tourne en rond depuis un petit moment alors je sollicite votre aide.

J'ai besoin de copier coller une formule en incrémentant à chaque fois le nom d'une feuille afin de m'éviter (entre autre) un nombre incalculable de manipulations fastidieuses.
Exemple :

Il me faudrait pouvoir faire que :
La cellule A1 ait la formule =SOMME('S1'!$O$4:$T$5)
La cellule du dessous (A2) ait la formule =SOMME('S2'!$O$4:$T$5)

Mon objectif est de pouvoir incrémenter ainsi jusque =SOMME('S51'!$O$4:$T$5)
(Les S1,S2,S3...S51 ne sont ni plus ni moins que des onglets représentant des semaines où je vais collecter des informations de production de mon entreprise).

Et si je sollicite votre aide, c'est parce que je dois répéter cette manipulation sur une dizaine de colonnes...

Par avance Merci,

Frédéric





2 réponses

f894009 Messages postés 16750 Date d'inscription dimanche 25 novembre 2007 Statut Membre Dernière intervention 3 décembre 2022 1 660
18 oct. 2012 à 09:19
Bonjour,
un exemple en VBA:


Sub ecriture_formule()
  For x = 1 To 51
  Worksheets("feuil1").Range("A" & x).Formula = "=Sum(S" & x & "!O4:T5)"
  Next x
End Sub


Bonne suite
1
Bonjour

Un grand merci (vraiment) pour le code.
Je reste cependant curieux de savoir " pourquoi " l'apostrophe apparait toute seule dans la formule (celle qui permet de spécifier le nom d'une feuille).


Cordialement,

Frédéric
0