Criteres 2 colonnes et somme 3eme colonnes [Résolu/Fermé]

Signaler
-
 Nohas -
Bonjour,

J'ai un souci dans un fichier Excell 2003.
1. Je dois selectionner un critere1 sur une colonne1
2. si le critere1est vrai je choisi dans une colonne2 un critere2 et si ce dernier est vrai.
3. je fais la somme sur la colonne3

En résumé:
Si critere1.colonne1 est vrai
Alors sicritere2.colonne2 est vrai
alors somme colonne3
Finsi
Finsi

1 réponse

Messages postés
52736
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
26 novembre 2020
14 686
Il suffit d'utiliser la fonction SOMMEPROD

Ceux qui sont passés à Excel 2007 ou 2010 bénéficient de la fonction SOMME.SI.ENS

C'est bien, la retraite ! Surtout aux Antilles ... :-)
☻ Raymond ♂
Pourrais vous , svp , donner un exemple d'utilisation de SOMMEPROD
Exemple: Calculer le nb de statut "en cours"/clos par semaine
Semaine statut
38 clos
38 en cours
39 en cours
39 clos
39 en cours
Messages postés
25610
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 novembre 2020
5 620
bonjour

en attendant Raymond qui habite à l'autre bout de la terre, le bienheureux

si vous êtes avant 2007
et en supposant que les N° vont de A1 à A100 et les libellés de B1 à B100:
=SOMMEPROD((A1:A100=38)*(B1:B100="en cours"))
(note: les valeurs texte entre guillemets)
vous pouvez aussi écrire:
=SOMMEPROD((A1:A100=X1)*(B1:B100=X2))
en plaçant en X1 la valeur cherchée en A et en X2 la valeur cherchée en B
possible sur excel à partir de 2007 -et moins gourmand en capacité):
=NB.SI.ENS(A1:A100;X1;B1:B100;X2)

crdlmnt
Messages postés
52736
Date d'inscription
lundi 13 août 2007
Statut
Contributeur
Dernière intervention
26 novembre 2020
14 686
Merci, cher camarade ! tu te doutais que je comptais sur quelqu'un comme toi pour fournir les formules précises et exactes ...
Très bonne journée.
Messages postés
25610
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
26 novembre 2020
5 620
Salut mon ami Raymond.

je me doutais surtout que tu étais parti te mettre les doigts de pied en éventail pendant que nous ici, on est sous le déluge des résidus de l'ouragan Nadine que tu nous envoies!

bonnes Antilles;
Merci à vous pour cet aide précieuse
Passez une bonne journée