Fonction =Droite avec dates [Résolu/Fermé]

Signaler
Messages postés
102
Date d'inscription
dimanche 15 mars 2009
Statut
Membre
Dernière intervention
1 avril 2019
-
 CocoPL -
Bonjour,
Pour une raison que je ne comprends pas, Excel transforme une chaîne de caractères lorsque je fais une formule =droite(A1;4) !
J'explique : j'ai une colonne dates aux formats JJ/MM/AAAA ou JJ/AAAA dont je veux extraire l'année. Pour faire simple, j'effectue donc avec =Droite l'extraction des 4 derniers caractères mais, par exemple, la date 01/04/1972 devient 6420 !?
Existe-t-il un moyen pour que la machine n'essaie pas d'interpréter les caractères et affiche, simplement, gentiment, les 4 caractères ?

Merci !



3 réponses

Messages postés
11
Date d'inscription
jeudi 13 septembre 2012
Statut
Membre
Dernière intervention
26 septembre 2012
2
Bonjour,

Il s'agit d'un probleme de format.
Selectionner votre colonne et remplacer / par un .
Au lieu d'avoir le 01/04 vous allez avoir le 01.04

J espere que cela vous conviendra.

Cordialement
1
Merci

Quelques mots de remerciements seront grandement appréciés. Ajouter un commentaire

CCM 60511 internautes nous ont dit merci ce mois-ci

Vieille réponse, mais pas moins utile (si on se fiche de gérer le format date).
Merci beaucoup.
Messages postés
23594
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
25 octobre 2020
6 422
Bonjour,

Pour excel une date est nombre (affiché au format date).
En l'occurence 01/04/1972=26390.

Utilise plutôt =annee(A1)

eric
Messages postés
102
Date d'inscription
dimanche 15 mars 2009
Statut
Membre
Dernière intervention
1 avril 2019
1
Bonjour Eriiic,
J'y avais pas pensé... Ça marche très bien sûr mais le problème est que je n'ai pas des formats uniformes dans la colonne d'origine et du coup si je fais par exemple =année(A1) sur une cellule contenant seulement 1972, la formule répond "1905"...
Messages postés
25432
Date d'inscription
lundi 23 juillet 2007
Statut
Contributeur
Dernière intervention
25 octobre 2020
5 552
Bonjour

peut être une ruse:
=SI(NBCAR(A1)=4;A1;ANNEE(A1))
crdlmnt

ne sommes nous pas seuls à comprendre ce que l'on explique?
Messages postés
102
Date d'inscription
dimanche 15 mars 2009
Statut
Membre
Dernière intervention
1 avril 2019
1
Bonjour,
Ça marche ! Merci beaucoup