PROBLEME DE FORMULE

Résolu/Fermé
Signaler
Messages postés
3
Date d'inscription
mardi 3 juillet 2012
Statut
Membre
Dernière intervention
3 juillet 2012
-
Messages postés
3
Date d'inscription
mardi 3 juillet 2012
Statut
Membre
Dernière intervention
3 juillet 2012
-
Bonjour,

Je dois effectuer un tableau
7 colonnes
je dois multiplier SOIT A1*B1 SOIT C1*D1 SOIT E1*F1 DANS LA COLONNE G1
Pouvez-vous m'aider?
Merci

5 réponses

Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 304
Bonjour,

oui c'est tout à fait possible de vous aider. Mais il nous faudra plus d'informations.

Quelles sont les conditions pour multiplier A1 par B1 ou C1 par D1 etc. ?

Quel logiciel ? Version ?

Cordialement.
0
Messages postés
3
Date d'inscription
mardi 3 juillet 2012
Statut
Membre
Dernière intervention
3 juillet 2012

je travaille sous excel 2007. Il s'agit d'un devis. j'ai 7 colonnes. EN A1 quantité et en B1 prix. Idem pour C1*D1 et E1*F1. En G1 total de A1*B1 OU C1*D1 OU E1*F1 OU rien si rien.
Vu comment je m'explique il est facile de comprendre que c'est un vrai casse tête pour moi!!!
0
Messages postés
4239
Date d'inscription
lundi 20 avril 2009
Statut
Contributeur
Dernière intervention
12 septembre 2014
1 304
Ok. Mais quelles sont les conditions qui vont déterminer que ce sera A1*B1 ou C1*D1 ou E1*F1 en G1 ?

je suppose que ça se base sur une quantité remplie, donc la formule devrait être :
=SI(NON(ESTVIDE(A1));A1*B1;SI(NON(ESTVIDE(C1));C1*D1;SI(NON(ESTVIDE(E1));E1*F1;"")))

Cordialement.
0
Messages postés
24290
Date d'inscription
mardi 11 septembre 2007
Statut
Contributeur
Dernière intervention
25 janvier 2022
7 034
Bonjour tout le monde,

si on part du principe que seules 2 cellules sont remplies on peut simplifier en :
=A1*B1+C1*D1+E1*G1

ERIC
0
Messages postés
3
Date d'inscription
mardi 3 juillet 2012
Statut
Membre
Dernière intervention
3 juillet 2012

Mais ouiiiiii, ça marche. Je reviendrais certainement vous voir car comme vous l'avez remarqué (sans me le faire remarquer, et ça c'est gentil) je ne suis pas très douée avec excel.
Merci, merci, merci
Cordialement
Kangourette
0